Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Webcam e microfono
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Mon Feb 08, 2010 5:46 pm    Post subject: [RISOLTO] Webcam e microfono Reply with quote

Ciao, ho davvero bisogno per riuscire ad usare la mia Webcam, ho configurato il kernel (gentoo-source-2.6.32-r3) come indicato da questa guida: http://en.gentoo-wiki.com/wiki/Webcam

Code:
Device Drivers  --->
  Multimedia devices  --->
    <*> Video For Linux
    [ ]   Enable Video For Linux API 1 (DEPRECATED)
    [*]   Enable Video For Linux API 1 compatible Layer

Code:
Device Drivers  --->
  Multimedia devices  --->
    [*] Video capture adapters  --->
      [*]   V4L USB devices  --->
         <M>   Empia EM28xx USB video capture support
         <M>     Empia EM28xx ALSA audio module

Code:
Device Drivers  --->
  <*> Sound card support  --->
    <M>   Advanced Linux Sound Architecture  --->
       [*]   USB sound devices  --->
        <M>   USB Audio/MIDI driver

Code:
Device Drivers  --->
  Multimedia devices  --->
    [*] Video capture adapters  --->
      [*]   V4L USB devices  --->
        <*>   USB Video Class (UVC)

Ho installato Cheese ed effettivamente la cattura dell'immagine strafunziona, mi vedo, posso fare video e foto senza problemi. Ma il microfono no! Il punto è che si tratta della prima volta che ho a che fare con un microfono quindi non so proprio dove metter mano, il software di GNOME ha un sacco di voci che io, da ignorante, non sempre comprendo, vi allego un'immagine per mostravi cosa ho impostato:
http://img85.imageshack.us/img85/3819/screenshot1f.jpg
Non riesco nemmeno a registrare dal tool di gnome ovviamente...
La webcam è collegata via USB, mentre il microfono tramite il classico Jack collegato alla scheda audio; Però anche qui ammetto la mia ignoranza: devo collegarlo al "Line in" (azzurro) o al "Mic in" (rosa)?

Spero mi possiate aiutare perché ci tengo molto a poter usare la webcam :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)


Last edited by spillo on Tue Feb 09, 2010 11:35 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4673
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Feb 08, 2010 5:55 pm    Post subject: Reply with quote

microfono e webcam sono famiglie separate.
la tua webcam funziona. punto.

per il microfono devi utilizzare la scheda audio.
se l'audio normale non funziona, vuol dire che c'è un problema di driver.
altrimenti, dovrebbe essere sufficiente lanciare il servizio /etc/init.d/alsasound e vedere se si aggiusta da sè.

uno strumento semi manuale per configurare la scheda audio può essere il comando alsaconf.

per i volumi puoi usare un programma qualunque. quello di base è alsamixer, da terminale in linea di comando.
alsamixer ti permette di attivare tutti i canali che vuoi. credo che il microfono sia quello rosa. ma provali entrambi: non ci dovrebbero essere grossi pericoli di bruciare nulla.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Mon Feb 08, 2010 6:09 pm    Post subject: Reply with quote

Capito, quindi si tratta di lavorare solo sul microfono. Il tool del volume di gnome altro non è che un front grafico di alsamixer quindi è indifferente quale decida di usare...

L'audio normale comunque funziona, perfettamente direi, è la registrazione del microfono che non va, ma appunto, magari sono io che sbaglio...

EDIT: se collego il jack alla presa rosa (mi pare di aver letto che è quella giusta) effettivamente sento la mia voce dalle casse, ma nessun software mi registra alcunché...
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4673
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Feb 08, 2010 8:43 pm    Post subject: Reply with quote

io amo i tool in linea di comando.

arecord nomefile dovrebbe permetterti di testare il funzionamento del microfono.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Mon Feb 08, 2010 11:05 pm    Post subject: Reply with quote

Nada, parlo nel mic ma non registra alcunché, il file viene creato correttamente ma quando lo lancio comunque è muto...
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Feb 09, 2010 10:22 am    Post subject: Reply with quote

Giusto per scrupolo, immagino che si tratti di un Desktop PC.
Per caso hai un pannellino frontale? Tempo fa ebbi un problema proprio con il microfono, dovuto ad una stupida sbadataggine. Magari è solo una questione di Front Mic, o Mic.
Ovviamente, come hai potuto constatare il "buco" giusto è quello MIC (Rosa).

Anche io come gli altri ti suggerisco di smanettare con alsaconf e alsamixer. Hanno perfettamente ragione quando dicono che i problemi al 90% dei casi si risolvono con essi.

Per registrare puoi provare anche con rec e per ascoltare con play, entrambi facenti parte del pacchetto media-sound/sox.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Feb 09, 2010 10:50 am    Post subject: Reply with quote

Grazie anche a te per l'intervento, io non ho il pannellino frontale, mi collego direttamente dietro (ho una asus p5q e, di cui si trova anche la pagina di qwiki di gentoo :) ), tra l'altro vedo che abbiamo la stessa scheda audio e il kernel configurato allo stesso modo... ho provato anche a segnare il front mic ad ogni modo, ma nada... Entro in alsamixer, premo f4 e trovo ciò:
Code:

│                                                                                                                                                                                                             │
│     ┌──┐                ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐                ┌──┐                ┌──┐      ┌──┐      │
│     │▒▒│                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │      │
│     ├──┤      ┌──┐      └──┘      ├──┤      ├──┤      └──┘      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      └──┘      ├──┤      ┌──┐      ├──┤      ┌──┐      ├──┤      └──┘      │
│     │OO│      │OO│                │OO│      │OO│                │OO│      │OO│      │MM│      │MM│      │OO│      │OO│      │OO│                │OO│      │MM│      │MM│      │OO│      │OO│                │
│     └──┘      └──┘                └──┘      └──┘                └──┘      └──┘      └──┘      └──┘      └──┘      └──┘      └──┘                └──┘      └──┘      └──┘      └──┘      └──┘                │
│     100               100<>100   79<>79    97<>97   100<>100  100<>100    100        97      97<>97   100<>100  100<>100   81<>81    33<>33   100<>100              100               100<>100    0<>0      │
│  < Master  >Headphone    PCM      Front   Front Mic Front Mic Surround   Center      LFE      Side      Line       CD        Mic    Mic Boost  S/PDIF   S/PDIF De   Beep      Mono    Analog Mi   HDMI   


il che a me, da ignorante, fa pensare che sia tutto al massimo e che dovrebbe funzionarmi, tant'è che se soffio nel microfono effettivamente sento il suono delle casse, solo che non registro una mazza... se avvio alsaconf mi ripristina i valori di default (e il mic va a zero!!!!), ma non cambia il fatto che non riesco nel mio intento, ovvero registrare la mia voce:

Code:
│                                                                                                                                                                                                          │
│   ┌──┐                ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐      ┌──┐                ┌──┐                ┌──┐      ┌──┐     │
│   │  │                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │  │                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │  │                │▒▒│      │  │      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │  │      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   │▒▒│                │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │▒▒│      │  │      │  │      │▒▒│      │▒▒│      │  │      │▒▒│      │▒▒│                │▒▒│                │▒▒│      │  │     │
│   ├──┤      ┌──┐      └──┘      ├──┤      ├──┤      └──┘      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      ├──┤      └──┘      ├──┤      ┌──┐      ├──┤      ┌──┐      ├──┤      └──┘     │
│   │OO│      │OO│                │OO│      │OO│                │OO│      │OO│      │MM│      │MM│      │OO│      │OO│      │MM│                │OO│      │MM│      │MM│      │OO│      │OO│               │
│   └──┘      └──┘                └──┘      └──┘                └──┘      └──┘      └──┘      └──┘      └──┘      └──┘      └──┘                └──┘      └──┘      └──┘      └──┘      └──┘               │
│    79               100<>100   79<>79   100<>100  100<>100  100<>100    100        0        0<>0    100<>100  100<>100    0<>0     33<>33   100<>100              100               100<>100    0<>0     │
│< Master  >Headphone    PCM      Front   Front Mic Front Mic Surround   Center      LFE      Side      Line       CD        Mic    Mic Boost  S/PDIF   S/PDIF De   Beep      Mono    Analog Mi   HDMI

_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Feb 09, 2010 11:02 am    Post subject: Reply with quote

Non solo abbiamo la stessa scheda audio, mi sembra di capire anche la stessa scheda madre (io ho la P5Q Pro).
Mi è parso di notare nel tuo alsamixer che c'è sia Mic che Front Mic. Dentro alsamixer se premi F4, dovresti avere qualche controllo del tipo "Input Source". E quello dovrebbe essere lo switch fra Front Mic e Mic. Da quello che riporti non riesco a capire benissimo a causa della sovrapposizione di alcune scritte. Anche se non hai il pannellino frontale, se hai selezionato Front Mic, non ti funzionerà mai il microfono. Io chiedevo casomai potessi fare una prova.
Per quanto riguarda il fatto che ti viene rimesso il volume a 0, controlla di avere
RESTORE_ON_START="yes" e SAVE_ON_STOP="yes" in /etc/conf.d/alsasound.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Feb 09, 2010 11:35 am    Post subject: Reply with quote

Scusami per il lungo codice, probabilmente non me ne sono accorto perché ho lo schermo grande...

Comunque sì, smanettando e rismanettando su alsamixer effettivamente ora funziona :D e ho pure capito un po' meglio il funzionamento di alsamixer stesso... Grazie mille :)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Tue Feb 09, 2010 11:41 am    Post subject: Reply with quote

È stato un piacere! Ora anche tu diventerai un sostenitore accanito di alsamixer!!!! :P
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum