Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hard disk con settori danneggiati
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Tue Feb 02, 2010 4:58 pm    Post subject: hard disk con settori danneggiati Reply with quote

salve,
un mio amico mi ha dato uno dei suoi portattili dato che il mio non ce' piu. allora per vedere se funzionava bene gli ho installato ubuntu come prima distribuzzione di partenza che poi da li installare gentoo. ma quando sono arrivsto sul desktop un messaggio di errore i dischi hanno molti settori danneggiati, pero l'installazione di ubuntu e andata ha buon fine ed ho provato per qualche giorno per vedere se non subbentravano complicazzioni. allora decisi di riavviare dalla liveusb per dimmezare la partizioni di ubuntu creandone una per gentoo. il disco e di 120GB e dedicai ha gentoo 50Gb
e cosi fece.. ha vedere sembrata tutto ok cosi ho riavviato per andare ha montare tutto per inizziare l'installazione di gentoo nel mio nuovo pc. ma nulla da fare il pc ha cominciato ha non caricarsi piu ha metterci una vita per avviare ubuntu poi la cosa piu grave che ora nemmeno da liveusb parte piu riamane una schermata nera con un trattino lampeggiante sulla sinistra della videata nera. ho provato anche con gentoo da liveusb ma la stessa identica cosa
cioe', parte il liveusb sul subito, faccio invio parte con le 4 righ di trattini poi schermata nera...
ho provato anche ha togliere l'hard disk ma la stessa cosa non parte nulla, il dvd e danneggiato dunque la usb e la mia unica scelta di installazione oppure da ubuntu ma se non dimezzo la partizione come faccio ad installare gentoo se ci sono altri metodi di partizionamento da poter fare direttamente da ubuntu seza riavviare, sew potete darmi qualche conscilgio
grazie.. :? :?
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
spillo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Feb 2008
Posts: 125
Location: S.Angelo Lodigiano

PostPosted: Tue Feb 02, 2010 11:56 pm    Post subject: Reply with quote

il disco potrebbe non essere danneggiato, la versione di gnome-disk-utility è buggata, dà sempre errore ;)
_________________
spillo

GnuLinuxExperience

Il mio blog! :)
Back to top
View user's profile Send private message
mattylux
Apprentice
Apprentice


Joined: 19 Jul 2008
Posts: 240
Location: bologna

PostPosted: Wed Feb 03, 2010 11:20 am    Post subject: Reply with quote

infatti gnome-disk-utility lo disinstallato ma il problema persiste ancora, tutto e iniziato con gparted avevo riavviato il pc e fatto partire la liveusb poi ho ridotto la partizione dedicando lo spazio ha gentoo. pero ha fatto tutto molto veloce, come ho dato l'ok della conferma a gparted, mi ha fatto vedere la partizione free, di 50GB allora ho pensato sara tutto apposto allora ho riavviato il pc e da li e successo tutto il casino e non mi ha nemmeno cambiato nula sul disco oltre che andare ad una lentezza esagerata. da liveusb neanche a parlarne, come ho gia scritto, si blocca subito e schermata nera invece in altri pc funziona perfettamente.
poi aggiungo che quando accendo il pc, devo premere un tasto qualsisi perche se no suona, beep,beep,beep per qualce secondo prima di fare partire il grub di avvio del sistema. :cry:
non so proprio che fare secondo me e proprio l hard disk che se ne sta andando...
se qualche altro di voi puo darmi qualche conscilgio anche di altri metodi di partizionamento per poter installare gentoo comunque..
saluti
_________________
persempre gentoo
il mio progetto in fase di lavoro
Http://stradedicarta.netsons.org
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Thu Feb 04, 2010 2:11 pm    Post subject: Reply with quote

Io uso
Code:
# emerge smartmontools

quindi
Code:
# smartctl --test=long /dev/sdX

Ci impiaga un po': (per es. sul mio hdd da 500 GiB mi indica 112 minut)i.
Quindi per leggere i dati completi
Code:
# smartctl --all /dev/sdX

comunque...
Code:
# man smartctl

per ogni info.

Riguardo i 3 beep della tastiera... non so. se pensi possa essere l'hdd controllerei che le connessioni interne siano a posto (i cavi ide o sata ben inseriti).
Farei anche un memory test.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum