Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Timout on server workgroup - Dolphin - KDE SC 4.3.5 - SAMBA
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
NismoC32
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 202

PostPosted: Sun Jan 31, 2010 1:39 am    Post subject: Timout on server workgroup - Dolphin - KDE SC 4.3.5 - SAMBA Reply with quote

After updating from KDE SC 4.3.4 to 4.3.5 the Samba function in KDE is no longer working.

When I try to browse my Samba Shares in Dolphin or Krusader I find the workgroups available om my net,
but when I try to browse into one of them nothing happens for a while and I then get an error message saying:
Timout on server "name of workgroup".

I'm using samba ver. 3.4.5

My emerge -info :
Quote:
wstation # emerge --info
Portage 2.2_rc62 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.11-r1, 2.6.32-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.32-gentoo-r3-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.0.1
Timestamp of tree: Sat, 30 Jan 2010 11:45:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 4.0_p37
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python: 2.6.4-r1, 3.1.1-r1
dev-python/pycrypto: 2.1.0
dev-util/ccache: 2.4-r8
dev-util/cmake: 2.8.0-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.6.0-r1
sys-apps/sandbox: 2.2
sys-devel/autoconf: 2.13, 2.65
sys-devel/automake: 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils: 2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6b
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -msse3 -fweb -frename-registers"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=k8 -pipe -msse3 -fweb -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi akonadi alsa amd64 apm berkdb bitmap-fonts bluetooth branding browserplugin bzip2 cairo camera cddb cdr cli consolekit cpudetection cracklib crypt cups cxx dba dbus desktopglobe dri dts dvd dvdr dvdread eds emboss encode evo fam ffmpeg firefox flac fuse gd gdbm gif glitz gpm gstreamer hal htmlhandbook iconv id3tag ieee1394 ipv6 jpeg jpeg2k kde kde4 lcms libnotify lm_sensors logitech-mouse lzma mad melt mikmod mmx mmxext mng modules mozilla mozsvg mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre pdf perl phonon pic png policykit ppds pppd python qt3support qt4 quicktime rar readline reflection samba sdl semantic-desktop session smp spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora thumbnail thunar tiff truetype truetype-fonts type1-fonts udev unicode usb utf8 v4l v4l2 vdpau vorbis webkit x264 xcomposite xml xorg xprint xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2 canon kodak fuji panasonic polaroid kodak" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="mceusb2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nvidia vdpau dri"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

wstation #

Samba works fine on my HTPC/XBMC.

Any idea why this happens ?


Last edited by NismoC32 on Sun Jan 31, 2010 5:01 am; edited 1 time in total
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 679

PostPosted: Sun Jan 31, 2010 4:21 am    Post subject: Reply with quote

Does it work ok when you mount it in the command line? eg 'mount -t cifs \\\\192.168.1.14\\share /mnt/samba_share'
Back to top
View user's profile Send private message
NismoC32
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 202

PostPosted: Sun Jan 31, 2010 4:56 am    Post subject: Reply with quote

Yes, it asks for a password and since I don't use one I just hit enter and it is mounted.
Back to top
View user's profile Send private message
NismoC32
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 202

PostPosted: Mon Feb 01, 2010 12:09 pm    Post subject: Reply with quote

I just found out that the same problem exists on my fileserver too,
My fileserver is also powered by Gentoo but in stable mode.
The samba version on my fileserver is 3.0.37 and KDE SC 4.3.3

I don't understand whats happened other than it has to have happened about the same
time as KDE SC 4.3.5 entered portage in unstable form.
I can't remember any other updates/changes that can have caused this problem.

Mounting my samba shares manually in a CLI and even entering them in fstab works fine,
and my XBMC Live PC has no problem accessing the smb shares.

I'm taking my laptop home from work today, It has Sabayon installed on it.
Just to see if the same problem exists there too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum