Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[rdesktop] Probleme de clavier
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Fri Jan 29, 2010 8:48 am    Post subject: [rdesktop] Probleme de clavier Reply with quote

Bonjour,

J'utilise rdesktop pour me connecter à un windows distant. Ca marche plus tôt bien mais lorsque j'essaye de taper des lettres accentués ou autres caractères spéciaux, windows affiche n'importe quoi et dans la console j'ai le warning suivant :
Quote:
WARNING: No translation for (keysym 0xfe51, dead_acute


D'après cette page https://bugs.launchpad.net/ubuntu/+source/rdesktop/+bug/404380, il ne faudrait pas compiler rdesktop avec le "raw keyboard patch"
Quote:
This problem does not happen if I compile without the raw keyboard patch.


Mais je n'ai pas d'use flag pour désactiver ce patch :
equery u =net-misc/rdesktop-1.6.0 wrote:

- - ao : Use libao audio output library for sound playback
- - debug : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
+ + ipv6 : Adds support for IP version 6
- - oss : Adds support for OSS (Open Sound System)


Vous avez une idée de comment je peux faire ?

Merci d'avance
Back to top
View user's profile Send private message
RaX
Apprentice
Apprentice


Joined: 16 Aug 2007
Posts: 166

PostPosted: Fri Jan 29, 2010 4:59 pm    Post subject: Reply with quote

Gentoo n'a pas l'air de compiler rdesktop avec ce patch.

Code:

# Automagic dependency on libsamplerate
        epatch "${FILESDIR}"/${P}-sound_configure.patch
        # Fix --enable-smartcard logic
        epatch "${FILESDIR}"/${P}-smartcard_configure.patch
        eautoreconf


Pour ton problème je ne peux pas plus t'aider je n'utilise pas.

Bonne chance et bon week-end.
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Mon Feb 15, 2010 7:44 pm    Post subject: Reply with quote

Etrange tout ça. Personnellement je n'ai aucun problème.

Quelle commande/config utilises tu pour lancer le bouzon?
Perso je fais un
Code:
rdesktop -k fr-be ma.machine.a.moi
et tout roule
Config du sys en utf8 peut-etre? Quid de la valeur de $LANG?

J'espère ne pas dire trop de bêtises :p
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Mon Feb 15, 2010 9:58 pm    Post subject: Reply with quote

Ça fait longtemps que je n'ai pas eu besoin de me reconnecter en rdesktop.

Je ne suis pas devant mon pc mais j'utilise la commande suivante :
Code:
rdesktop -g 80% ip.remote


Je pense que mon système est en full UTF-8 (mais j'en suis pas complètement sure).

Je regarderai ce soir.

Merci de vos réponses.
Back to top
View user's profile Send private message
Gronono
Tux's lil' helper
Tux's lil' helper


Joined: 12 Sep 2007
Posts: 99
Location: Noumea, NC

PostPosted: Tue Feb 16, 2010 10:28 pm    Post subject: Reply with quote

Bonjour,

Je confirme je suis bien en UTF-8 : LANG=fr_FR.UTF-8
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum