Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
access VirtualBox client running in NAT mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Thu Jan 28, 2010 6:47 pm    Post subject: access VirtualBox client running in NAT mode Reply with quote

I need to access VirtualBox client (Windows XP) - VirtualBox client network is setup in NAT mode

Gentoo box (10.10.0.1 - gateway) IP: 10.10.0.2
VirtualBox NAT (192.168.56.1 - vboxnat0), Windows XP (10.0.2.2 - gateway) IP: 10.0.2.15

How can I access Windows inside (IP 10.0.2.15) - I need mount Windows XP directory with samba.
I can mount Windows XP directory via samba when VirtualBox client network is in "Bridge Mode" but not in "NAT"
_________________
#Thelma
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Thu Jan 28, 2010 8:00 pm    Post subject: Reply with quote

Hi,

I think you can use the Shared Folders Functionality only in this case.
_________________
You deserve free software!
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2571
Location: Edmonton, AB

PostPosted: Thu Jan 28, 2010 8:11 pm    Post subject: Reply with quote

ursusca wrote:
Hi,

I think you can use the Shared Folders Functionality only in this case.

I think I could try port forwarding, following instruction from here:
http://sk.c-wd.net/wp/2008/08/17/virtualbox-port-forwarding-with-windows-host/

but I just created another network interface: type "bridge"
_________________
#Thelma
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Sun Jan 31, 2010 9:48 pm    Post subject: Reply with quote

Hi,

I think you don't need to modprobe the vboxnetflt kernel module in this case. And try to configure NAT in you /etc/conf.d/net file.
_________________
You deserve free software!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum