Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[xfce4.6] J'ai quelques petites erreurs
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Tue Jan 26, 2010 11:48 am    Post subject: [xfce4.6] J'ai quelques petites erreurs Reply with quote

Le problème est que j'ai à la fois de l'anglais et du français.
Par exemple dans la fenetre de wicd la barre d'outils m'affiche Réseau Disconnect All Refresh Preferences About Quit puis en dessous j'ai choisir parmi les réseaux suivants et tout le reste est en français.

Ensuite certaines fenetres ont le bouton en bas à droite qui dit Fermer et d'autres qui dit Close
Par exemple si je tape dans un terminal
Code:
xfce4-about

La fenetre qui s'ouvre est en francais alors que la fenetre suivant est en anglais avec des messages d'erreur
Code:
$ xfce4-appearance-settings

(xfce4-appearance-settings:3141): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Xfce/LastCustomDPI" does not exist on channel "xsettings"


Lorsque je lance un startxfce4 dans le shell, j'ai plein de messages d'erreur avec xfconf-WARNING ou GLib-GLobject-CRITICAL

Pourtant j'ai mis le systeme en francais
Code:
$ locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=


Et j'ai compilé xfce-meta avec les uses session -minimal
_________________
Gentoo rocks
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Tue Jan 26, 2010 11:59 am    Post subject: Reply with quote

Des erreurs ou juste des traductions manquantes, car non traduites en FR ? ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Tue Jan 26, 2010 1:44 pm    Post subject: Reply with quote

C'est des erreurs dont l'une des conséquences est au niveau de la traduction.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Tue Jan 26, 2010 1:57 pm    Post subject: Reply with quote

Tiens j'ai le même comportement pour les traductions:
Quote:

Ensuite certaines fenetres ont le bouton en bas à droite qui dit Fermer et d'autres qui dit Close
Par exemple si je tape dans un terminal
Code:
xfce4-about

La fenetre qui s'ouvre est en francais alors que la fenetre suivant est en anglais avec des messages d'erreur
Code:
$ xfce4-appearance-settings

(xfce4-appearance-settings:3141): xfconf-WARNING **: Error check failed at xfconf_channel_get_internal():390: Property "/Xfce/LastCustomDPI" does not exist on channel "xsettings"

Mais sans le message d'erreur.

à y regarder de plus prêt. Le paquet xfce-utils (pour xfce4-about) installe un fichier de localisation: (/usr/share/locale/fr/LC_MESSAGES/xfce-utils.mo) mais pas xfce4-settings (pour xfce4-appearance-settings).
Pourtant le fichier fr.po est bien présent dans le paquet source (et la traduction semble complète). Je penche donc pour un problème à l'installation.

Que nous dit bugzilla ?
--> https://bugs.gentoo.org/show_bug.cgi?id=298460.

Bruno
Back to top
View user's profile Send private message
Fenril
Apprentice
Apprentice


Joined: 16 May 2009
Posts: 209

PostPosted: Tue Jan 26, 2010 9:47 pm    Post subject: Reply with quote

J'ai eu le même problème lors de la dernière mise à jour de Xfce, pour xfce4-mouse-settings et d'autres composants Xfce (mais pas tous) qui se sont retrouvés en anglais. Je n'ai jamais cherché à régler ce problème, s'il s'agit bien d'un problème, en même temps, je n'ouvre pas sans arrêt ces programmes donc bon. peut-être qu'on retrouvera une traduction 100% française à la prochaine MAJ.

Property "/Xfce/LastCustomDPI" me fait plus penser à une erreur au niveau de xorg ou du pilote d'affichage, pas à un problème de traduction.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum