Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Python]Python 3...2... 1,0 feu!!! [convergera vers résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Sun Jan 24, 2010 7:38 pm    Post subject: [Python]Python 3...2... 1,0 feu!!! [convergera vers résolu] Reply with quote

Ben je suis perdu dans ce monde pythonesque !!

voyez vous même :
Code:
# python-updater
 * Starting Python Updater from 3.1 to 2.6 :
^C


pourtant :
Code:
eselect python list
Available Python interpreters:
  [1]   python2.6 *
  [2]   python3.1


mais mais que se passe t-il? :/ alors version3 ou version 2, telle est la question !
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo


Last edited by Mickael on Mon Jan 25, 2010 12:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Jan 24, 2010 10:31 pm    Post subject: Reply with quote

Rien ne fonctionne avec Python 3.x actuellement, donc reste plutôt sur une version en 2.x si tu ne veux pas tout casser. :)
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Jan 24, 2010 10:47 pm    Post subject: Reply with quote

geekounet wrote:
Rien ne fonctionne avec Python 3.x actuellement, donc reste plutôt sur une version en 2.x si tu ne veux pas tout casser. :)

Bah portage si :mrgreen:

Mais bon, c'est vrai qu'il reste plein de softs pythons qui ne sont pas portés par ailleurs...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Jan 25, 2010 7:48 am    Post subject: Reply with quote

Humm, un duel à la cour se profile; le procureur annonce que tout est bancale alors que l'avocat commis d'office essaye de trouver encore un peu d'espoir... MOOOONNNN DIEUUU ça va pas bien moi ;)

Sinon, c'est bien ce que je pensais, mise à part portage, le reste est encore (c'est pas du tout péjoratif) sous 2.6 (moi aussi d'ailleurs!). Donc on va attendre un log d'alerte lors des prochaines mise à jour.

Je mettrai un résolu les enfants lorsque le passage à 3 sera obligatoire!

Merci.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Jan 25, 2010 8:57 am    Post subject: Reply with quote

Mickael wrote:
Je mettrai un résolu les enfants lorsque le passage à 3 sera obligatoire!


Étant moi même développeur Python/Zope/Plone, je peux te dire que ça sera pas avant plusieurs d'années. Dans beaucoup de projets c'est un cauchemar d'upgrader sur Python 3.x tellement il y a de changements. Déjà que jusqu'à très récemment, Plone 3 ne tournait encore que sur Python 2.4 maximum... (mais le 4 qui vient de sortir supporte le 2.6 si j'ai bien suivi).
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Jan 25, 2010 12:56 pm    Post subject: Reply with quote

geekounet wrote:
Mickael wrote:
Je mettrai un résolu les enfants lorsque le passage à 3 sera obligatoire!


Étant moi même développeur Python/Zope/Plone, je peux te dire que ça sera pas avant plusieurs d'années. Dans beaucoup de projets c'est un cauchemar d'upgrader sur Python 3.x tellement il y a de changements. Déjà que jusqu'à très récemment, Plone 3 ne tournait encore que sur Python 2.4 maximum... (mais le 4 qui vient de sortir supporte le 2.6 si j'ai bien suivi).


Te plein pas, ma carte DSP utilisée pendant ma thèse utilisait python 2.1 ou 2.2, m'enfin c'était du python c'est déjà ça !!
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum