Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wicd not Working Properly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
IcEonFirE
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 174

PostPosted: Sat Jan 23, 2010 2:57 am    Post subject: Wicd not Working Properly Reply with quote

Hi
I have problem with wicd-client, the tray icon appears at session startup. When I try to scan for wireless network, the context menu remains at Scanning...
I am even not able to change Preference menu, button has no effect. So I quit the tray icon and start wicd-client using console as root, here's the output:

libnotify-Message: Unable to get session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
libnotify-Message: Unable to get session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Could not initalize pynotify
Has notifications support False
Loading...
Connecting to daemon...
Can't connect to the daemon, trying to start it automatically...
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
GConf Error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
Connected.
Done loading.
warning: ignoring exception org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

Here's also the output of wicd-curses:

Can't connect to the daemon, trying to start it automatically...
Traceback (most recent call last):
File "/usr/lib/wicd/wicd-curses.py", line 1034, in <module>
setup_dbus()
File "/usr/lib/wicd/wicd-curses.py", line 1024, in setup_dbus
dbus_ifaces = dbusmanager.get_dbus_ifaces()
File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 36, in get_dbus_ifaces
return DBUS_MANAGER.get_dbus_ifaces()
File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 62, in get_dbus_ifaces
if not self._dbus_ifaces: connect_to_dbus()
File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 48, in connect_to_dbus
return DBUS_MANAGER.connect_to_dbus()
File "/usr/lib/python2.6/site-packages/wicd/dbusmanager.py", line 79, in connect_to_dbus
proxy_obj = self._bus.get_object("org.wicd.daemon", '/org/wicd/daemon')
File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
follow_name_owner_changes=follow_name_owner_changes)
File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
self._named_service = conn.activate_name_owner(bus_name)
File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
self.start_service_by_name(bus_name)
File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
'su', (bus_name, flags)))
File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 622, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.wicd.daemon was not provided by any .service files

and the output of wicd -foe

---------------------------
wicd initializing...
---------------------------
wicd is version 1.6.2.2 463
setting backend to external
trying to load backend external
successfully loaded backend external
trying to load backend external
successfully loaded backend external
Couldn't detect a wireless interface.
setting wireless interface wlan0
automatically detected wired interface eth0
setting wired interface eth0
setting wpa driver wext
setting use global dns to False
setting global dns
global dns servers are None None None
domain is None
search domain is None
setting automatically reconnect when connection drops True
Setting dhcp client to 0
Wireless configuration file found...
Wired configuration file found...
chmoding configuration files 0600...
chowning configuration files root:root...
Using wireless interface...wlan0
Using wired interface...eth0
hidden

I reinstalled wicd as mentioned on post https://forums.gentoo.org/viewtopic-t-763388-highlight-wicdclient+dbus.html, unfortunetly, it worked only once, the problem reappeared on my next system startup

Any idea please ?
Thanks in advance
Back to top
View user's profile Send private message
e3k
Apprentice
Apprentice


Joined: 01 Oct 2007
Posts: 167
Location: Slovakia

PostPosted: Tue Jan 26, 2010 5:58 pm    Post subject: Reply with quote

as sugested here http://vavai.net/2009/09/07/solved-could-not-connect-to-wicds-d-bus-interface/
add wicd to boot runlevel:
Code:
rc-update -a wicd boot
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum