Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge rhythmbox fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
arifmamdani
n00b
n00b


Joined: 11 Jun 2002
Posts: 21
Location: St. Paul, MN

PostPosted: Mon Jul 15, 2002 3:31 am    Post subject: emerge rhythmbox fails Reply with quote

Trying to emerge rhythmbox on a fairly new Gnome2 installation, and I'm getting this as an error -- anyone have any idea how to resolve this?
Quote:
/usr/lib/libquicktime.so: undefined reference to `raw1394_errcode_to_errno'
collect2: ld returned 1 exit status
make[2]: *** [lavplay] Error 1
make[2]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.0-r2/work/mjpegtools-1.6.0/lavtools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.0-r2/work/mjpegtools-1.6.0'
make: *** [all] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line -95, Exitcode 2
!!! (no error message)

!!! emerge aborting on /usr/portage/media-video/mjpegtools/mjpegtools-1.6.0-r2.ebuild .


any help would be appreciated.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18350

PostPosted: Mon Jul 15, 2002 4:53 am    Post subject: Reply with quote

Code:
# emerge -s rhythm
[ Results for search key : rhythm ]
[ Applications found : 1 ]
 
*  media-sound/rhythmbox [ Masked ]
You did know it was masked, no?
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
arifmamdani
n00b
n00b


Joined: 11 Jun 2002
Posts: 21
Location: St. Paul, MN

PostPosted: Mon Jul 15, 2002 5:02 am    Post subject: yup, knew it was masked, tried anyway Reply with quote

Yeah, saw the mask, but figured I'd try emerging it anyway. . .
thanks

kanuslupus wrote:
Code:
# emerge -s rhythm
[ Results for search key : rhythm ]
[ Applications found : 1 ]
 
*  media-sound/rhythmbox [ Masked ]
You did know it was masked, no?
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18350

PostPosted: Mon Jul 15, 2002 5:08 am    Post subject: Re: yup, knew it was masked, tried anyway Reply with quote

arifmamdani wrote:
Yeah, saw the mask, but figured I'd try emerging it anyway. . .
thanks
Masked ebuilds can be emerged, you just have to edit them properly.
I've never done it yet, so can't help you there.
_________________
The media sells it and you live the role.
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Mon Jul 15, 2002 2:16 pm    Post subject: Reply with quote

Don't waste your time with rhythmbox. It's just not usable yet. Rhythmbox 0.2.1 freezes when I feed to it my music folders. And the cvs snapshot from today which I wanted to try out crashes whenever I press 'play'. The GUI looks nice (like that of iTune from Apple) but it can't play music yet ;-)

Cheers,
Andreas
Back to top
View user's profile Send private message
sisob
Apprentice
Apprentice


Joined: 28 Jun 2002
Posts: 274
Location: Ireland

PostPosted: Mon Jul 15, 2002 3:32 pm    Post subject: Reply with quote

To run rb - you need:

Rhythmbox and monkeysound from cvs.
Mad mp3 decoder
gstreamer 0.4 configured in such a way that it will actually play
mp3's with the gst-player program.

NOTHING ELSE IS LIKELY TO WORK

especially not the latest tar.gz version of rb

It's no small challenge - I've gotten everything except gstremer working - if i get it going i'll let y'all know
_________________
Mark Finlay - Gnome Hacker of Sorts
Come join me on the Gnome User's Forum
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Mon Jul 15, 2002 3:41 pm    Post subject: Reply with quote

sisob wrote:

gstreamer 0.4 configured in such a way that it will actually play
mp3's with the gst-player program.


What do you mean? The mad plugin and a working osssink?
Back to top
View user's profile Send private message
orangegoblin
n00b
n00b


Joined: 12 Jul 2002
Posts: 5

PostPosted: Mon Jul 15, 2002 6:13 pm    Post subject: quicktime error Reply with quote

it seems that the mjpegtools ebuild has got a problem with some quicktime libraries. try to compile mjpegtools without quicktime support.
Code:

USE="-quicktime $USE" emerge mjpegtools

then try to emerge rhythmbox.
hope this helps. :)
it worked well for me, of course without the ability to read quicktime files.

greets,
orangegoblin
Back to top
View user's profile Send private message
arifmamdani
n00b
n00b


Joined: 11 Jun 2002
Posts: 21
Location: St. Paul, MN

PostPosted: Mon Jul 15, 2002 10:39 pm    Post subject: Re: quicktime error Reply with quote

orangegoblin wrote:
it seems that the mjpegtools ebuild has got a problem with some quicktime libraries. try to compile mjpegtools without quicktime support.
Code:

USE="-quicktime $USE" emerge mjpegtools

then try to emerge rhythmbox.
hope this helps. :)
it worked well for me, of course without the ability to read quicktime files.

greets,
orangegoblin


I tried that last night, and it seemed to be getting hung up on lavplay. I'll try it again later and post the full error message if it'd be helpful to anyone, though at this point, while I'm interested in continuing to try to figure this out, I'm also more than willing to wait till it's totally ready for prime time.
Back to top
View user's profile Send private message
arifmamdani
n00b
n00b


Joined: 11 Jun 2002
Posts: 21
Location: St. Paul, MN

PostPosted: Mon Jul 15, 2002 10:59 pm    Post subject: ooops... no it dies on gst-plugins Reply with quote

just tried it again, here's what I get now:
Code:
gstflacenc.c:184: `metadata' undeclared (first use in this function)
make[3]: *** [libgstflac_la-gstflacenc.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/gst-plugins-0.4.0/work/gst-plugins-0.4.0/ext/flac'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gst-plugins-0.4.0/work/gst-plugins-0.4.0/ext'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gst-plugins-0.4.0/work/gst-plugins-0.4.0'
make: *** [all] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 65, Exitcode 2
!!! (no error message)

!!! emerge aborting on  /usr/portage/media-libs/gst-plugins/gst-plugins-0.4.0.ebuild .

this is after removing quicktime from USE
-arif
Back to top
View user's profile Send private message
Spark
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 87

PostPosted: Tue Jul 16, 2002 3:04 am    Post subject: a little bit offtopic Reply with quote

Can somebody tell me, if this application is really exciting? ;)
I mean, is it really usefull to manage and play my music files or is it more usefull for people who do a lot with ripping and burning audio CD's? I might rip some CD's but I got no burner, so I'm wondering if I should look forward to this app to become usefull or if it's not of interest for me. :) I got a version working but it crashed when giving a folder as lib source so I could only add single mp3 files and then play them, not really comfortable.
Will it be more interesting than xmms for simple audiofile managing and playing? I don't know iTunes, so the constant references to this app don't help me. :)
Back to top
View user's profile Send private message
credmp
Apprentice
Apprentice


Joined: 02 Jul 2002
Posts: 207
Location: Netherlands

PostPosted: Tue Jul 16, 2002 6:27 am    Post subject: Reply with quote

Another interesting app might be apollo... not as spiffy gui as rb, but still ;)

-- Arjen
Back to top
View user's profile Send private message
dvNuLL
n00b
n00b


Joined: 17 Apr 2002
Posts: 56
Location: Seattle

PostPosted: Tue Jul 16, 2002 9:19 am    Post subject: Rhythmbox Reply with quote

Okay first off u need to compile gst-plugins withough flac and mjpegtools

Once you have done that you need to get the MAD mp3 decoder ( http://www.mars.org/home/rob/proj/mpeg/ )

Once you have done that get monkey-sound and rhythmbox from gnome cvs

That will compile.

One more thing. For gst-plugins to compile make sure you dont have a config.h file in /usr/include/aviplay

dvNuLL
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Tue Jul 16, 2002 1:16 pm    Post subject: Reply with quote

Okay, now I have Rhythmbox 0.3.0 running. I used the BRANCH-RELEASE-0_4_0 of gstreamer and gst-plugins (without mpjegtools support), and cvs head for monkey-sound and rhythmbox. It even plays sounds. Rhythmbox needed around 6-7 minutes to build it's music database. It saves the metainfo in some xml file, which seems to lead to very bad performance and scalability. Startup time for me is around 5 minutes! Unusable. Now I know why they haven't made a release since months ;-)
Back to top
View user's profile Send private message
crevette
Guru
Guru


Joined: 21 May 2002
Posts: 543
Location: Chrooted in Nice, France

PostPosted: Sun Aug 11, 2002 7:41 am    Post subject: problems too Reply with quote

I tried to compile monkey-media (0.5) and rhythmbox (0.3) from www site's tarball...
monkey-media compile successfully but when i do a configure for rhythmbox, I receive this message.
>
monkey-media >= 0.5.0... Package monkey-media was not found in the pkg-config search path.
Perhaps you should add the directory containing `monkey-media.pc'
to the PKG_CONFIG_PATH environment variable
>

How can I add this variable

Thanks
_________________
http://www.mille-mathias.info
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Sun Aug 11, 2002 7:45 am    Post subject: Re: problems too Reply with quote

How about:
Code:
$ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/path/to/monkey-media.pc

P.S. Did you do something strange with your post, like moving it around or something? I tried to reply to it and got some strange phpBB errors, and was wondering if I should report them.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
crevette
Guru
Guru


Joined: 21 May 2002
Posts: 543
Location: Chrooted in Nice, France

PostPosted: Sun Aug 11, 2002 8:08 am    Post subject: Hoooups (in french) Reply with quote

Yes My post was moving around because, i realize that instead of reply I click on new topic button....
so I delete it and I reply to this post
sorry
:oops: :oops: :oops: :oops: :oops: :oops:


thanks for your help
_________________
http://www.mille-mathias.info
Back to top
View user's profile Send private message
Spark
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2002
Posts: 87

PostPosted: Sun Aug 11, 2002 9:06 am    Post subject: Reply with quote

Did anyone get RB 3.0 working? It compiled for me but crashs whenever I hit play. I bet the problem is with gstreamer or monkeysound. I guess nobody has any usefull hints? I really like the app, not beeing able to play is a minor letdown though. :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum