Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Problem with cups automounting my printer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
kanba
n00b
n00b


Joined: 16 Feb 2007
Posts: 14
Location: Stuttgart

PostPosted: Thu Jan 21, 2010 9:13 pm    Post subject: [solved] Problem with cups automounting my printer Reply with quote

Hi there,

can anybody tell me, how to switch off the automount feature of cups. Switching on my printer, the printer is added automatically to the printers.conf file. Unfortunately it comes with a wrong DeviceURI
Code:
<Printer PSC-1600-series2>
Info HP PSC 1600 series
Location zaphod
MakeModel HP PSC 1600 Series, hpcups 3.9.12
DeviceURI usb://HP/PSC%201600%20series?serial=HU51ODRCC5L0
State Idle
StateTime 1264104441
Type 36876
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-raster 0 hpcups
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>


Adding the printer manually via the cups-interface I get this entry:
Code:
<DefaultPrinter PSC-1600-series>
Info HP PSC 1600 series
Location zaphod
MakeModel HP PSC 1600 Series, hpcups 3.9.12
DeviceURI hp:/usb/PSC_1600_series?serial=HU51ODRCC5L0
State Stopped
StateMessage ready to print
StateTime 1264095374
Reason paused
Type 36876
Filter application/vnd.cups-raw 0 -
Filter application/vnd.cups-raster 0 hpcups
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>


if I delete the automatically added printer, it comes back with the wrong DeviceURI after switching it off and on again. So either the system should add the printer with the correct DeviceURI or the printer should not be added at all. And I'm not able to print, before deleting the newly added printer or reconfigure it to the correct DeviceURI.
I'm using
Code:
 net-print/cups  1.4.2-r1!t(19:51:43 20.12.2009)(X acl dbus gnutls jpeg ldap linguas_de linguas_ja pam perl png python ssl tiff)

and
Code:
 net-print/hplip 3.9.12-r1(00:11:01 07.01.2010) (hpcups libnotify new-hpcups qt4 scanner snmp udev-acl)


System messages after switching on my printer:
Code:

Jan 21 22:05:37 zaphod hal_lpadmin: Running hal_lpadmin
Jan 21 22:05:38 zaphod hal_lpadmin: hal_lpadmin triggered by usblp kernel module
Jan 21 22:05:38 zaphod hal_lpadmin: Using device ID from HAL database entry
Jan 21 22:05:38 zaphod hal_lpadmin: add
Jan 21 22:05:38 zaphod hal_lpadmin: URIs: ['usb://HP/PSC%201600%20series?serial=HU51ODRCC5L0', 'hal:///org/freedesktop/Hal/devices/usb_device_3f0_4811_HU51ODRCC5L0_if1_printer_HU51ODRCC5L0']
Jan 21 22:05:38 zaphod hal_lpadmin: HPLIP Fax URIs: None
Jan 21 22:05:38 zaphod hal_lpadmin: Calling GetReady
Jan 21 22:05:38 zaphod hal_lpadmin: D-Bus method call failed: org.freedesktop.DBus.Error.ServiceUnknown: The name com.redhat.NewPrinterNotification was not provided by any .service files
Jan 21 22:05:40 zaphod hal_lpadmin: Device ID: MFG:HP;MDL:PSC 1600 series;DES:5740;CMD:MLC,PCL,PML,DW-PCL,DESKJET,DYN; URI:usb://HP/PSC%201600%20series?serial=HU51ODRCC5L0
Jan 21 22:05:41 zaphod hal_lpadmin: PPD: drv:///hp/hpcups.drv/hp-psc_1600_series.ppd; Status: 0
Jan 21 22:05:41 zaphod hal_lpadmin: Added printer PSC-1600-series2
Jan 21 21:05:42 zaphod kernel: usb-storage: device scan complete
Jan 21 21:05:43 zaphod kernel: scsi 5:0:0:0: Direct-Access     HP       PSC 1610         1.00 PQ: 0 ANSI: 2
Jan 21 21:05:43 zaphod kernel: sd 5:0:0:0: Attached scsi generic sg2 type 0
Jan 21 21:05:43 zaphod kernel: usb 2-1:1.3: uevent
Jan 21 21:05:43 zaphod kernel: usb 2-1: uevent
Jan 21 21:05:43 zaphod kernel: usb 2-1:1.3: uevent
Jan 21 21:05:43 zaphod kernel: sd 5:0:0:0: [sdc] Attached SCSI removable disk


any help? Thanks


Last edited by kanba on Wed Jan 27, 2010 9:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7711
Location: Saint Amant, Acadiana

PostPosted: Thu Jan 21, 2010 11:11 pm    Post subject: Reply with quote

Remove usblp from your kernel, CUPS does not need it.
Back to top
View user's profile Send private message
kanba
n00b
n00b


Joined: 16 Feb 2007
Posts: 14
Location: Stuttgart

PostPosted: Wed Jan 27, 2010 9:53 pm    Post subject: Reply with quote

Solved my Problem.
Thanxs
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum