Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[hal, xorg-server 1.7] et dell x200 (portable)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lbr
Guru
Guru


Joined: 05 Apr 2004
Posts: 503
Location: Paris

PostPosted: Mon Jan 18, 2010 10:22 am    Post subject: [hal, xorg-server 1.7] et dell x200 (portable) Reply with quote

Bonjour à tous,

J'avais un vieux portable DELL X200 que j'ai rétrofitté pour ma fille (essentiellement pour jouer avec GCompris). Ce faisant je me suis dis que j'allais upgrader et nettoyer.
Donc je suis passé de xorg-server <1.6 à 1.7.4 avec use=hal ...
J'ai viré xorg.conf.
X se lance sans soucis ... sauf que j'ai un clavier US ; et rien n'y fait !
Dans /etc/hal/fdi/policy/ j'ai ajouté 10-input-policy.fdi avec l'ajout des lignes
Code:
<merge key="input.xkb.layout" type="string">fr</merge>
<merge key="input.xkb.variant" type="string">latin9</merge>

idem pour 10-keymap.fdi et 10-x11-input.fdi

Après quand je fais un
Code:
hal-device |grep layout
, il continue à prétendre que c'est un clavier US ! (après avoir relancé hald, évidemment ;) )

Quelles solutions à part recompiler xorg avec -hal ?
Merci...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum