Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Jagged Alliance 2
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
choward
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 92

PostPosted: Sat Jan 31, 2004 5:26 pm    Post subject: Reply with quote

I understand the importance of a native game for the long term of Linux gaming, but for what it's worth, the Ja2 series runs flawlessly with WineX CVS.
_________________
Craig Howard
4B Computer Science -- University of Waterloo
Back to top
View user's profile Send private message
meowsqueak
Veteran
Veteran


Joined: 26 Aug 2003
Posts: 1549
Location: New Zealand

PostPosted: Sat Jan 31, 2004 9:09 pm    Post subject: Reply with quote

So they fixed that annoying double-click problem then? Every time I click something in JA2 under WineX, it acts as a double click, making it impossible to play.
Back to top
View user's profile Send private message
supernova
n00b
n00b


Joined: 12 Jan 2004
Posts: 49
Location: Karlsruhe, Germany

PostPosted: Sun Feb 01, 2004 11:54 pm    Post subject: Reply with quote

toojays, you rock!

That did the job! Thanks a lot to you (and meowsqueak, too)! :D
_________________
Roses are red
Violets are blue
All my base
Are belong to you
Back to top
View user's profile Send private message
choward
Tux's lil' helper
Tux's lil' helper


Joined: 08 Nov 2002
Posts: 92

PostPosted: Sun Feb 01, 2004 11:58 pm    Post subject: Reply with quote

Yes, the double click problem is definately fixed.
_________________
Craig Howard
4B Computer Science -- University of Waterloo
Back to top
View user's profile Send private message
meowsqueak
Veteran
Veteran


Joined: 26 Aug 2003
Posts: 1549
Location: New Zealand

PostPosted: Mon Feb 16, 2004 1:29 am    Post subject: Reply with quote

choward wrote:
Yes, the double click problem is definately fixed.


So it is. Thank you.
Back to top
View user's profile Send private message
ChojinDSL
l33t
l33t


Joined: 07 Jul 2003
Posts: 784

PostPosted: Mon Jun 07, 2004 4:40 pm    Post subject: Reply with quote

In case your still having problems with the linux version of Jagged Alliance, try to install the game using the loki installer available at this website:

http://liflg.sourceforge.net

I had the same segfault problem using the original text based installer included on cd. When I installed it via the loki installer, everything was fine.
Back to top
View user's profile Send private message
norc
Guru
Guru


Joined: 22 Apr 2004
Posts: 366
Location: Germany

PostPosted: Wed Jun 09, 2004 7:34 am    Post subject: Reply with quote

i havent played it, but my brother.
I could try to ask him, but he didnt use the irc-net anymore.
But he use wine for JA2.
Where do u get the win-JA2 from??
_________________
Unix is simple. It just takes a genius to understand its simplicity.
Back to top
View user's profile Send private message
sdaffis
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2003
Posts: 99

PostPosted: Wed Jun 16, 2004 4:16 pm    Post subject: Reply with quote

The shop :D
_________________
Believe the lie
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Fri Dec 31, 2004 4:53 pm    Post subject: Reply with quote

The correct location of the loki installer is http://liflg.org/?catid=6&gameid=11

BTW, why JA2 is not in portage?

EDIT: Working flawlessly when installed by this installer.
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
Bill Cosby
Guru
Guru


Joined: 22 Jan 2005
Posts: 430
Location: Aachen, Germany

PostPosted: Sun Jul 10, 2005 9:48 am    Post subject: Reply with quote

Hi everyone, when I use the installer posted above I get the following error
Code:
# ./jagged.alliance2_1.06b-english.run
Verifying archive integrity... All good.
Uncompressing Jagged Alliance2 1.06b-english Installer........................................................
tail: `-1' option is obsolete; use `-n 1' since this will be removed in the future

What does this mean? Can anybody help?
_________________
The Creature from Jekyll Island.
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Sun Jul 10, 2005 10:06 am    Post subject: Reply with quote

This is a warning, not an error. I see it when using any of the loki installers. Everything should be fine.
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
https://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
Bill Cosby
Guru
Guru


Joined: 22 Jan 2005
Posts: 430
Location: Aachen, Germany

PostPosted: Sun Jul 10, 2005 10:42 am    Post subject: Reply with quote

Yep, noticed that too :)
Because I got it aways by
Code:
export _POSIX2_VERSION=199209

the installer still stops for some reason, it just stops :cry:

I put all the files from the two ja2 cds in one folder and copyed the "jagged.alliance2_1.06b-english.run" in this folder, the setup.sh just works fine.
Any ideas?

thanks though
Bill

[edit]I think it is because I am on an AMD64 :cry: [/edit]
_________________
The Creature from Jekyll Island.
Back to top
View user's profile Send private message
Bill Cosby
Guru
Guru


Joined: 22 Jan 2005
Posts: 430
Location: Aachen, Germany

PostPosted: Sun Jul 10, 2005 2:20 pm    Post subject: Reply with quote

Yay, they updated to installer, it works now :)
_________________
The Creature from Jekyll Island.
Back to top
View user's profile Send private message
(l)user
Guru
Guru


Joined: 31 Jan 2004
Posts: 334
Location: Poland

PostPosted: Tue Nov 15, 2005 10:30 pm    Post subject: Reply with quote

I have problems wiht sound. In game sound doesn't wokr properly, its getting jammed. I can hear one sample all over again like "okay...okay...okay...okay...okay...okay...okay...", it chagnes from time to time to gunshoot or another sprech :D. Any idesa how to solve this problem?
_________________
Registered Linux user #302020
Gadu Gadu #490092
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Thu Nov 17, 2005 8:31 pm    Post subject: Reply with quote

use wine. That way everything works and you can reap what modifications have been done since ja2 is opensource.

Here's the changelog/todo to make you all superjealous. ;)
http://www.ja-galaxy-forum.com/ubb/ultimatebb.php?ubb=get_topic;f=42;t=000017
Back to top
View user's profile Send private message
(l)user
Guru
Guru


Joined: 31 Jan 2004
Posts: 334
Location: Poland

PostPosted: Tue Nov 22, 2005 1:18 am    Post subject: Reply with quote

Thats a shame that windows version via wine works better then the native one.
_________________
Registered Linux user #302020
Gadu Gadu #490092
Back to top
View user's profile Send private message
Crimson Rider
Guru
Guru


Joined: 23 Jun 2003
Posts: 462
Location: Delft, the Netherlands

PostPosted: Tue Nov 22, 2005 10:18 am    Post subject: Reply with quote

Yeah, but they released the source code. So you can actually try and make it work that way.
_________________
Code, justify, code - Pitr Dubovich
Back to top
View user's profile Send private message
nasko8
n00b
n00b


Joined: 18 Feb 2006
Posts: 1

PostPosted: Sat Feb 18, 2006 4:52 pm    Post subject: Reply with quote

Hi! I am trying to run ja2 since this morning but still no success.
I am running the 2.6.12 kernel. I installed the game with the loki installer. When I type ja2.sh, I see the banners of Sirtech and Tribsoft and them a Segmentation fault follows.
I tried out some things that I read in this and other forums, including starting a new x server, logging in as root and trying to start ja2, i even tried to run it under a 2.4 kernel I also have. Nope, always the same - I see the two banners one after the other and hear sound and a segfault after that.
I would appreciate every help as ja is the best game I've played (some time ago under winblows) and would be very happy to be able to play under linux...
Back to top
View user's profile Send private message
ExZombie
Apprentice
Apprentice


Joined: 29 May 2004
Posts: 164

PostPosted: Sun Apr 30, 2006 9:14 pm    Post subject: Reply with quote

I'm a bit late replying to you but nasko8 but I hope it's still of use.
The system ja2 was built for is a relatively ancient one: outdated kernel, outdated glibc, outdated xfree. Replacing all these is not an option. But I managed to get ja2 working by using an old version of Vector Linux. No need to install it though. You simply download it, unpack it to some dir and chroot into it, just as if you were chrooting into a gentoo stage. Get a version from the time when ja2 was built, and it should work. You will need to rebind /dev and /tmp (and maybe /proc) into the chroot by doing 'mount --bind' in order for devices and X to work (check 'man mount' if you don't know what this means). And maybe there is a thing or two to configure, but I don't think so, and don't remember. Anyway, if you managed to install gentoo you should know your way around.
Back to top
View user's profile Send private message
odborg
Tux's lil' helper
Tux's lil' helper


Joined: 12 Apr 2002
Posts: 89
Location: Aalborg, Denmark

PostPosted: Thu Jun 22, 2006 4:21 am    Post subject: Reply with quote

Here what i did. Goto http://gentoo-wiki.com/HOWTO_Running_Old_Loki_Games and fetch loki_compat_libs-1.1.tar.bz2
Unpack to your directory of choice and start ja2 like this(with paths adjusted):
Code:
LD_LIBRARY_PATH=/opt/Loki_Compat/ /opt/Loki_Compat/ld-linux.so.2 /opt/ja2/ja2 -w


This stopped segmentation faults AND sound stutter/jamming problems for me :)
Edit:

Actually compiling glibc with glibc-compat use flag is enough (edit /etc/make.conf), if you install ja2 with the graphical installer from http://www.liflg.org/?catid=6&gameid=11.
Edit the ja2.sh script(at the bottom), to read:
Code:
LD_ASSUME_KERNEL=2.4.1 LD_PRELOAD=$GAME_DIR/lib/libX11.so.6.2 ./$GAME_BINARY "$CMD_ARGS" "$@"
#LD_PRELOAD=$GAME_DIR/lib/libX11.so.6.2 ./$GAME_BINARY "$CMD_ARGS" "$@"

instead of:
Code:
#LD_ASSUME_KERNEL=2.4.1 LD_PRELOAD=$GAME_DIR/lib/libX11.so.6.2 ./$GAME_BINARY "$CMD_ARGS" "$@"
LD_PRELOAD=$GAME_DIR/lib/libX11.so.6.2 ./$GAME_BINARY "$CMD_ARGS" "$@"


Happy gaming :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum