Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Apache] Démarrage en local (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Mon Jan 04, 2010 6:50 pm    Post subject: [Apache] Démarrage en local (Résolu) Reply with quote

Bonjour, et bonne année à tous :)

Voilà, je souhaite démarrer un serveur apache2 pour qu'il n'écoute qu'en local, afin de travailler un site pour un pote.

Seulement lorsque je le lance, il cherche a démarrer mon bridge réseau, mais je ne sais pas pourquoi.

Je suis connecté à Internet via le wifi sur wlan0, et le bridge br0 prend eth0 et tap0 comme interfaces .. Du coup ça cherche un dhcp mais sans rien trouver ..

Je ne comprend pas pourquoi il veut absolument démarrer ce bridge, il ne me sert que lors d'une connexion filaire + une VM Windows bridgée.

Voilà la sortie lors d'un start :
Code:

laptoo ~ # /etc/init.d/apache2 start
 * Bringing up interface br0
 *   Destroying bridge br0 ...                                                                                                                                   [ ok ]
 *   Creating bridge br0 ...
set hello timer failed: Invalid argument
 *   Adding ports to br0
 *     tap0 ...                                                                                                                                                  [ ok ]
 *     eth0 ...                                                                                                                                                  [ ok ]
 *   dhcp ...
 *     Running dhcpcd ...
dhcpcd: version 5.1.3 starting
dhcpcd: br0: broadcasting for a lease
dhcpcd: timed out                                                                                                                                                [ !! ]
 * ERROR: net.br0 failed to start
 * Bringing up interface br0
 *   Destroying bridge br0 ...
 *     Removing port eth0 ...                                                                                                                                    [ ok ]
 *     Removing port tap0 ...                                                                                                                                    [ ok ]
 *   Creating bridge br0 ...
set hello timer failed: Invalid argument
 *   Adding ports to br0
 *     tap0 ...                                                                                                                                                  [ ok ]
 *     eth0 ...                                                                                                                                                  [ ok ]
 *   dhcp ...
 *     Running dhcpcd ...
dhcpcd: version 5.1.3 starting
dhcpcd: br0: broadcasting for a lease
dhcpcd: timed out                                                                                                                                                [ !! ]
 * ERROR: net.br0 failed to start
 * ERROR: cannot start netmount as net.br0 would not start
 * ERROR: cannot start apache2 as net.br0 would not start
laptoo ~ #


Je soupçonne un lien avec netmount mais je ne sais pas trop ce que c'est, donc si quelqu'un peux m'éclairer ...
Je peux poster plus d'infos si nécessaire (conf, use).

Merci :D


Last edited by engil on Tue Jan 05, 2010 8:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
engil
Tux's lil' helper
Tux's lil' helper


Joined: 22 Nov 2005
Posts: 117
Location: France

PostPosted: Tue Jan 05, 2010 8:25 pm    Post subject: Reply with quote

Bon, ben en fait c'était tout con ... j'ai commenté la partie bridge dans /etc/conf.d/net (pas suffisant) et supprimé le lien /etc/init.d/net.br0 et ça démarre ...

J'ai aussi réemergé apache avec les options qui vont bien, ça m'a l'air plus propre.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum