Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[installation] Besoin d'aide pour installer Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Tue Dec 29, 2009 8:32 pm    Post subject: Reply with quote

ce matin, j'ai lu les commandes qui sont propre à emerge.
j'ai recherché fluxbox et tester l'instal. emerge /dossier_fluxbox...
Ça ma pas donner grand chose donc là il faut que je rééssaie avec les tutos.
pour annuler une installation avec emerge, je tape bien: emerge --unmerge /dossier_fluxbox ?

pour ma carte graphique, c'est une Nvidia (je ne connais pas le nom exacte. Y a t-il une commande spécial à rentrer dans le shell pour trouver le nom des composants ?)
autre question:
durant l'installation je n'ai pas pris l'installation manuel du noyau car je ne sais pas quel processeur choisir dans la rubrique "Processor family".
J'ai un intel dual core inside et j'ai hésité à choisir "core2/ new xeron".
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Tue Dec 29, 2009 11:10 pm    Post subject: Reply with quote

Salut pi-2r, peux-tu poster ceci :

Code:

# cat /proc/cpuinfo
# lspci -n
# emerge --info
# rc-update show


Ça va nous donner le détail de ce que tu as présentement sur ton ordi.
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Wed Dec 30, 2009 3:39 pm    Post subject: Reply with quote

salut d2_racing :)

alors depuis le liveDVD et avec la commande chroot, j'obtiens ça:
pour cat /proc/cpuinfo:
Code:
processor   : 0
vendor_id   : GenuineIntel
cpu family   : 6
model      : 15
model name   : Intel(R) Pentium(R) Dual  CPU  T2390  @ 1.86GHz
stepping   : 13
cpu MHz      : 1941.008
cache size   : 1024 KB
physical id   : 0
siblings   : 2
core id      : 0
cpu cores   : 2
apicid      : 0
initial apicid   : 0
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 10
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips   : 3882.01
clflush size   : 64
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family   : 6
model      : 15
model name   : Intel(R) Pentium(R) Dual  CPU  T2390  @ 1.86GHz
stepping   : 13
cpu MHz      : 1941.008
cache size   : 1024 KB
physical id   : 0
siblings   : 2
core id      : 1
cpu cores   : 2
apicid      : 1
initial apicid   : 1
fdiv_bug   : no
hlt_bug      : no
f00f_bug   : no
coma_bug   : no
fpu      : yes
fpu_exception   : yes
cpuid level   : 10
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts pni dtes64 monitor ds_cpl est tm2 ssse3 cx16 xtpr pdcm lahf_lm
bogomips   : 3723.42
clflush size   : 64
power management:


pour lspci -n:
Code:
00:00.0 0600: 8086:2a00 (rev 03)
00:01.0 0604: 8086:2a01 (rev 03)
00:1a.0 0c03: 8086:2834 (rev 03)
00:1a.1 0c03: 8086:2835 (rev 03)
00:1a.7 0c03: 8086:283a (rev 03)
00:1b.0 0403: 8086:284b (rev 03)
00:1c.0 0604: 8086:283f (rev 03)
00:1c.1 0604: 8086:2841 (rev 03)
00:1c.5 0604: 8086:2849 (rev 03)
00:1d.0 0c03: 8086:2830 (rev 03)
00:1d.1 0c03: 8086:2831 (rev 03)
00:1d.2 0c03: 8086:2832 (rev 03)
00:1d.7 0c03: 8086:2836 (rev 03)
00:1e.0 0604: 8086:2448 (rev f3)
00:1f.0 0601: 8086:2815 (rev 03)
00:1f.1 0101: 8086:2850 (rev 03)
00:1f.2 0106: 8086:2829 (rev 03)
00:1f.3 0c05: 8086:283e (rev 03)
01:00.0 0300: 10de:0428 (rev a1)
06:00.0 0200: 11ab:4353 (rev 14)
07:01.0 0805: 1180:0822 (rev 19)
07:01.1 0880: 1180:0843 (rev 01)
07:01.2 0880: 1180:0592 (rev 0a)


pour emerge --info
Code:
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r6-i686-Intel-R-_Pentium-R-_Dual_CPU_T2390_@_1.86GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 29 Dec 2009 11:15:01 +0000
app-shells/bash:     4.0_p35
dev-lang/python:     2.6.4
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org/ "
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 jpeg kde ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


et enfin pour rc-update show, j'ai:
Code:
      bootmisc | boot                         
             checkfs | boot                         
           checkroot | boot                         
               clock | boot                         
         consolefont | boot                         
            hostname | boot                         
             keymaps | boot                         
               local |      default nonetwork       
          localmount | boot                         
             modules | boot                         
            net.eth0 |      default                 
              net.lo | boot                         
            netmount |      default                 
           rmnologin | boot                         
           syslog-ng |      default                 
             urandom | boot



voilà pour les détails :D
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Wed Dec 30, 2009 4:21 pm    Post subject: Reply with quote

Dans ta lancée pour donner les infos sur ton PC, peux-tu nous donner le modèle exact.

Pour ton histoire de configuration de kernel tu me fais penser que dans le nouveau 2.6.32, ils ont mis une nouvelle fonction qui s'appelle make localmodconfig à utiliser avant un make menuconfig ainsi compiler un kernel devient beaucoup moins casse tête puisqu'il te crée une config automatique.
_________________
Gentoo rocks
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Wed Dec 30, 2009 5:25 pm    Post subject: Reply with quote

bonsoir,

pour le modéle, c'est un Packard Bell EasyNote SB65
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 30, 2009 5:37 pm    Post subject: Reply with quote

Salut pi-2r, tout d'abord je t'ai demandé ton lspci -n à cause de l'info qu'on peut retrouver ici : http://62.3.120.141/~pappy/working.html

Avec ce que tu m'as donné, j'ai quelques modifications que tu devrais ajouter dans ton make.conf :

Code:

MAKEOPTS="-j3"
VIDEO_CARDS="vesa nvidia"


Pour ce qui est de ton installation, tu utilises les paramètres de base de GCC et pour une première installation ça peut aller.

Par contre, si un jour tu recommences ou tu veux optimiser à fond ton installation, je te recommande ceci :

Code:

CFLAGS="-O2 -march=native -pipe"
CXXFLAGS="${CFLAGS}"
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 30, 2009 5:40 pm    Post subject: Reply with quote

Au fait, veux-tu que ta Gentoo soit en Anglais ou en Français, car présentement tu vas installer tout en Anglais.
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Wed Dec 30, 2009 5:53 pm    Post subject: Reply with quote

bonsoir,


merci de ton aide d2_racing, mais ma gentoo est installer :wink:

aujourdh'ui j'ai voulu installer Xorg et fluxbox mais je rencontre quelques problemes, donc là je me rabat sur KDE :D

pour ce qui est de la langue, anglais ou français, ça n'a aucune importance. Disons que l'anglais me servira à trvailler cette langue ;), mais s'il y a un manip pour avoir tout en français, je suis tout de fois preneur ^^,
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 30, 2009 7:03 pm    Post subject: Reply with quote

Salut, oui il existe une méthode, la voici :

Code:

# nano -w /etc/conf.d/consolefont


Assure toi que cette ligne n'est pas en commentaire :
Code:

CONSOLETRANSLATION="8859-1_to_uni"


Ajoute ceci dans ta variale USE dans ton /etc/make.conf
Code:

nls truetype userlocales unicode


Ajoute ceci dans ton /etc/make.conf
Code:

LINGUAS="fr"


Ensuite édite ce fichier :
Code:

# nano /etc/env.d/02locales


Code:

LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR.UTF-8"


Ensuite édite ce fichier :
Code:

# nano /etc/locale.gen

Code:

fr_FR ISO-8859-1
fr_FR.UTF-8 UTF-8


Édite ce fichier :
Code:

# nano /etc/portage/package.use

Code:

sys-libs/glibc userlocales


Ensuite lance ceci :
Code:

# locale-gen
# env-update && source /etc/profile


Maintenant, tu vas devoir recompiler tout ton système.

Code:

# emerge -e world


Si tu fais ça, profite s'en pour optimiser ton installation en faisant ceci en modifiant ton fichier /etc/make.conf :

Code:

CFLAGS="-O2 -march=native -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j3"


Remplace ta ligne CFLAGS et CXXFLAGS par celle que je viens de te donner.

Enfin, ajoute MAKEOPTS="-j3", ça va donner un peu plus de puissance.
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Thu Dec 31, 2009 10:20 am    Post subject: Reply with quote

merci pour la manip

le seul truc c'est que je n'ai trouver le fichier package.use, car j'ai voulu le sauvegrader, ça ma donner un erreur. donc j'ai laisser tombé....
là je recomplie le system.
ça veut dire qu'aprés ça, je repards à zéro ,


Code:
 
* IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items. 


j'ai installer xorg-x11, fluxbox, et kdebase-startkde.
pour déinstaller xorg-x11 j'ai tapé emege --unmerge xorg-x11, mais je ne suis pas sur que cela ait marché (comment peut-on le vérifier ,et comment voire les paquets installer par emerge ,)
Hier soir j'ai installer l'environnement KDE (cf: kdebase-startkde). Ça a mit plus de 5h pour tout compiler.....
mais quand j'ai voulu lancer la commande startx, j'ai eu l'erreur suivante:

Code:
etc/x11/xinit/xinitric: line 58 :twn
etc/x11/xinit/xinitric: line 59 :xclock
etc/x11/xinit/xinitric: line 60: xterm
etc/x11/xinit/xinitric: line 61: xterm
etc/x11/xinit/xinitric: line 62: exec


avec au final, dans le message d'erreur un "Invald argument (22)"
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Dec 31, 2009 12:57 pm    Post subject: Reply with quote

Arf, t'as fait une bonne grosse bourde de débutant !
Xorg est la couche graphique communément utilisée avec Linux.
Gnome, KDE ou fluxbox utilisent cette couche graphique pour l'affichage.

Conclusion : t'as installé KDE mais t'as viré Xorg... en gros, t'as mis une belle peinture sur ta voiture mais t'as retiré le moteur.

Faut que tu réinstalles Xorg et que tu t'assures que celui ci est fonctionnel avant de lancer KDE.

Pour récupérer comme tu peux, tu peux tenter le :

Code:
revdep-rebuild -- -a


Si tu hésites à valider, tu réponds non et tu nous donne le display de la commande pour qu'on voit l'état des dégâts ;)

EDIT : euh, si t'as pas la commande "revdep-rebuild", il doit se trouver dans "portage-utils".
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Thu Dec 31, 2009 1:11 pm    Post subject: Reply with quote

Merci de tes remarques Temet :wink:
Temet wrote:

Conclusion : t'as installé KDE mais t'as viré Xorg... en gros, t'as mis une belle peinture sur ta voiture mais t'as retiré le moteur.


:? :lol:

pour la manip, je tenterai plus tard car là il y à la commande emerge -e world qui tourne...
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Thu Dec 31, 2009 1:30 pm    Post subject: Reply with quote

Temet wrote:

EDIT : euh, si t'as pas la commande "revdep-rebuild", il doit se trouver dans "portage-utils".


Salut!

revdep-rebuild fait plutôt partie du package "gentoolkit" :wink:
_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Dec 31, 2009 6:55 pm    Post subject: Reply with quote

pi-2r wrote:
le seul truc c'est que je n'ai trouver le fichier package.use, car j'ai voulu le sauvegrader, ça ma donner un erreur. donc j'ai laisser tombé....


C'est normal, le fichier n'existe pas :

Code:

# nano -w /etc/portage/package.use
sys-libs/glibc userlocales
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Dec 31, 2009 6:58 pm    Post subject: Reply with quote

Pour gentoolkit, C'est ici :

Code:

# emerge -av app-portage/gentoolkit
# app-portage/portage-utils


Quand tu vas avoir recompiler ton world et que tu vas avoir installé xorg, tu posteras ceci s.v.p :

Code:

# emerge --info
# rc-update show
# qlist -ICv xorg
# qlist -ICv kde
# qlist -ICv fluxbox


Au fait, as-tu pris le temps de changer des cflags ?
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Fri Jan 01, 2010 9:16 pm    Post subject: Reply with quote

Bonsoir

pour emerge --info :

Code:
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r6 i686)                                                     
=================================================================               
System uname: Linux-2.6.30-gentoo-r6-i686-Intel-R-_Pentium-R-_Dual_CPU_T2390_@_1.86GHz-with-gentoo-1.12.13                                                     
Timestamp of tree: Fri, 01 Jan 2010 18:45:03 +0000                             
app-shells/bash:     4.0_p35                                                   
dev-java/java-config: 2.1.9-r2                                                 
dev-lang/python:     2.6.4                                                     
dev-util/cmake:      2.6.4-r3                                                   
sys-apps/baselayout: 1.12.13                                                   
sys-apps/sandbox:    1.6-r2                                                     
sys-devel/autoconf:  2.63-r1                                                   
sys-devel/automake:  1.9.6-r2, 1.10.2                                           
sys-devel/binutils:  2.18-r3                                                   
sys-devel/gcc-config: 1.4.1                                                     
sys-devel/libtool:   2.2.6b                                                     
virtual/os-headers:  2.6.27-r2                                                 
ACCEPT_KEYWORDS="x86"                                                           
CBUILD="i686-pc-linux-gnu"                                                     
CFLAGS="-O2 -march=i686 -pipe"                                                 
CHOST="i686-pc-linux-gnu"                                                       
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"                     
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                 
CXXFLAGS="-O2 -march=i686 -pipe"                                               
DISTDIR="/usr/portage/distfiles"                                               
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                 
GENTOO_MIRRORS="http://distfiles.gentoo.org/ "                                 
LANG="fr_FR.UTF-8"                                                             
LDFLAGS="-Wl,-O1"                                                               
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo fam firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 jpeg kde ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd thunar tiff truetype unicode usb vorbis win32codecs x264 x86 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY



pour rc-update show:
Code:
           bootmisc | boot
             checkfs | boot
           checkroot | boot
               clock | boot
         consolefont | boot
            hostname | boot
             keymaps | boot
               local |      default nonetwork
          localmount | boot
             modules | boot
            net.eth0 |      default
              net.lo | boot
            netmount |      default
           rmnologin | boot
           syslog-ng |      default
             urandom | boot


pour qlist -ICv xorg
Code:
x11-base/xorg-drivers-1.6
x11-base/xorg-server-1.6.5-r1
x11-base/xorg-x11-7.4-r1



pour qlist -ICv kde
Code:
kde-base/automoc-0.9.88                             
kde-base/kcminit-4.3.3                               
kde-base/kcontrol-4.3.3                             
kde-base/kde-env-4.3.3                               
kde-base/kdebase-data-4.3.3                         
kde-base/kdebase-desktoptheme-4.3.3                 
kde-base/kdebase-kioslaves-4.3.3                     
kde-base/kdebase-menu-icons-4.3.3                   
kde-base/kdebase-startkde-4.3.3-r1                   
kde-base/kdebase-wallpapers-4.3.3                   
kde-base/kdelibs-4.3.3-r1                           
kde-base/kdesu-4.3.3                                 
kde-base/kdialog-4.3.3
kde-base/kdnssd-4.3.3
kde-base/keditfiletype-4.3.3
kde-base/kephal-4.3.3
kde-base/kfmclient-4.3.3
kde-base/kglobalaccel-4.3.3
kde-base/khotkeys-4.3.3
kde-base/kioclient-4.3.3
kde-base/kmimetypefinder-4.3.3
kde-base/knotify-4.3.3
kde-base/kreadconfig-4.3.3
kde-base/krunner-4.3.3
kde-base/ksmserver-4.3.3
kde-base/ksplash-4.3.3
kde-base/kstartupconfig-4.3.3
kde-base/kstyles-4.3.3
kde-base/ksysguard-4.3.3
kde-base/ktimezoned-4.3.3
kde-base/kurifilter-plugins-4.3.3
kde-base/kwin-4.3.3-r1
kde-base/libknotificationitem-4.3.3
kde-base/libkonq-4.3.3
kde-base/libkworkspace-4.3.3
kde-base/libplasmaclock-4.3.3
kde-base/libtaskmanager-4.3.3
kde-base/oxygen-icons-4.3.3
kde-base/phonon-kde-4.3.3
kde-base/plasma-apps-4.3.3
kde-base/plasma-runtime-4.3.3
kde-base/plasma-workspace-4.3.3-r1
kde-base/pykde4-4.3.3
kde-base/qimageblitz-0.0.4
kde-base/solid-4.3.3
kde-base/soliduiserver-4.3.3
kde-base/systemsettings-4.3.3


pour qlist -ICv fluxbox
Code:

x11-wm/fluxbox-1.1.1-r1


voilà pours les infos, sachant que j'ai ré-installer xorg-x11 et xorg-server
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Fri Jan 01, 2010 9:44 pm    Post subject: Reply with quote

autre soucis.
je suis la lecture du tuto suivant: http://www.gentoo.org/doc/fr/xorg-config.xml
et lorsque je lance la commande: X -config /root/xorg.conf.new, j'ai un écran totalement noir et quand je bouge la souris, ça ne fait rien....

si quelqu'un à une idée ,
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Jan 02, 2010 5:12 am    Post subject: Reply with quote

Ajoute ceci dans ton fichier /etc/make.conf :

Code:

VIDEO_CARDS="vesa nvidia"


Ensuite, lance ceci :

Code:

# emerge -auDNv world


Last edited by d2_racing on Sat Jan 02, 2010 5:14 am; edited 1 time in total
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Jan 02, 2010 5:13 am    Post subject: Reply with quote

Tu vas devoir lancer ceci :

Code:

# rc-update add hald default


Peux-tu poster ceci :

Code:

# cat /etc/conf.d/xdm
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sat Jan 02, 2010 9:27 am    Post subject: Reply with quote

Oui, bien mettre les driver de la carte graphique dans le make.conf et aussi les driver du clavier, souris, ...
_________________
Gentoo rocks
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Sat Jan 02, 2010 10:13 am    Post subject: Reply with quote

bonjour,

pour cat /etc/conf.d/xdm, j'obtiens:
Code:
# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | kdm-4.3 | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
#
# KDE-specific note:
# - If you are using kdeprefix go with "kdm-4.Y", e.g. "kdm-4.3".
#     You can find possible versions by looking at the directories in /usr/kde/.
# - Else, if you are using KDE 3 enter "kdm-3.5"
# - Else, if you are using KDE 4 enter "kdm" without a version
DISPLAYMANAGER="xdm"

# Set whether xorg should depend on hald or not. If set to 'auto' then the init
# script tries to determine the dependency on hald automatically, by examining
# xorg.conf files on various locations. If you have built xorg without hal
# use-flag, you should set 'no' here.  If xorg has been built with hal then you
# may set 'auto' or 'yes' here.
# Possible values are: [ yes | no | auto ]
NEEDS_HALD="auto"


(je travail en chroot)

par ailleurs, j'ai trouver ce topic sur gentoo quebec (http://gentoo-quebec.org/forum/viewtopic.php?f=3&t=1289), et il correspond aux difficultées que je rencontre....
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Sat Jan 02, 2010 6:17 pm    Post subject: Reply with quote

Bonsoir,

avec le lien que j'ai trouvé, j'ai mit dans /etc/x11/xorg.conf l'écriture suivante:
Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
 


Quand je lance startx, j'ai un écran noir, puis le logo de nvidia, puis j'ai par la suite une erreur avec ça:

Code:
etc/x11/xinit/xinitric: line 58 :twn
etc/x11/xinit/xinitric: line 59 :xclock
etc/x11/xinit/xinitric: line 60: xterm
etc/x11/xinit/xinitric: line 61: xterm
etc/x11/xinit/xinitric: line 62: exec


ainsi que ça:

Code:
expected keysum, got XF86 TouchpadToggle: line 122


faut-il que je génére automatiquement le fichier xorg-conf ?



Edit: dans le fichier /etc/make.conf, j'y ai aussi rajouter un INPUT_DEVICES="keyboard mouse", mais ça n'a pas l'aire de résoudre mon probléme......
Back to top
View user's profile Send private message
Biloute
Guru
Guru


Joined: 03 Apr 2008
Posts: 364
Location: LENS

PostPosted: Sat Jan 02, 2010 7:55 pm    Post subject: Reply with quote

Est-ce que tu veux dire que tu as juste rajouté INPUT_DEVICES="keyboard mouse" ou est-ce que tu as rajouté INPUT_DEVICES="keyboard mouse" puis tu as lancé emerge -1 xorg-server? (attention, si tu as mise USE="... hal ..." dans /etc/make.conf il faut mettre aussi INPUT_DEVICES="keyboard mouse evdev")

Enfin si tu as installé KDE et fluxbox, quand tu fais un simple startx est-ce que ton système sait quel environnement il faut lancer par défault. Est-ce que un startkde ne serait pas plus approprié?

Si tu veux avoir fluxbox par default avec startx alors tu dois faire
Code:
# echo "exec startfluxbox" > ~/.xinitrc

_________________
Gentoo rocks


Last edited by Biloute on Sat Jan 02, 2010 8:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
pi-2r
n00b
n00b


Joined: 28 Dec 2009
Posts: 28

PostPosted: Sat Jan 02, 2010 8:18 pm    Post subject: Reply with quote

depuis le chroot, j'obtient ça:
Code:
No protocol specified
$DISPLAY is not set or cannot connect to the X server.


donc si je tape ceci au lancement de la session, ça risque de ne pas marcher....
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Jan 02, 2010 10:13 pm    Post subject: Reply with quote

Peux-tu poster ceci :

Code:

# qlist -ICv x11-drivers
# qlist -ICv kdm
# qlist -ICv twn
# qlist -ICv xterm


Enfin, si tu as installé kdm, je te recommande de faire ceci :

Code:

# nano /etc/conf.d/xdm


Change

Code:

DISPLAYMANAGER="xdm"


pour

Code:

DISPLAYMANAGER="kdm"


Ensuite redémarre ton ordi.

Quand tu vas lancer ceci :

Code:

# /etc/init.d/xdm start


ça devrait te donner kdm :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum