Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on eeepc 1000he help!!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Thu Dec 24, 2009 10:46 am    Post subject: Reply with quote

ago88 wrote:
Kernel78 wrote:
ago88 wrote:
1) Innanzitutto è ******* compilare un kernel mettendo dei driver M e poi aggiungerli nell'autoload(tranne in casi eccezionali), tanto vale metterli built-in (*)


potrei farlo anche nel tuo post ma è meglio se ci arrivi da solo a capire che hai fatto un passo oltre, torni indietro e chiedi scusa.
se vuoi puoi ritenerlo inutile, controproducente o usare altri aggettivi (senza denigrare) ma sarebbe carino che prima di dare un giudizio ti informassi sulle ragioni che l'hanno spinto e poi che tu ti motivassi
ovviamente sempre mantenendo il massimo rispetto.




non voglio degenerare in discussioni...ma talvolta un utente sbaglia perchè segue ad occhi chiusi la guida senza chiedersi che sta facendo...ecco un classico esempio:

vorrei anche ben vedere che non vuoi degenerare in discussioni, hai torto e adesso invece di inviarmi un mp continui ancora qui.
Forse non ti sono chiari alcuni punti:
1) Le linee guida del forum PRETENDONO il rispetto
2) tu non hai rispettato un altro utente
3) non hai modificato il tuo post come richiesto
4) non hai chiesto scusa come richiesto

Non mi interessa neppure conoscere le ragioni tecniche che potresti addurre, qui si tratta di regole di convivenza civile e del loro rispetto.
Per favore, fatemi vivere un po' di spirito natalizio, non voglio richiedere ban (temporanei) sotto natale e per motivi del genere.

Per favore, chiedi scusa e modifica il tuo post.

Lo dico come moderatore e non lo ripeterò più.

/EDIT:ok, il messaggio è stato modificato e le scuse fatte. Manteniamo uno spirito natalizio o mi toccherà portare carbone ai bambini cattivi :lol:
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Thu Dec 24, 2009 10:39 pm    Post subject: Reply with quote

soeca wrote:
Scusatemi...xorg serve o no??meglio hal o xorg?Non ci sto capendo più niente!! :?


Ciao, perdonami se ti ho fatto casino. non era mia intenzione. Ti spiego brevemente.

Xorg è il server grafico di linux. Server grafico vuol dire che è quello che ti va vedere qualsiasi tipo di grafica. su questo server si appoggiano le varie librerie grafiche per linux (dalle opengl alle QT, alle GTK, e che so... insomma.. quel che ti viene in mente)

HAL (Hardware abstraction Layer) entra in gioco in quanto, dalla versione di XORG 1.5 in poi è possibile fregarsene del file /etc/X11/xorg.conf. Cosa succede?
semplice, se XORG è stato compilato con la flag "hal" ed hai hal caricato all'avvio (rc-update add hald default), XORG riesce a "generarsi" un suon xorg.conf in automatico. Da parte tua non hai più necessità di definire lo xorg.conf a manina: xorg capirà da solo quali driver caricare e abilitare.
Nella maggiorparte dei casi questa "autoconfigurazione" funziona meglio della conf manuale, ma ci sono alcuni casi in cui non va. Per questo motivo, puoi impostare il file /etc/X11/xorg.conf: Xorg andrà ad usare le specifiche che hai messo tu.


Quote:
Tornando al discorso gentoo....ragazzi sto compilando per l'ennesima volta(speriamo sia la definitiva!!)il kernel dopo aver seguito gli ultimi consigli!!Speriamo bene altrimenti mi sa che dovrò pensare seriamente di fare un passo indietro e tornare ad Arch o a Ubuntu perchè a breve ho 2materie di programmazione(java e mic) e ovviamente mi serve il pc.


Gentoo non è impossibile, te lo dico io che all'inizio ho fatto un sacco di casini sul mio pc......
E' sempre un problema iniziare ad usare gentoo. Soprattutto all'inizio non devi dare nulla per scontato e leggere il più pedissequamente possibile le guide ufficiali.
Mi spiace che tu abbia tutti questi problemi, ma vedrai che ne uscirai e avrai imparato molto . Segui i consigli di Kernel78 e vedrai che riuscirai a compilare il kernel come lo vuoi tu.

domanda personale: ma nemmeno con VESA ti carica il video?
cioè, mio consiglio. fai una cosa per gradi, del tipo: prima vedi se si carica con VESA. poi prova con il driver INTEL. poi, infine, concentrati sul DRI.
Se vuoi il mio consiglio, mettere tutto build-in (come dice ago88) è una buona idea. Io seguirei il suo consiglio, ti togli un sacco di problemi.
Poi fai tu :wink: (sinceramente non ho capito 'na mazza della diatriba in corso)
_________________
Darkman
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Dec 25, 2009 10:27 am    Post subject: Reply with quote

Ragazzi tantissimi auguri di un Buon e Sereno Natale a tutti quanti!!!
Tornando al discorso gentoo...ho compilato un altro kernel e ora arrivo fino alla schermata di avvio di gnome(la schermata in cui chiede Nome utente e password) io inserisco tutti i dati ed esce il seguente errore:
Code:

Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean may be out of diskspace. Try logging in with one of the failsafe sessions to see if you can fix this problem.
se clicco su
Code:

View details( /.xsessions-error file)

compaiono questi messaggi:
Code:

/etc/X11/gdm/Xsession:Beginning session setup...
/etc/X11/gdm/Xsession:Cannot find Xclients
/etc/X11/gdm/Xsession:line 203:exec:xterm:not found

che vuol dire???o meglio cosa dovrei controllare???Grazie e ancora auguriiii...Forza ragazzi siamo ad un passo dal finire... :D
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Fri Dec 25, 2009 6:23 pm    Post subject: Reply with quote

Quote:

arrivo fino alla schermata di avvio di gnome(la schermata in cui chiede Nome utente e password)

Si chiama GDM (giusto per capirsi :wink: quando farò riferimento a lui)

soeca wrote:
Ragazzi tantissimi auguri di un Buon e Sereno Natale a tutti quanti!!!
compaiono questi messaggi:
Code:

/etc/X11/gdm/Xsession:Beginning session setup...
/etc/X11/gdm/Xsession:Cannot find Xclients
/etc/X11/gdm/Xsession:line 203:exec:xterm:not found

che vuol dire???o meglio cosa dovrei controllare???Grazie e ancora auguriiii...Forza ragazzi siamo ad un passo dal finire... :D


Buon Natale anche a te

La parte che segue, saltala se vuoi :roll: , ma te la consiglio giusto per verificare che le librerie siano tutte ok :wink:
--------------------------------
allora... Onde pensare ad altri problemi io consiglio di fare le seguenti operazioni in successione.
Code:
revdep-rebuild

questo comando scansiona le librerie in cerca di eventuali problemi (segnatelo, è molto utile!)

dopodichè ti farà, nel caso trovi problemi, automaticamente ri-emerge alcuni pacchetti.
Infine, controlla con
Code:
emerge -uDN world

di avere soddisfatto tutte le dipendenze.
(è solo per esser sicuro che sia tutto ok)
--------------------------------

domanda: ti stai loggando come root con GDM?

altra cosa, nel caso, prova così.
Code:
cd /home/<utente>
echo "gnome" > .Xclients
chmod +x .Xclients


riprova, va?
prova un
Code:
emerge xterm
sembra che stia cercando xterm...

boh, è una idea
_________________
Darkman
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Dec 25, 2009 6:44 pm    Post subject: Reply with quote

darkmanPPT wrote:

...la parte che segue,saltala se vuoi,ma te la consiglio giusto per verificare che le librerie siano tutte ok...

E perchè la dovrei saltare?!
1)Mi stai aiutando anche a Natale e di questo posso solo dirti grazie
2)questo è un preziosissimo consiglio che mi permette di conoscere un nuovo ed utilissimo comando inerente gentoo
3)ho speso 4giorni assieme a voi a capire come installare e configurare gentoo sul mio pc e risolvere i casini che credo di aver combinato....non vedo perchè giusto ora(che stiamo quasi per finire) dovrei cominciare ad avere fretta di concludere !! :D

Per ora sta finendo di riemergere gdm però stavolta ho usato il comando
Code:
 emerge gnome
e non
Code:
 emerge gnome-light
appena finisce riprovo a rientrare se mi da problemi attuo subito i tuoi consigli!!PS i problemi me li dava sia entrando come root che entrando con il mio utente!!PPS ancora non capisco come mai con il vecchio kernel continuo a non poter entrare......boooo!! :D
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Fri Dec 25, 2009 11:03 pm    Post subject: Reply with quote

Niente da fare......ho eseguito tutti i comandi.....ora non ho nessun errore all'avvio di gdm ma il pc si blocca su una schermata verde, il pc non si pianta infatti il mouse continua a funzionare(tranne i tasti sx e dx) , dopo aver inserito nome utente e password(sia che entro come root sia che entro con il mio utente!!)...non capisco!!ho provato a installare lxde ma...peggio che andar di notte quindi direi che è meglio concentrarsi solo su gdm che su lxde!!altri consigli o comandi da applicare???
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sat Dec 26, 2009 12:22 am    Post subject: Reply with quote

Quote:
1)Mi stai aiutando anche a Natale e di questo posso solo dirti grazie


Beh, ho fatto solo un salto sul forum. A rispondere non ci vuol molto :wink:
cmq, prego.

soeca wrote:
Niente da fare......ho eseguito tutti i comandi.....ora non ho nessun errore all'avvio di gdm ma il pc si blocca su una schermata verde, il pc non si pianta infatti il mouse continua a funzionare(tranne i tasti sx e dx) , dopo aver inserito nome utente e password(sia che entro come root sia che entro con il mio utente!!)...non capisco!!ho provato a installare lxde ma...


Qualcosa del genere?
http://www.farstar.it/linux/ambienti_grafici/twm.php
Cerca di essere più "preciso" nella descrizione

Allora, correggimi se sbaglio.
Tu avvii il computer.
Si carica Xorg, il quale, a sua volta, carica GDM (quello che ti serve per loggarti).

Su GMD inserisci nome_utente e password e selezioni come sezione "gnome".

corretto?

Quote:
peggio che andar di notte quindi direi che è meglio concentrarsi solo su gdm che su lxde!!altri consigli o comandi da applicare???


Aspè, non facciamo casino. Un conto sono i login manager grafici come gdm e kdm e un conto sono i Window Manager come gnome, kde, xfce, lxde, elinghtment, blackbox, etc etc..
Non facciamo confusione, sennò non ci si capisce più.

Dopo aver controllato se hai selezionato con window manager (da GDM, prima di loggarti) la voce "gnome", posta le ultime righe di /var/log/gdm.log (o il relativo file di log che non so com'altro potrebbe chiamarsi). Ora mi pare che il problema si sia spostato non più tanto su Xorg (la grafica ora ti funziona) ma sul window manager che non si carica.
corretto?

Dato che mi sta sorgendo un dubbio, fai questo controllo.
Code:
nano /etc/conf.d/xdm


controlla che la voce sia impostata così (mi è sorto il dubbio se veramente stai usando GDM o un'altra roba...)
DISPLAYMANAGER="gdm"

non prenderla come un affronto, ma dato che sei nuovo di gentoo potresti esserti dimenticato qualcosa di basilare.

nel caso la voce fosse impostata diversamente, dopo averla impostata a "gdm", riavvia il login manager così:
Code:
/etc/init.d/xdm restart


fai sapere se va.
ciao
_________________
Darkman
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sat Dec 26, 2009 1:11 am    Post subject: Reply with quote

Allora ho fatto un video con il cellulare e lo caricato su youtube.......il video lo trovi QUI ecco cosa succede!!Ora cerco il relativo .log e lo posto!!Per il resto tranquillo tutto impostato subito dopo aver emerso gnome!!PS mi scuso per la qualità del video ma ho un ottimo smartphone con android ma con una fotocamera un pò scarsetta..... :D
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sat Dec 26, 2009 1:19 am    Post subject: Reply with quote

io non ho la più pallida idea di come aiutarti ma è decisamente carina l'idea del video :lol:
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
soeca
n00b
n00b


Joined: 24 Jun 2009
Posts: 57

PostPosted: Sat Dec 26, 2009 1:33 am    Post subject: Reply with quote

Ho provato ad installare LXDE proprio perchè GDM mi dava sti problemi!!a nessuno viene niente in mente??comunque non c'è un file log!!

EDIT1: Ragazzi vi ringrazio tantissimo per l'aiuto che mi avete dato in questi giorni ma anche ieri ho fatto un'altra notte brava dietro a gentoo per tentare di risolvere qualche problema spulciandomi le varie guide su Xorg,GDM aggiornamenti e problemi vari!!Non posso però continuare così anche perchè ribadisco tra pochi giorni ho 2esami da domani mi devo rimettere a programmare ho bisogno di un S.O direi quindi che il progetto Gentoo on EEEPC1000HE si può considerare PER ORA concluso....finito questo periodo di esami ci ritornerò.....ormai è una questione di principio...ci devo riuscire!! :D :D Ringrazio ancora tutti per la gentilezza e la disponibilità.Divertitevi in quest giorni di festa!!Per me questo topic si può chiudere.....Ne riparliamo a Febbraio/Marzo!!Ciaoooooooooo
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sun Dec 27, 2009 1:38 pm    Post subject: Reply with quote

Ciao.
mi spiace che tu abbia abbandonato tale progetto, spero tu lo riprenda in mano in futuro.

comunque sia, gli errori di sessione li trovi nel seguente file:

Code:
~/.xsession-errors


potresti dare una occhiata là dentro per capire la natura del problema.
in bocca al lupo per i 2 esami.
_________________
Darkman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum