Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ipod su gentoo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Sun Dec 20, 2009 6:55 pm    Post subject: Ipod su gentoo Reply with quote

Ciao ragazzi,
Ho provato a configurare il kernel 2.6.31-gentoo-r6 per poter utilizzare l'ipod sotto linux seguendo le indicazioni presenti qui http://www.gentoo-wiki.info/Apple_iPod
Al termine della configurazione ho eseguito i passaggi necessari alla copia dell'immagine del kernel in /boot e quindi configurare grub.conf.
Al riavvio Kernel Panic -not syncing: VFS: Unable to mount root fs
Questo il mio /etc/fstab:

Quote:
/dev/sda2 /boot ext2 noauto,noatime 1 2
/dev/sda4 / ext3 noatime 0 1
/dev/sda3 none swap sw 0 0
/dev/cdrom /mnt/cdrom auto noauto,user,ro 0 0


Il mio disco contiene però anche una partizione sda1 dove è presente windows xp.

Grazie per eventuali suggerimenti.
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Dec 20, 2009 10:38 pm    Post subject: Reply with quote

ti ricordo che la guda che hai letto non è ufficiale...ma andando aldilà di questo credo che per dare kernel panic..in genere hai dimenticare di mettere built-in qualcosa tipo fs, driver del hd, driver scsi e forse driver della mobo, ( i2c? )

cmq posta anche grub.conf...


P.S. potresti anche togliere/commentare l'ultima riga di fstab in quanto il lettore cd viene gestito da hal (versione stabile in tree)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Dec 21, 2009 2:22 pm    Post subject: Reply with quote

Grazie ago88 il tuo suggerimento ha funzionato alla perfezione.
Ho reso built in la voce disk scsi support e tutto ha ripreso a funzionare.
Ciao
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Dec 21, 2009 5:51 pm    Post subject: Reply with quote

Purtroppo l'ipod non viene riconosciuto come /dev/sdc o /dev/sdb o altro.
L'output di dmesg mi riporta questo:

Quote:
505.669657] usb 5-1: New USB device found, idVendor=05ac, idProduct=1293
[ 505.669663] usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 505.669668] usb 5-1: Product: iPod
[ 505.669673] usb 5-1: Manufacturer: Apple Inc.
[ 505.669705] usb 5-1: SerialNumber: 9296a953a070a5dd422bf93217c26a47fea156aa
[ 505.669844] usb 5-1: uevent
[ 505.669903] usb 5-1: usb_probe_device
[ 505.669909] usb 5-1: configuration #1 chosen from 3 choices
[ 505.671383] usb 5-1: adding 5-1:1.0 (config #1, interface 0)
[ 505.671430] usb 5-1:1.0: uevent
[ 505.671524] drivers/usb/core/inode.c: creating file '004'
[ 505.672479] usb 5-1: uevent


Quindi non posso seguire le istruzioni presenti nel wiki al fine di montare il dispositivo.
Che fare?
Ciao
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Mon Dec 21, 2009 6:59 pm    Post subject: Reply with quote

Ciao scusate se mi intrometto, ma tempo fa settai tutto per usare un ipod con amarok e ci riuscii senza problemi.
L'ipod purtroppo non era il mio ma della mia ragazza, quindi ora non potrei fare prove, comunque una cosa che ho dovuto fare è stata la seguente:
creare una regola di udev in modo tale che quando collego l'ipod mi venga associato a /dev/ipod.

Il file è /etc/udev/rules.d/10-ipod.rules :
Code:
KERNEL=="sd[abcdefg]2", ATTRS{idVendor}=="05ac", ATTRS{idProduct}=="1260" NAME="ipod"

Chiaramente idProduct varierà nel tuo caso.

Per il fatto che non venga proprio visto mi sembra strano, non saprei come aiutarti al momento.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum