Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.3.4 non parte piu` [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue Dec 15, 2009 7:26 pm    Post subject: KDE 4.3.4 non parte piu` [risolto] Reply with quote

Ho aggiornato kde 4.3.1 in 4.3.4 ma scopro con mia delusione che non ne vuole sapere piu` di partire...
All`avvio ricevo un messaggio del tipo
Code:
# startx
hostname: Unknown host
xauth: creating new autority file /root/.serverauth.4303
xauth: (stdin):2: unknown command "655db179338d221e00df1f1a90c42ae9"
xauth: (stdin):2: unknown command "655db179338d221e00df1f1a90c42ae9"

Fatal server error:
Server is already active for display 0
   If this server is no longer running, remove /tmp/.X0-lock and start again.

Please consult the The X.Org Foundation support at http://wiki.x.org for help

Inutile dire che h gia` rimosso /tmp/.X0-lock senza nessun risultato e se vado a vedere il og di Xorg leggo
Code:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(EE) Failed to load module "dri2" *module does not exist, 0)
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "xtrap" (module does not exist, 0)


Last edited by mrl4n on Fri Dec 18, 2009 9:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Dec 15, 2009 8:59 pm    Post subject: Re: KDE 4.3.4 non parte piu` Reply with quote

mrl4n wrote:
Ho aggiornato kde 4.3.1 in 4.3.4 ma scopro con mia delusione che non ne vuole sapere piu` di partire...
All`avvio ricevo un messaggio del tipo
Code:
# startx
hostname: Unknown host
xauth: creating new autority file /root/.serverauth.4303


il fatto che non riconosca l'host mi fa pensare a un problema di malconfigurazione del sistema, non a un problema di kde. e anche il fatto che cerchi un file nella cartella di root ...
mrl4n wrote:

Code:
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
(EE) Failed to load module "dri2" *module does not exist, 0)


quello che non parte è X.
davvero non è un problema di kde.
probabilmente hai aggiornato anche il server grafico, ma non tutti i driver:
Code:

emerge -1 `qlist -IC x11-drivers/` -av

_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Tue Dec 15, 2009 9:08 pm    Post subject: Re: KDE 4.3.4 non parte piu` Reply with quote

mrl4n wrote:
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.


X funziona...ora sto scrivendo da qui...e` possibile che ci siano problemi ai driver, rifaro` l`emerge ma ho il sospetto che non risolvero` il problema.

KDE 4.3.1 funzionava, ho aggiornato tutto e questo e` il risultato.

EDIT: ORA, non funziona più
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Wed Dec 16, 2009 6:52 am    Post subject: Reply with quote

Hai riemerso i drivers?
Anche a me è successo, ma ho risolto in modo simile al consiglio di cloc3.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 832
Location: Villach, Austria

PostPosted: Wed Dec 16, 2009 8:43 am    Post subject: Reply with quote

in questi giorni c'è stato un aggiornamento corposo di X
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed Dec 16, 2009 8:33 pm    Post subject: Reply with quote

Mi fa piacere...io sono in un labirinto da cui non ne esco più...
Se completo il boot, piuttosto che accedere alla maschera di login di kde arrivo a quella di X, ma X non parte come pure kde.
Se faccio un'avvio interattivo, riesco ad accedere a kde ma non vanno più nè mouse nè tastiera... :evil: :twisted:
Mai avuti così tanti problemi da un cambio di scheda video.

bandreabis wrote:
Hai riemerso i drivers?
Anche a me è successo, ma ho risolto in modo simile al consiglio di cloc3.


Si :(
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Thu Dec 17, 2009 8:10 pm    Post subject: Reply with quote

Qualche guida di riferimento per Xorg 1.6.5 e kde 4.3.4 su kernel 2.6.31-r6?

Non so più cosa fare...dopo questo mi resta solo il forum inglese.
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Thu Dec 17, 2009 11:52 pm    Post subject: Reply with quote

Gia provato a rifare
Code:
# X -configure
# mv /root/xorg.conf.new /etc/X11/xorg.conf

?
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Dec 18, 2009 3:33 pm    Post subject: Reply with quote

hai fatto un revdep-rebuild ?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Fri Dec 18, 2009 4:20 pm    Post subject: Reply with quote

dopo l'avvio di xorg-server, revdep-rebuild non mi dava problemi sui driver di tastiera e mouse, e invece andavano ricompilato come detto nel thread
_________________
rb
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Fri Dec 18, 2009 7:03 pm    Post subject: Reply with quote

Io ho aggiornato il sistema a kde 4.3.3 e mi sono trovato nell'impossibilità di utilizzare il login manager kdm (era scomparso e al suo posto era presente un'altra finestra di login da cui non era possibile entrare nel sistema), poi mi sono ricordato di impostare, in /etc/conf.d/xdm,la variabile DISPLAYMANAGER a kdm e ho digitato il seguente comando:
Quote:
nano -w /etc/conf.d/xdm
(Modificare la seguente variabile)
DISPLAYMANAGER="kdm"


A questo punto ho digitato:

Quote:
# rc-update add xdm default


Così ho potuto riavviare il sistema grazie a kdm.

Spero possa esserti di aiuto.
Ciao
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Fri Dec 18, 2009 9:07 pm    Post subject: Reply with quote

Sembra proprio la mia situazione...ora provo...per ora grazie.

EDIT: i problemi non mancano, primo tra tutti la corretta installazione della scheda video, però ora kde parte. :D
Grazie
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Fri Dec 18, 2009 9:57 pm    Post subject: Reply with quote

ciro64 wrote:
Gia provato a rifare
Code:
# X -configure
# mv /root/xorg.conf.new /etc/X11/xorg.conf

?


ricordo che da Xorg 1.6, xorg.conf è deprecato :)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum