Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
less displays output in hex format...why??
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
logical_guy
Apprentice
Apprentice


Joined: 18 Sep 2007
Posts: 241

PostPosted: Thu Dec 10, 2009 11:48 am    Post subject: less displays output in hex format...why?? Reply with quote

I tried looking at the cups error log using less and this is what I got:

Code:
# less /var/log/cups/error_log

00000000  49 20 5b 31 38 2f 4e 6f  76 2f 32 30 30 39 3a 31  |I [18/Nov/2009:1|
00000010  37 3a 30 34 3a 34 39 20  2b 30 30 30 30 5d 20 4c  |7:04:49 +0000] L|
00000020  69 73 74 65 6e 69 6e 67  20 74 6f 20 3a 3a 31 3a  |istening to ::1:|
00000030  36 33 31 20 28 49 50 76  36 29 0a 49 20 5b 31 38  |631 (IPv6).I [18|
00000040  2f 4e 6f 76 2f 32 30 30  39 3a 31 37 3a 30 34 3a  |/Nov/2009:17:04:|
00000050  34 39 20 2b 30 30 30 30  5d 20 4c 69 73 74 65 6e  |49 +0000] Listen|
00000060  69 6e 67 20 74 6f 20 31  32 37 2e 30 2e 30 2e 31  |ing to 127.0.0.1|
00000070  3a 36 33 31 20 28 49 50  76 34 29 0a 49 20 5b 31  |:631 (IPv4).I [1|
00000080  38 2f 4e 6f 76 2f 32 30  30 39 3a 31 37 3a 30 34  |8/Nov/2009:17:04|
00000090  3a 34 39 20 2b 30 30 30  30 5d 20 4c 69 73 74 65  |:49 +0000] Liste|
000000a0  6e 69 6e 67 20 74 6f 20  2f 76 61 72 2f 72 75 6e  |ning to /var/run|
000000b0  2f 63 75 70 73 2f 63 75  70 73 2e 73 6f 63 6b 20  |/cups/cups.sock |


Any reason why it does not give me a normal text listing of the file?
With more I get something like this:
Code:
# more /var/log/cups/error_log
I [18/Nov/2009:17:04:49 +0000] Listening to ::1:631 (IPv6)
I [18/Nov/2009:17:04:49 +0000] Listening to 127.0.0.1:631 (IPv4)
I [18/Nov/2009:17:04:49 +0000] Listening to /var/run/cups/cups.sock (Domain)
I [18/Nov/2009:17:04:49 +0000] Remote access is disabled.
I [18/Nov/2009:17:04:49 +0000] Loaded configuration file "/etc/cups/cupsd.conf"
I [18/Nov/2009:17:04:49 +0000] Using default TempDir of /var/spool/cups/tmp...
I [18/Nov/2009:17:04:49 +0000] Configured for up to 100 clients.
I [18/Nov/2009:17:04:49 +0000] Allowing up to 100 client connections per host.
I [18/Nov/2009:17:04:49 +0000] Using policy "default" as the default!
I [18/Nov/2009:17:04:49 +0000] Full reload is required.
I [18/Nov/2009:17:04:49 +0000] Loaded MIME database from '/etc/cups': 35 types, 39 filters...
I [18/Nov/2009:17:04:49 +0000] Full reload complete.
I [18/Nov/2009:17:04:49 +0000] Cleaning out old temporary files in "/var/spool/cups/tmp"...
I [18/Nov/2009:17:04:49 +0000] Listening to ::1:631 on fd 1...
I [18/Nov/2009:17:04:49 +0000] Listening to 127.0.0.1:631 on fd 3...


Anybody have any ideas??? How can I get less to display text like more??

EDIT: less displays output just fine with every other file. its just this one....really strange.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Thu Dec 10, 2009 3:53 pm    Post subject: Reply with quote

Moved from Other Things Gentoo to Duplicate Threads, please see less (pager) showing hex [SOLVED].
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum