Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XEN] DeprecationWarning: the sets module is deprecated
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Wed Dec 09, 2009 8:30 pm    Post subject: [XEN] DeprecationWarning: the sets module is deprecated Reply with quote

Bonjour,

depuis un emerge world, mon xen ne fonctionne plus :

Quote:
# /etc/init.d/xend restart
* Starting Xen control daemon ...
/usr/lib/python2.6/site-packages/xen/xend/XendAPI.py:21: DeprecationWarning: the sets module is deprecated
import sets
/usr/lib/python2.6/site-packages/xen/xend/XendAPI.py:21: DeprecationWarning: the sets module is deprecated
import sets


apparemment, cela viendrait de l'installation de python 2.6.

J'ai pensé que le problème se résoudrait en sélectionnant une ancienne install de python (2.4 par exemple), via les commandes

Quote:
eselect python set 1 et python-updater


Mais ca n'a pas marché.

J'ai ensuite recompiler mon noyau (2.6.21-xen), mais même problème.

Par quelle manip mon xen pourrait il refonctionner ? Je n'ai pas vraiment trouvé de solution sur internet.

Merci
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Dec 09, 2009 10:18 pm    Post subject: Reply with quote

'alute

essais en sélectionnant la version 2.5 de python (et vérifie qu'il est bien compilé avec le use "ssl" au passage) puis réemerge les xen-tools et refait un test pour voir si c'est toujours pareil
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
floc_12
Apprentice
Apprentice


Joined: 28 Jun 2006
Posts: 191

PostPosted: Thu Dec 10, 2009 12:09 pm    Post subject: Reply with quote

Salut boozo, et merci de ta réponse.

J'avais essayé python2.5 avec la commande magique (eselect) mais ca n'avait pas fonctionné.

Je suis finalement repassé en 2.6.20, et je n'ai plus l'erreur. La reinstallation de xen et xen-tool a même reussi :) . Il ne me manque plus qu'a reconfigurer xen.
Je ne pourrais pas m'y remettre d'ici Dimanche et Lundi, mais bon ... je regarderai s'il y a effectivement le ssl (de tête, oui, je crois bien).

Par contre, j'ai une question :

2 Noyaux xen sont dispo (2.6.20-xen et 2.6.21-xen). Ca fait un moment que je galère a avoir une machine stable avec mon 2.6.20 (pourtant, j'essaye de bien tout faire ... ).
J'ai vu sur un tuto que le noyau 2.6.27 était beaucoup plus stable avec xen en le "xénifiant" (installation d'un patch). Qu'en pensez vous ? ca vaudrait le coup d'essayer ca ? Et avec quel noyau d'après vous (emerge m'a telecharge le 2.6.31) ?

Merci
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Dec 10, 2009 5:14 pm    Post subject: Reply with quote

A vrai dire, je ne sais pas si il reste grand monde ici qui utilise encore xen :?:

Et depuis que kvm est passé par là tout le reste est un peu passé de mode mais sur le site du projet y'a encore de quoi faire pour les noyaux récents mais je ne saurais t'en dire plus quant à la stabilité dsl
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum