Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
webcam MS vx1000
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Dec 07, 2009 6:24 pm    Post subject: webcam MS vx1000 Reply with quote

Saluto gli amici del forum.
Dopo aver faticato per settare una webcam philips, questa si è rotta e così ho acquistato la vx1000.
Configurando il kernel ho individuato i drivers appropriati, gspca_sonixj, e li ho settati appunto come moduli.
Finchè ho usato il kernel 2.6.30-r8 tutto bene, i programmi kopete, skype, mplayer e camorama mi permettevano di usare la webcam al meglio.
Venerdì scorso ho aggiornato il sistema come pure il kernel passando alla versione 2.6.31-r6.
Questo ha comportato anche l'aggiornamento dei drivers nvidia passando alla versione, 185.18.36.
Ora quando utilizzo i programmi sopramenzionati e cerco di configurare il dispositivo video ricevo uno schermo verde nonostante questi venga individuato correttamente. Vi posto l'output del seguente comando:
Quote:
# lsmod
Module Size Used by
snd_seq_dummy 2504 0
snd_seq_oss 24736 0
snd_seq_midi_event 5604 1 snd_seq_oss
snd_seq 41904 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 5648 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 34080 0
snd_mixer_oss 12676 1 snd_pcm_oss
nvidia 9577480 39
snd_hda_codec_conexant 17380 1
snd_hda_intel 23400 2
iwl3945 57668 0
snd_hda_codec 50212 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 6280 1 snd_hda_codec
snd_pcm 58696 3 snd_pcm_oss,snd_hda_intel,snd_hda_codec
snd_timer 16588 2 snd_seq,snd_pcm
ehci_hcd 41816 0
gspca_sonixj 18980 0
tifm_7xx1 5028 0
snd 44740 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
firewire_ohci 19400 0
firewire_core 38656 1 firewire_ohci
sdhci_pci 6724 0
gspca_main 18916 1 gspca_sonixj
videodev 31328 1 gspca_main
iwlcore 89092 1 iwl3945
v4l1_compat 11944 1 videodev
sdhci 15016 1 sdhci_pci
mmc_core 42880 1 sdhci
tifm_core 6304 1 tifm_7xx1
soundcore 5632 1 snd
crc_itu_t 1636 1 firewire_core
snd_page_alloc 7628 2 snd_hda_intel,snd_pcm


Vorrei capire se il problema dipende da nvidia o altro.
Vi ringrazio
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Dec 07, 2009 9:12 pm    Post subject: Reply with quote

che io sappia non c'e alcuna connessione tra l'aggiornamento del kernel e i driver nvidia...anche perchè se segui le guide ufficiali dicono di non buildare nvidia all'interno del kernel ma usare i x11-drivers/nvidia-drivers, i quali vengono scaricati e installati automaticamente settando la variabile VIDEO_CARDS in make.conf cosi come segue:
Code:
VIDEO_CARDS="nvidia"


tornando al problema..me ne è capitato uno simile...sempre con webcam..in una versione precedente di kernel funzionava..mentre con una superiore no(pur essendoci il modulo).
Quello che ti consiglio è di vedere se il modulo viene caricato..altrimenti prova con modprobe...(dal tuo post non capisco se è l'output del .30-r8 o .31-r6)
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Dec 08, 2009 12:11 am    Post subject: Reply with quote

prova a mettere l'ultima versione ~ dei drivers. Può essere che quella marcata stabile sia troppo vecchia per il tuo kernel e non funzioni bene.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Tue Dec 08, 2009 11:11 am    Post subject: Reply with quote

L'output di lsmod si riferisce al kernel 2.6.31-r6, e i moduli vengono caricati come accadeva con il precedente kernel.
Probabilmente mi sono espresso male parlando dell'aggiornamento del kernel infatti non ho modificato alcuna impostazione relativa alla voce device driver -->
graphics.e ho semplicemente emerso nvidia-drivers come dicevi tu ago88.
I drivers nvidia presenti sul mio sistema sono quelli che risultano dal seguente output:
Quote:
eix nvidia-drivers
[D] x11-drivers/nvidia-drivers
Available versions: 71.86.09!s ~71.86.11!s 96.43.13!s ~173.14.18!s[1] 173.14.20!s ~173.14.20-r1!s 173.14.20-r1!s[2] 180.60!s ~185.18.36!s ~185.18.36-r1!s ~190.42-r1!s ~190.42-r2!s {acpi custom-cflags gtk kernel_FreeBSD kernel_linux multilib userland_BSD}
Installed versions: 185.18.36!s(11:52:06 08/12/2009)(acpi kernel_linux -custom-cflags -gtk -multilib)
Homepage: http://www.nvidia.com/
Description: NVIDIA X11 driver and GLX libraries

[1] "gentoo-quebec" /usr/local/portage/layman/gentoo-quebec
[2] "sabayon" /usr/local/portage/layman/sabayon


Ho provato a reinstallarli come suggerito da Onip ma rimane tutto come prima.
Vorrei a questo punto postarvi altri output nella speranza di trovare una soluzione:

Quote:
$ LD_PRELOAD=/usr/lib64/libv4l/v4l2convert.so kopete
ERROR: ld.so: object '/usr/lib64/libv4l/v4l2convert.so' from LD_PRELOAD cannot be preloaded: ignored.
No protocol specified
kopete: cannot connect to X server :0.0



Quote:
$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama
No protocol specified

(camorama:10646): Gtk-WARNING **: cannot open display: :0.0



Quote:
$ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
No protocol specified


Vi ringrazio.

Ciao
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Tue Dec 08, 2009 11:21 am    Post subject: Reply with quote

Epicuro wrote:
Probabilmente mi sono espresso male parlando dell'aggiornamento del kernel infatti non ho modificato alcuna impostazione relativa alla voce device driver

fa nulla....
cmq giusto per aggiungerei gtk e custom-cflags

cmq credo che onip dicesse di smascherare i driver per poter utilizzare quelli beta..dopo dovresti avere una cosa del genere:
Code:

[I] x11-drivers/nvidia-drivers
     Available versions:  71.86.09!s 71.86.11!s 96.43.13!s (~)96.43.14!s 173.14.20!s (~)173.14.20-r1!s (~)173.14.22!s 180.60!s 185.18.36!s (~)185.18.36-r1!s (~)190.29!s (~)190.42-r2!s (~)190.42-r3!s {acpi custom-cflags gtk kernel_FreeBSD kernel_linux multilib userland_BSD}
     Installed versions:  190.42-r3!s(22:05:15 20/11/2009)(acpi custom-cflags gtk kernel_linux -multilib)
     Homepage:            http://www.nvidia.com/
     Description:         NVIDIA X11 driver and GLX libraries


ma hai provato un revdep-rebuild?
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Dec 08, 2009 11:30 am    Post subject: Reply with quote

Epicuro wrote:

Ho provato a reinstallarli come suggerito da Onip ma rimane tutto come prima.


Veramente ti avevo consigliato di mettere gli ultimi ~, non quelli stabili. Ma, ad ogni modo, avevo letto male io il tuo post e avevo capito che lo schermo verde fosse quello di X, non quello della cam, colpa mia. Se X parte i driver vanno bene e non dovrebbero centrare.

Passando ad altro, aggiornando il kernel hai copiato il vecchio config al posto del nuovo e dato make oldconfig ? Oppure hai controllato in menuconfig che tutte le voci necessarie siano abilitate?
Come mai lanci i programmi specificando LD_PRELOAD? Io, le poche volte che ho giocato con la webcam, non ne ho avuto bisogno.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Tue Dec 08, 2009 11:58 am    Post subject: Reply with quote

Non ho copiato il vecchio .config ma ho eseguito make menuconfig abilitando moduli e supporti come dal precedente .config.
Le voci abilitate sono queste:
Quote:
Multimedia core support
#
CONFIG_VIDEO_DEV=m
CONFIG_VIDEO_V4L2_COMMON=m
# CONFIG_VIDEO_ALLOW_V4L1 is not set
CONFIG_VIDEO_V4L1_COMPAT=y
# CONFIG_DVB_CORE is not set
CONFIG_VIDEO_MEDIA=m

#
# Multimedia drivers
#
# CONFIG_MEDIA_ATTACH is not set
CONFIG_MEDIA_TUNER=m
# CONFIG_MEDIA_TUNER_CUSTOMISE is not set
CONFIG_MEDIA_TUNER_SIMPLE=m
CONFIG_MEDIA_TUNER_TDA8290=m
CONFIG_MEDIA_TUNER_TDA9887=m
CONFIG_MEDIA_TUNER_TEA5761=m
CONFIG_MEDIA_TUNER_TEA5767=m
CONFIG_MEDIA_TUNER_MT20XX=m
CONFIG_MEDIA_TUNER_XC2028=m
CONFIG_MEDIA_TUNER_XC5000=m
CONFIG_MEDIA_TUNER_MC44S803=m
CONFIG_VIDEO_V4L2=m
CONFIG_VIDEO_CAPTURE_DRIVERS=y
# CONFIG_VIDEO_ADV_DEBUG is not set
# CONFIG_VIDEO_FIXED_MINOR_RANGES is not set
CONFIG_VIDEO_HELPER_CHIPS_AUTO=y
# CONFIG_VIDEO_VIVI is not set
# CONFIG_VIDEO_BT848 is not set
# CONFIG_VIDEO_SAA5246A is not set
# CONFIG_VIDEO_SAA5249 is not set
# CONFIG_VIDEO_ZORAN is not set
# CONFIG_VIDEO_SAA7134 is not set
# CONFIG_VIDEO_HEXIUM_ORION is not set
# CONFIG_VIDEO_HEXIUM_GEMINI is not set
# CONFIG_VIDEO_CX88 is not set
# CONFIG_VIDEO_IVTV is not set
# CONFIG_VIDEO_CAFE_CCIC is not set
# CONFIG_SOC_CAMERA is not set
CONFIG_V4L_USB_DRIVERS=y
# CONFIG_USB_VIDEO_CLASS is not set
CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y
CONFIG_USB_GSPCA=m
CONFIG_USB_M5602=m
CONFIG_USB_STV06XX=m
CONFIG_USB_GSPCA_CONEX=m
CONFIG_USB_GSPCA_ETOMS=m
CONFIG_USB_GSPCA_FINEPIX=m
CONFIG_USB_GSPCA_MARS=m
CONFIG_USB_GSPCA_MR97310A=m
CONFIG_USB_GSPCA_OV519=m
CONFIG_USB_GSPCA_OV534=m
CONFIG_USB_GSPCA_PAC207=m
CONFIG_USB_GSPCA_PAC7311=m
CONFIG_USB_GSPCA_SN9C20X=m
CONFIG_USB_GSPCA_SN9C20X_EVDEV=y
CONFIG_USB_GSPCA_SONIXB=m
CONFIG_USB_GSPCA_SONIXJ=m
CONFIG_USB_GSPCA_SPCA500=m
CONFIG_USB_GSPCA_SPCA501=m
CONFIG_USB_GSPCA_SPCA505=m
CONFIG_USB_GSPCA_SPCA506=m
CONFIG_USB_GSPCA_SPCA508=m
CONFIG_USB_GSPCA_SPCA561=m
CONFIG_USB_GSPCA_SQ905=m
CONFIG_USB_GSPCA_SQ905C=m
CONFIG_USB_GSPCA_STK014=m
CONFIG_USB_GSPCA_SUNPLUS=m
CONFIG_USB_GSPCA_T613=m
CONFIG_USB_GSPCA_TV8532=m
CONFIG_USB_GSPCA_VC032X=m
CONFIG_USB_GSPCA_ZC3XX=m
# CONFIG_VIDEO_PVRUSB2 is not set
# CONFIG_VIDEO_HDPVR is not set
# CONFIG_VIDEO_EM28XX is not set
# CONFIG_VIDEO_CX231XX is not set
# CONFIG_VIDEO_USBVISION is not set
# CONFIG_USB_ET61X251 is not set
# CONFIG_USB_SN9C102 is not set
# CONFIG_USB_ZC0301 is not set
CONFIG_USB_PWC_INPUT_EVDEV=y
# CONFIG_USB_ZR364XX is not set
# CONFIG_USB_STKWEBCAM is not set
# CONFIG_USB_S2255 is not set
CONFIG_RADIO_ADAPTERS=y
# CONFIG_RADIO_GEMTEK_PCI is not set
# CONFIG_RADIO_MAXIRADIO is not set
# CONFIG_RADIO_MAESTRO is not set
# CONFIG_USB_DSBR is not set
# CONFIG_USB_SI470X is not set
# CONFIG_USB_MR800 is not set
# CONFIG_RADIO_TEA5764 is not set
CONFIG_DAB=y
# CONFIG_USB_DABUSB is not set


In verità il comando LD_PRELOAD l'ho trovato sfogliando alcuni post, comunque anche lanciando i programmi attraverso Kickoff lancia applicazioni di kde 4.3.1 ottengo il medesimo risultato.

Perdona la mia nubbiaggine Onip adesso ho capito cosa significa ~.
Ciao e ancora grazie
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Dec 08, 2009 12:27 pm    Post subject: Reply with quote

Epicuro wrote:

Perdona la mia nubbiaggine Onip adesso ho capito cosa significa ~.


Se un pacchetto è marcato x86 vuol dire che è considerato stabile per le architetture x86. Al contrario ~x86 indica un software considerato instabile. Stabile\instabile riguardano esclusivamente la distribuzione, non ricalcano quanto considerato dai gestori\manutentori\sviluppatori del tal software. In generale un pacchetto viene inserito in portage come ~ e, se per 30 giorni non si manifestano problemi, viene marcato stabile.
In caso di problemi noti e gravi il pacchetto viene messo come hardmasked.

Riguardo al kernel io un tentativo con oldconfig lo farei, potrebbe sempre essere che ti sia sfuggito qualcosa. Purtroppo è poco probabile in quanto dici che il device video viene creato e quindi il kernel, in teoria, riconosce la tua periferica.

una prova che puoi fare è, da root, lanciare
Code:
# tail -f /var/log/messages

e poi da utente lanciare un'applicazione che accede alla webcam e vedere se nel terminale con il log viene dato qualche messaggio significativo.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Tue Dec 08, 2009 12:55 pm    Post subject: Reply with quote

Ho lanciato nell'ordine, kopete, skype, xawtv, ekiga e mplayer e questo è l'output:
Quote:
# tail -f /var/log/messages
Dec 8 13:00:01 Hall9000 cron[13407]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:10:01 Hall9000 cron[13844]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:20:01 Hall9000 cron[14217]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:25:35 Hall9000 su[10718]: pam_unix(su:session): session closed for user root
Dec 8 13:25:40 Hall9000 su[10621]: pam_unix(su:session): session closed for user eddie
Dec 8 13:25:40 Hall9000 su[4680]: pam_unix(su:session): session closed for user root
Dec 8 13:30:01 Hall9000 cron[14617]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:30:05 Hall9000 su[14612]: Successful su for root by eddie
Dec 8 13:30:05 Hall9000 su[14612]: + pts/1 eddie:root
Dec 8 13:30:05 Hall9000 su[14612]: pam_unix(su:session): session opened for user root by eddie(uid=1000)
Dec 8 13:30:43 Hall9000 kernel: [ 6604.747538] uhci_hcd 0000:00:1d.1: reserve dev 3 ep81-ISO, period 1, phase 0, 807 us
Dec 8 13:31:25 Hall9000 kernel: [ 6646.966517] uhci_hcd 0000:00:1d.1: release dev 3 ep81-ISO, period 1, phase 0, 807 us
Dec 8 13:40:01 Hall9000 cron[15006]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:49:32 Hall9000 kernel: [ 7734.289870] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
Dec 8 13:49:36 Hall9000 kernel: [ 7738.340030] CE: hpet increasing min_delta_ns to 33750 nsec
Dec 8 13:49:49 Hall9000 kernel: [ 7751.140685] uhci_hcd 0000:00:1d.1: reserve dev 3 ep81-ISO, period 1, phase 0, 807 us
Dec 8 13:50:01 Hall9000 cron[15404]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Dec 8 13:50:08 Hall9000 kernel: [ 7769.929651] uhci_hcd 0000:00:1d.1: release dev 3 ep81-ISO, period 1, phase 0, 807 us
Dec 8 13:52:05 Hall9000 kernel: [ 7887.255702] uhci_hcd 0000:00:1d.1: reserve dev 3 ep81-ISO, period 1, phase 0, 807 us



Ciao
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Tue Dec 15, 2009 6:08 pm    Post subject: Reply with quote

Ciao ragazzi dovete scusarmi ma ancora sono alle prese con il problema della webcam.
Ho provato a vedere su google e su altri forum se esisteva un problema come il mio ma non ho trovato nulla di simile.
Vorrei inviarvi l'output del comando usato per lanciare le applicazioni che usano la webcam:

Quote:
eddie@Hall9000 ~ $ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama

(camorama:7000): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: unknown huffman code: 0000ffd9
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
eddie@Hall9000 ~ $ LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so kopete
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
eddie@Hall9000 ~ $ VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument
VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 6 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits


e questo:

Quote:
eddie@Hall9000 ~ $ LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so kopete
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
eddie@Hall9000 ~ $ VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument
VIDIOC_ENUMSTD: Invalid argument
VIDIOC_ENUM_FMT: Invalid argument
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 3 more bits
^C


Potreste inviarmi un suggerimento?
Grazie
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Wed Dec 23, 2009 6:33 pm    Post subject: Reply with quote

Un saluto agli amici del forum,
non riesco a farla funzionare questa benedetta webcam, mi viene il dubbio che manchi qualche libreria dal momento che i moduli del kernel vengono caricati correttamente.
Qualche suggerimento?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum