Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo brings up my network device even if I don't want to
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
inp3dance
n00b
n00b


Joined: 22 Jan 2008
Posts: 17

PostPosted: Sun Dec 06, 2009 9:51 pm    Post subject: gentoo brings up my network device even if I don't want to Reply with quote

Hi,

I have some strange things going on. I removed the net.eth0 script from the default runlevel, to bring up my network device when I need it, but with net.lo starts net.eth0 too. When udev starts, it says something like: device initiated services: net.eth0 , so I guess that is guilty, but I don't know exactly why want udev to start the net.eth0 service and how to stop doing that.

But the strangest thing is when net.eth0 starts, eth0 gets ip address from the dhcp, but I still can't go online. When I manually start the dhcpcd on eth0, the network connection works.

/var/log/rc.log:

rc boot logging started at Mon Dec 7 01:18:10 2009

* Setting system clock using the hardware clock [Local Time]...
[ ok ]
* Autoloaded 0 module(s)
* Checking local filesystems ...
WARNING: bad format on line 31 of /etc/fstab
Gentoo: clean, 108221/1022000 files, 881341/4084518 blocks (check after next mount)
/dev/sda3: clean, 41/76608 files, 47306/305232 blocks
[ ok ]
* Remounting root filesystem read/write...
[ ok ]
* Updating /etc/mtab...
[ ok ]
* Mounting local filesystems...
[ ok ]
* Setting hostname to Dante...
[ ok ]
* Configuring kernel parameters...
[ ok ]
* Creating user login records...
[ ok ]
* Cleaning /var/run...
[ ok ]
* Wiping /tmp directory...
[ ok ]
* Setting terminal encoding [UTF-8]...
[ ok ]
* Setting console font [default8x16]...
[ ok ]
* Setting keyboard mode [UTF-8]...
[ ok ]
* Loading key mappings [us]...
[ ok ]
* Bringing up interface lo
* 127.0.0.1/8...
[ ok ]
* Adding routes
* 127.0.0.0/8 via 127.0.0.1...
[ ok ]
* Bringing up interface eth0
* No configuration specified; defaulting to DHCP
* dhcp...
* Running dhcpcd...
eth0: dhcpcd 4.0.15 starting
eth0: waiting for carrier
eth0: carrier acquired
eth0: broadcasting for a lease
eth0: offered 192.168.0.151 from 192.168.0.1
eth0: acknowledged 192.168.0.151 from 192.168.0.1
eth0: checking 192.168.0.151 is available on attached networks
eth0: leased 192.168.0.151 for 604800 seconds
[ ok ]
* received address 192.168.0.151/24
[ ok ]
* Starting network
[ ok ]
* Mounting USB device filesystem [usbfs]...
[ ok ]
* Mounting misc binary format filesystem...
[ ok ]
* Adding static routes...
SIOCADDRT: No such process
[ ok ]
* Activating swap devices...
[ ok ]
* Initializing random number generator...
[ ok ]

rc boot logging stopped at Sun Dec 6 23:18:23 2009

$ ls /etc/runlevels/boot/
$ bootmisc consolefont fsck hostname hwclock keymaps localmount modules mtab net.lo network procfs root staticroute swap sysctl termencoding urandom


$ ls /etc/runlevels/sysinit/
$ devfs dmesg udev


$ ls /etc/runlevels/default/
$ acpid hald local udev-postmount

Using openrc-0.5.3, baselayout-2.0.1, sysvinit-2.87-r1 on gentoo amd64, gcc 4.4.2, kernel-2.6.32-gentoo

Can somebody help me with the above problems?

Thank you in advice!
Back to top
View user's profile Send private message
WastingBody
Tux's lil' helper
Tux's lil' helper


Joined: 09 May 2008
Posts: 105

PostPosted: Sun Dec 06, 2009 11:41 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-804861.html
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2671
Location: here, there or in transit

PostPosted: Mon Dec 07, 2009 12:03 am    Post subject: Reply with quote

Moved from Other Things Gentoo to Duplicate Threads, see thread referenced above.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum