Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDS 4.3 internationalisation ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Thu Dec 03, 2009 12:12 pm    Post subject: [SOLVED] KDS 4.3 internationalisation ? Reply with quote

Hello,

I have no i18n package in portage for KDE 4.3 ...

Only for KDE 3.5.10

Where should I start looking for internationalizing KDE 4.3 ?

Thanks in advance


Last edited by yfh2 on Wed Dec 16, 2009 1:10 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Thu Dec 03, 2009 12:16 pm    Post subject: Reply with quote

You want this: http://packages.gentoo.org/package/kde-base/kde-l10n
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Thu Dec 03, 2009 3:03 pm    Post subject: Reply with quote

Thanks, but I have this ...
My understanding is this is the 'localisation' package.

If it's the package where the translation are, they don't appear, though I have set things in 'systemsettings' ...
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Dec 03, 2009 5:58 pm    Post subject: Reply with quote

Hi, can you post yout emerge --info plz.
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Thu Dec 03, 2009 9:09 pm    Post subject: Reply with quote

Here it is :

Code:

fanless4 eb # emerge --info
Portage 2.1.6.13 (default/linux/amd64/10.0, gcc-4.3.4, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================                                     
System uname: Linux-2.6.30-gentoo-r5-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_3800+-with-gentoo-1.12.13                                                                                               
Timestamp of tree: Tue, 01 Dec 2009 08:15:02 +0000                                                     
app-shells/bash:     4.0_p28                                                                           
dev-java/java-config: 2.1.9-r1                                                                         
dev-lang/python:     2.6.2-r1                                                                         
dev-util/cmake:      2.6.4-r3                                                                         
sys-apps/baselayout: 1.12.13                                                                           
sys-apps/sandbox:    1.6-r2                                                                           
sys-devel/autoconf:  2.13, 2.63-r1                                                                     
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2                                                       
sys-devel/binutils:  2.18-r3                                                                           
sys-devel/gcc-config: 1.4.1                                                                           
sys-devel/libtool:   2.2.6a                                                                           
virtual/os-headers:  2.6.27-r2                                                                         
ACCEPT_KEYWORDS="amd64"                                                                               
CBUILD="x86_64-pc-linux-gnu"                                                                           
CFLAGS="-O3 -march=k8 -mtune=k8 -pipe"                                                                 
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ ftp://mirrors.ipv6.linuxant.fr/distfiles.gentoo.org/ "
LDFLAGS="-Wl,-O1"
LINGUAS="fr en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 acl acpi alsa amd64 berkdb bzip2 cdr cli cracklib crypt cups dbus divx4linux dri dvb dvd font-server fortran gdbm gphoto2 gpm hal iconv ipv6 kde lirc lm_sensors mad mmx mmxext mng modules mudflap multilib mysql ncurses nls npp nptl nptlonly nsplugin openexr opengl openmp oss pam pcre perl png ppds pppd python qt3support qt4 readline reflection samba scanner session spl sql sse sse2 ssl svg sysfs tcpd threads tiff truetype unicode usb v4l v4l2 webkit xorg xvid zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr en" LIRC_DEVICES="avermedia creative devinput inputlirc userspace" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Thu Dec 03, 2009 9:33 pm    Post subject: Reply with quote

You should set LANG in /etc/make.conf according to your preferences (blank separated list if you want more than one language).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Dec 04, 2009 1:53 am    Post subject: Reply with quote

Hi, I use this :

Code:

# cat /etc/env.d/02locales
LANG="fr_CA.UTF-8"
LANGUAGE="fr_CA.UTF-8"


Also, make sure that you have this set of your USE flags :

Code:

nls truetype userlocales unicode


After that run this :

Code:

# emerge -auDNv world


And reboot your box, your KDE will have the option to be in French.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Fri Dec 04, 2009 2:04 am    Post subject: Reply with quote

Also important in that context is LINGUAS which usually affects the installation of dictionaries, docs, templates etc. Also to be set in make.conf.

Where's LANGUAGE used? emerge -pvN didn't come up with any related stuff when I set it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Dec 04, 2009 1:02 pm    Post subject: Reply with quote

Did you try :

Code:

# emerge -auDNv world
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7138
Location: Austria

PostPosted: Fri Dec 04, 2009 2:37 pm    Post subject: Reply with quote

d2_racing wrote:
Did you try :

Code:

# emerge -auDNv world

-N should cover any affected ebuilds, anyway, I'll try when I have access to my notebook. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Fri Dec 04, 2009 10:28 pm    Post subject: Reply with quote

Maybe he needs the D.
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Sat Dec 05, 2009 2:37 pm    Post subject: Reply with quote

Well, I have tried to set the USE flags with
Quote:

nls truetype userlocales unicode


and run
Code:

# emerge -auDNv world


but no package came up to be re-emerged ...

Also, I know the french language has been installed when I emerged kde-l10n

I can choose 'french' in the system settings, and it works for 'some' parts of KDE, like the start menu, and application names in this menu. It also works for the 'systemsettings' applet names, but overall, I don't get ANY applications menu in french.

Even Konqueror, where there is the possibility to switch the application language, does not work.

:-(
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Tue Dec 08, 2009 11:06 pm    Post subject: Reply with quote

d2_racing wrote:
Hi, I use this:
Code:
# cat /etc/env.d/02locales
LANG="fr_CA.UTF-8"
LANGUAGE="fr_CA.UTF-8"


I had the same problem, solved with the above tip.
Try to follow the "Gentoo Localization Guide", especially Par.3 - Locale System.
Back to top
View user's profile Send private message
monkeygirl
n00b
n00b


Joined: 08 Feb 2004
Posts: 62

PostPosted: Wed Dec 09, 2009 4:36 pm    Post subject: Reply with quote

When you emerge your files you need to make sure your linguas are set in the order of your language preference as some applications like mplayer default to the first language option regardless of what your system language is. You will not use i18n for KDE 4.

If you've already updated your system with the your LINGUAS options but without result, double check your KDE Country/Region & Language settings.

I'm using KDE 4.3 and my make.conf is set to LINGUAS="en ja" so that I can easily switch between English and Japanese. If this is what you're talking about... ?

http://m5b.org/ss/linguas.png http://m5b.org/ss/linguas1.png
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Mon Dec 14, 2009 7:13 pm    Post subject: Reply with quote

As a matter of fact, LINGUAS are set as this :
LINGUAS="fr en"

I have emerged kde-l10n, which gets the french language ok, but NOTHING gets translated, apart from a couple of items, like the KDE menu entries ...

I have also set the french language in KDE system settings, but still no game ...
Back to top
View user's profile Send private message
firephoto
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1604
Location: +48° 5' 23.40", -119° 48' 30.00"

PostPosted: Mon Dec 14, 2009 8:54 pm    Post subject: Reply with quote

As others have said if you don't have your /etc/locale.gen and /etc/env.d/02locale set strange things happen in a KDE environment even on an english install.

If you follow the localization and unicode guides and get the above items set then restart xdm or your session your desired language should work.

I had to go through this again last night on a new install because without it set google suggest in Arora doesn't work as strange as this may seem.

Here I have set...

Code:

# /etc/locale.gen
en_US ISO-8859-1
en_US.UTF-8 UTF-8


Code:

# /etc/env.d/02locale
LANG="en_US.UTF-8"

_________________
#gentoo-kde on freenode
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Wed Dec 16, 2009 1:09 am    Post subject: Reply with quote

Ok, that was my 'locale.gen' which was not properly set : I had no fr_Fr@euro, and I added fr_FR.UTF-8

Thanks !
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 16, 2009 4:34 am    Post subject: Reply with quote

Nice, at last :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum