Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] turn numlock on after boot?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Thu Dec 03, 2009 8:50 am    Post subject: [SOLVED] turn numlock on after boot? Reply with quote

Hi All

I have kde 4.1 install but cannot get numlock to turn on during bootup - I have it in my default run level but still numlock does not turn on - any other things to checks?

Cheers
Shelton.
_________________
answer an unanswered post:
https://forums.gentoo.org/search.php?search_id=unanswered


Last edited by shazam75 on Fri Dec 04, 2009 11:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
Aquiles
Apprentice
Apprentice


Joined: 23 Feb 2007
Posts: 230
Location: Somewhere, surrounded by my circumstances.

PostPosted: Thu Dec 03, 2009 8:55 am    Post subject: Reply with quote

I don't know about kde4, but in kde3 it was possible to automatically activate numlock after login. Perhaps you can find it in the keyboard configuration panel in "system settings".
_________________
Aquiles
Back to top
View user's profile Send private message
yfh2
Apprentice
Apprentice


Joined: 20 May 2004
Posts: 242

PostPosted: Thu Dec 03, 2009 12:05 pm    Post subject: Reply with quote

You can add 'numlock' to the init scripts
Code:

rc-update add numlock default


But it seems KDE won't keep the numlock state when it start,
So you will have to go to the systems settings / keyboard to enable it in KDE
Back to top
View user's profile Send private message
Apheus
Apprentice
Apprentice


Joined: 12 Jul 2008
Posts: 205

PostPosted: Thu Dec 03, 2009 6:16 pm    Post subject: Reply with quote

Numlock is off after boot, except if the numlock service is running:
Code:
rc-update add numlock default


KDM switches it off again - except if you have in /usr/share/config/kdm/kdmrc:

Code:
...
[X-*-Greeter]
NumLock=On


Logging in switches it off again, except you said something else in your keyboard settings:

systemsettings - keyboard & mouse - NumLock on KDE Startup "On" or "Unchanged"

(this is ~/.kde4/share/config/kcminputrc:

Code:
[Keyboard]
Numlock=0


Someone does not want to let us use the numpad :roll:
Back to top
View user's profile Send private message
shazam75
Guru
Guru


Joined: 18 Mar 2006
Posts: 562
Location: Brisbane, Australia

PostPosted: Fri Dec 04, 2009 11:06 pm    Post subject: Reply with quote

yes thanks - after I did a search on google I found a post and you have to do this:

Code:
vi ~/.kde4/share/config/kcminputrc
 


Code:
[Keyboard]
NumLock=0


This worked :)

Cheers
Shelton.
_________________
answer an unanswered post:
https://forums.gentoo.org/search.php?search_id=unanswered
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2671
Location: here, there or in transit

PostPosted: Sat Dec 05, 2009 12:12 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads.

See [SOLVED] Activate numlock on KDE.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum