Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Encodage] Utiliser ISO
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
[vector]
Apprentice
Apprentice


Joined: 02 Nov 2004
Posts: 170
Location: France, Le Havre

PostPosted: Mon Nov 30, 2009 1:47 pm    Post subject: [Encodage] Utiliser ISO Reply with quote

Bonjour,

Après qu'une barette mémoire m'a laché, j'ai procédé à une réinstallation. Je souhaite sur ce PC utiliser ISO-8859-1(5) en en_US. Le problème est que je n'arrive pas à avoir un comportement correct avec les accents dans la console (tty, c'est un serveur sans X).

Je peux taper "é" qui s'affichera bien dans la console, mais si je fais retour arrière, deux caractères peuvent être supprimés. De plus, si je monte une partion Reiserfs qui contient des fichiers dont les noms sont encodés en ISO, ils ne s'affichent pas correctement.

De plus, si je fais le test suivant :
Code:

echo "aéa" | hexdump -C

cela donne : 61 c3 a9 61 ce qui est de l'UTF-8.

De même, un :
Code:

echo -e "\xe9"

ne s'affiche pas correctement.
Alors qu'un :
Code:

echo -e "\xc3\xa9"

affiche 'é'.

Or, ma configuration est :
Code:

#locale.gen

en_US ISO-8859-1
fr_FR ISO-8859-1
fr_FR@euro ISO-8859-15


Code:

#env.d/02locale

LANG="en_US"
LC_COLLATE="C"


Code:

# /etc/conf.d/consolefont
CONSOLEFONT="lat0-16"

#CONSOLETRANSLATION="8859-15_to_uni"


Code:

# /etc/conf.d/keymaps
KEYMAP="fr-latin1"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS=""
#EXTENDED_KEYMAPS="backspace keypad euro"
DUMPKEYS_CHARSET=""


De même si je fais 'echo "aéa" | hexdump -C' sur le LiveCD actuel, j'ai le même comportement. Mais si je fais ça sur un vieux 2004.1, j'ai le comportement qui me semble correct: il renvoie 61 e9 61.

D'ailleurs, si je partage via Samba la partition Reiserfs, les accents sont corrects sour Windows avec la configuration :
Code:

unix charset = ISO8859-15
dos charset = 850


Comment se fait-il que le système semble utiliser UTF-8 au lieu de l'ISO demandé ?
Merci d'avance.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7894
Location: ~Brussels - Belgique

PostPosted: Mon Nov 30, 2009 1:50 pm    Post subject: Reply with quote

vérifie aussi dans /etc/rc.conf (ou /etc/conf.d/rc) que UNICODE est à "no".
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
[vector]
Apprentice
Apprentice


Joined: 02 Nov 2004
Posts: 170
Location: France, Le Havre

PostPosted: Mon Nov 30, 2009 2:11 pm    Post subject: Reply with quote

Oui, j'ai effectivement oublié de le préciser, UNICODE est à no.
Back to top
View user's profile Send private message
[vector]
Apprentice
Apprentice


Joined: 02 Nov 2004
Posts: 170
Location: France, Le Havre

PostPosted: Mon Nov 30, 2009 3:30 pm    Post subject: Reply with quote

Je suis tombé sur https://bugs.gentoo.org/214981 et effectivement la solution donnée vt.default_utf8=0 fonctionne pour moi.

Cependant, je n'ai pas trouvé trouvé de doc sur cette option ni si c'est possible de le faire à la compilation du noyau.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum