Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dopo emerge -DuNav world errori da tutte le parti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Wed Nov 25, 2009 12:56 pm    Post subject: dopo emerge -DuNav world errori da tutte le parti Reply with quote

come al solito ho un problema dopo una (faticata) procedura di emerge -DuNav world...dopo aver effettuato questa procedura e riavviato il sistema nella fase di montaggio delle partizioni mi esce ils eguente errore(tutto ciò ke ho saputo ricopiare siccome non sò come risalire ad un log o cose simili)
Code:

Waiting for event to be process:
Udev[15608]:Udev. missing using sysfs features, please update the kernel's or disable the kernel's CONFIG_SYSFS_DEPRECATED option, udev may fail to work correctly


poi mi sembra di aver letto anche una cosa del genere
Code:
Populating /dev ecc...

ma non sono riuscito a vedere di più e il guaio e che cene sono anceh altri ma nono riesco a leggerli siccome la pagina scorre inesorabile :S...ora il problema è :
l'errore mi dice o di disabilitare il kernel oppure una opzione chiamata CONFIG_SYSFS_DEPRECATED siccome udev ha fallito e non funziona correttamente

ma siccome ho paura di fare guai....cosa dovrei fare esattamente? cosa mi consigliate di fare? e quella variabile dove posso trovarla?
(sto in un pallone ma dovete perdonarmi per ora di gentoo ne capisco poco appunto x questo l'ho installato x cercare di imparare un pò di più di Linux)
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Wed Nov 25, 2009 1:12 pm    Post subject: Reply with quote

revdep-rebuild da chroot
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Nov 25, 2009 1:15 pm    Post subject: Reply with quote

Basta che leggi, c'è tutto scritto:
Quote:
Udev. missing using sysfs features
manca qualcosa in sysfs o nella sua configurazione; per caso hai aggiornato udev l'ultima volta senza dare un etc-update o un dispatch-conf (se non ricordo male udev fa aggiornare molti file di configurazione)? Altrimenti c'è qualcosa di sbagliato nel kernel.
Quote:
please update the kernel
che versione del kernel hai?
Quote:
or disable the kernel's CONFIG_SYSFS_DEPRECATED option
"oppure disabilita l'opzione CONFIG_SYSFS_DEPRECATED all'interno del kernel", non mi sembra che si possa equivocare.

Come dice djinnz, livecd+chroot e prova a riparare.
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Wed Nov 25, 2009 4:39 pm    Post subject: Reply with quote

il kernel ho la 2.6.30-gentoo-r8 ora provo la vostra soluzione vi terrò aggiornati
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Wed Nov 25, 2009 6:35 pm    Post subject: Reply with quote

niente da fare! ho fatto come dicevate con revdep-rebuild ma l'errore melo riscontra cmq mi ha solo reinstallato un plugin di audacious che installai e poi rimosso poco dopo...ma 1 domanda...potrebbe causarmi danni irreversibili questo errore? siccome molte impostazioni mi si sono sballate :S
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Nov 25, 2009 9:14 pm    Post subject: Reply with quote

Che dice grep SYSFS /usr/src/linux/.config ?
Hai provato a ricompilare udev?
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Wed Nov 25, 2009 9:17 pm    Post subject: Reply with quote

Code:
gentoo ~ # grep CONFIG_SYSFS_DEPRECATED /usr/src/linux/.config
CONFIG_SYSFS_DEPRECATED=y
CONFIG_SYSFS_DEPRECATED_V2=y

si ho rimosso e reinstallato udev ma non cambia niente
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Nov 25, 2009 10:32 pm    Post subject: Reply with quote

Quiz: tra
Quote:
disable the kernel's CONFIG_SYSFS_DEPRECATED option
(post iniziale) e
Quote:
CONFIG_SYSFS_DEPRECATED=y
CONFIG_SYSFS_DEPRECATED_V2=y
non noti alcuna incongruenza?
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Thu Nov 26, 2009 10:21 am    Post subject: Reply with quote

bhè non capisco il perche ci sono 2 variabili 1 che dovrebbe essere quella da disabilitare...e l'altra _v2 non capisco da dove esce....dovrei mettere n per disabilitarla....correggimi se sbaglio
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Nov 26, 2009 7:32 pm    Post subject: Reply with quote

Prova a disabilitare entrambe e ricompila il kernel.
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Thu Nov 26, 2009 10:40 pm    Post subject: Reply with quote

allora correggimi se sbaglio:
1)apro il file .config in questo modo
Code:
vim /usr/src/linux/.config

poi cerco
Code:
CONFIG_SYSFS_DEPRECATED=y
CONFIG_SYSFS_DEPRECATED_V2=y

e sostituisco con
Code:
CONFIG_SYSFS_DEPRECATED=n
CONFIG_SYSFS_DEPRECATED_V2=n

poi salvo (:w) e chiudo(:q)
2) ricompilo il kernel pensavo che facendo così
Code:
genkernel --menuconfig all

una volta aperto non dovrei fare niente dovrei solo uscire e lasciarlo compilare
poi riavviare e il gioco e fatto...ehmmm...il problema e che credo non abbia funzionato...mmm forse devo fare il make? mi dareste qualche dritta? scusate la niubbità
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Nov 27, 2009 7:11 am    Post subject: Reply with quote

KinG-InFeT wrote:

e sostituisco con
Code:
CONFIG_SYSFS_DEPRECATED=n
CONFIG_SYSFS_DEPRECATED_V2=n


brutto (e dannoso?). non è questa la sintassi di .config:
Code:

s939 linux # grep SYSFS_DEPRECATED .config
# CONFIG_SYSFS_DEPRECATED_V2 is not set

la cosa migliore, per editare .config senza fare pasticci è usare make menuconfig e rompersi un po' a navigare il menù grafico.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Nov 27, 2009 10:10 am    Post subject: Reply with quote

È sotto "General setup", la trovi col nome "remove sysfs features which may confuse old userspace tools".
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Nov 27, 2009 10:12 am    Post subject: Reply with quote

oppure schiacciando il tasto / in menuconfig viene fuori l'utility per ricercare le voci all'interno del kernel tree.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Nov 27, 2009 2:37 pm    Post subject: Reply with quote

perdonatemi io ho eseguito la ricerca ed ho trovato le 2 fonti
Code:
 Symbol: SYSFS_DEPRECATED_V2 [=y]                                                                                                         
  │ Prompt: Create deprecated sysfs layout for older userspace tools                                                                           
  │   Defined at init/Kconfig:617                                                                                                                             
  │   Depends on:
  │   Location:                                                                                     
  │     -> General setup                                                                                                                     
  │   Selects: SYSFS_DEPRECATED                                                                                   
  │                                                                                                                             
  │                                                                                                 
  │ Symbol: SYSFS_DEPRECATED [=y]                                                                                             
 Selected by: SYSFS_DEPRECATED_V2 && SYSFS

ma nel menu entrando nel general setup non cè...invece editando a mano il file facendo
#CONFIG_SYSFS_DEPRECATED is not set
#CONFIG_SYSFS_DEPRECATED_V2 is not set
come faccio poi a ricompilare il kernel?
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Fri Nov 27, 2009 3:21 pm    Post subject: Reply with quote

Se non ricordo male da precedeti tue discussioni, avevi usato genkernel.
in tal caso fai di nuovo
Code:
# genkerel --menuconfig all

ricontrollando le voci di tuo interese.
..........................
in caso contrario dopo aver modificato con make menuconfig
Code:
# make && make modules_install
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Nov 27, 2009 3:31 pm    Post subject: Reply with quote

KinG-InFeT wrote:
ma nel menu entrando nel general setup non cè

non c'è la voce precisa che ti dicono di disabilitare, ma la sua "traduzione" in lingua inglese scritta. (se guardi nell'help delle voci in menuconfig poi la trovi indicata)
KinG-InFeT wrote:
come faccio poi a ricompilare il kernel?

Allo stesso modo di come l'hai compilato quando hai installato.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Fri Nov 27, 2009 3:42 pm    Post subject: Reply with quote

ciro64 wrote:
Code:
# make && make modules_install

sì, e poi?
già è confuso non diamogli le istruzioni a metà....

@KinG-InFeT
Questo mettilo dritto nei bookmark.

In particolare potrebbero esserti utili -> genkernel, compilazione (sezione 3 e 4 almeno), configurazione, aggiornamento.
Attenzione: siccome alcune cose potrebbero essere non più valide (o non esserlo in futuro) non prendere tutto quello che trovi scritto (è in italiano, leggile) come oro colato, ma cerca di afferrarne quanto meno il principio; non occorre essere degli hacker da leggenda per cambiare la configurazione del kernel, ricompilarlo ed installarselo.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Nov 27, 2009 4:43 pm    Post subject: Reply with quote

si perdonatemi grazie per le guide che comunque mi saranno di aiuto ora il probblema sta...come faccio a settare le 2 variabili di ambiente CONFIG_SYSFS_DEPRECATED a is not set? nel file .config cono settacome come ho detto prima ovvero commentate ecc...ora anche se il file .config non melo prende dal genkernel....anche facendo
Code:
genkernel --menuconfig all

e non facendo niente siccome non trovo la parte relativa alle 2 variabili anche se mi dice che si trova in General Setup come il messaggio che ho postato prima durante il search....porca miseria che casino cmq dalle guide che mi avete dato(thanks Onip) ho riscontrato ke con genkernel è possibile installare il kernel appena compilato automaticamente aggiungendo il comando --install....ora il problema è quello di sempre dove trovo le 2 voci da disabilitare nel kernel?
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Fri Nov 27, 2009 11:30 pm    Post subject: Reply with quote

Chiedo scusa se inprecedenza sono stato troppo "vago" :oops:

Riguardo il tuo problema, disabilita nel menù.

General setup --> (è proprio il primo in alto)
Code:

      [ ] Create deprecated sysfs layout for older userspace tools

Provvederà a disabilitare entrambe le variabili.
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Sat Nov 28, 2009 2:36 pm    Post subject: Reply with quote

allora ho trovato la parola chiave(non era proprio nei primi posti) ma cmq ho avviato come da manuale
Code:
genkernel --menuconfig --install all

ho trovato la voce e lo deselezionata, ora sono uscito ed ha compilato e tutto...ho riavviato ehmmm..pensate un pò? non è cambiato una H! :S consigli?
oppure reinstallo gentoo?(porca miseria cancellare tutta la fatiche che ci ho messo per arrivare fino e qui :cry: )
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Sun Nov 29, 2009 8:36 pm    Post subject: Reply with quote

KinG-InFeT wrote:
allora ho trovato la parola chiave(non era proprio nei primi posti) ma cmq ho avviato come da manuale
Code:
genkernel --menuconfig --install all

ho trovato la voce e lo deselezionata, ora sono uscito ed ha compilato e tutto...ho riavviato ehmmm..pensate un pò? non è cambiato una H! :S consigli?
oppure reinstallo gentoo?(porca miseria cancellare tutta la fatiche che ci ho messo per arrivare fino e qui :cry: )

domanda banale: sei sicuro di aver caricato il kernel giusto al boot ?

P.S. reinstallare gentoo senza avere idea di quale sia il problema ti farebbe rifare gli stessi passi e ritroveresti lo stesso problema ad aspettarti ...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Sun Nov 29, 2009 9:30 pm    Post subject: Reply with quote

ops....allora meglio se eseguio
Code:
 genkernel --menuconfig --bootloader=lilo --install all

?? così me lo installa direttamente lui no?
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Dec 04, 2009 11:31 am    Post subject: Reply with quote

ecco fato ho fatto la cretinata....kernel panic...quindi rotto i Co*****i mi accingo ad formattare e reinstallare....e provare la sorpresa?
MI ESCE DINUOVO LO STESSO ERRORE AL BOOT DI AVVIOOOOOOOO! MA MI DOMANCO COME è POSSIBILE? E HO REINSTALLATO PIù VOLTE NEL CERCARE DI CAPIRE SE SBAGLIAVO IO OPPURE è MAGIA OSCURA :s

AIUTO ORA ESCO PAZZO :|

PS. se vorrei utilizzare il comando revdep-rebuild non melo trova più come comando bash da eseguire
ps2. il kernel è aggiornato alla vesione 2.6.31-gentoo-r6
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
KinG-InFeT
Apprentice
Apprentice


Joined: 01 Oct 2009
Posts: 269
Location: Napoli

PostPosted: Fri Dec 04, 2009 12:35 pm    Post subject: Reply with quote

mi scuso per il doppio post ma dopo aver ricompilato il kernel rimuovendo i settaggi delle 2 variabili CONFIG_SYSFS mi è uscito quest'altro errore al posto di quello vecchio
[code]udev[15304]: device node '/dev/mapper/control' already exists, link to '/dev/mapper/control' will not overwrite it[code]
cosa devo fare? :?
_________________
My Site => http://www.kinginfet.net/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum