Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] glibc e gtk-doc-am
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 690
Location: tra veneto e friuli (italy)

PostPosted: Sun Nov 22, 2009 4:56 pm    Post subject: [RISOLTO] glibc e gtk-doc-am Reply with quote

Sono in procinto di aggiornare e trovo questa piccola novità :
Code:
[nomerge      ] kde-base/kgpg-4.3.3 [4.3.2] USE="handbook (-aqua) -debug (-kdeprefix)"  [0]
[nomerge      ]  kde-base/kdelibs-4.3.3 [4.3.2-r3] USE="3dnow acl alsa bindist bzip2 handbook kerberos mmx nls opengl semantic-desktop spell sse sse2 ssl (-altivec) (-aqua) -debug -doc -fam -jpeg2k (-kdeprefix) -lzma -openexr -test -zeroconf"  [0]
[nomerge      ]   dev-libs/soprano-2.3.1  USE="clucene dbus java raptor -debug -doc -redland"  [0]
[nomerge      ]    media-libs/raptor-1.4.19  USE="unicode xml -curl -debug"  [0]
[nomerge      ]     dev-libs/glib-2.20.5-r1 [2.20.5] USE="-debug -doc -fam -hardened (-selinux) -xattr"  [0]
[ebuild  N    ]      dev-util/gtk-doc-am-1.11  443 kB [0]

Praticamente adesso le glib necessitano obbligatoriamente delle librerie per la documentazione in gtk anche se ho impostato la USE "-doc" per glib e la USE globale "-gtk".
Questo comportamento è corretto? E' una svista nell'ebuild? Non ho capito io cosa sta facendo emerge? :-)

Ciao
_________________
proud user of faKeDE-4.7.3


Last edited by xdarma on Sun Nov 22, 2009 6:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sun Nov 22, 2009 5:39 pm    Post subject: Reply with quote

Il comportamento in questione è corretto, nel senso che l'ebuild è stato scritto cosi.

Tra le"Build dependencies" di dev-libs/glib-2.20.5-r1 trovo obbligatorio (e non condizionale) dev-util/gtk-doc-am.

Il fatto curioso è che nelle glib 2.22.2 la dipendenza prima obbligatoria di dev-util/gtk-doc-am magicamente non c'è piu.

La prima cosa che mi viene in mente è che gtk-doc-am sia stato integrato in qualcos altro, ma ragionandoci su questo non puo essere:

1) Perche ho glib-2.22.2 e anche gtk-doc-am. Se il nuovo glib si appoggiasse a qualcosa che integra gia gtk-doc-am avrei un conflitto con gtk-doc-am (che è ancora installato sul mio sistema).

2) Se cerco di eliminarlo con l'altro manager(e con il -p, ovvio), mi viene segnalato che le seguenti applicazioni usano gtk-doc-am
Code:

These packages will be uninstalled:

* dev-libs/redland-1.0.9-r1:0::installed requires <dev-util/gtk-doc-am-1.11:0::installed>
* gnome-base/gconf-2.26.2-r1:2::installed requires <dev-util/gtk-doc-am-1.11:0::installed>
* gnome-base/gnome-keyring-2.26.3:0::installed requires <dev-util/gtk-doc-am-1.11:0::installed>
* gnome-base/gnome-vfs-2.24.1:2::installed requires <dev-util/gtk-doc-am-1.11:0::installed>   
* sys-auth/policykit-0.9-r1:0::installed requires <dev-util/gtk-doc-am-1.11:0::installed>     
* x11-libs/gtk+-2.16.6:2::installed requires <dev-util/gtk-doc-am-1.11:0::installed>           
* x11-libs/libgksu-2.0.9:2::installed requires <dev-util/gtk-doc-am-1.11:0::installed>         
* x11-libs/libwnck-2.26.2-r2:0::installed requires <dev-util/gtk-doc-am-1.11:0::installed>     
* dev-util/gtk-doc-am-1.11:0::installed   


Total: 1 package and 8 errors
Use either --with-dependencies or --permit-unsafe-uninstalls


Per cui deduco semplicemente che le glib che hai tu, per qualche motivo hanno veramente bisogno di gtk-doc-am, Con le nuove glib questa dipendenza è stata tolta.

Comunque sarebbe utile sentire la voce di qualcuno che ha veramente idea del perché sia stata aggiunta questa dipendenza.
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
xdarma
l33t
l33t


Joined: 08 Dec 2003
Posts: 690
Location: tra veneto e friuli (italy)

PostPosted: Sun Nov 22, 2009 6:16 pm    Post subject: Reply with quote

Apetrini wrote:
Il fatto curioso è che nelle glib 2.22.2 la dipendenza prima obbligatoria di dev-util/gtk-doc-am magicamente non c'è piu.
[...snip...]
Per cui deduco semplicemente che le glib che hai tu, per qualche motivo hanno veramente bisogno di gtk-doc-am, Con le nuove glib questa dipendenza è stata tolta.

Hai ragione, glib-2.22.2 non richiede gtk-doc-am.
Ho impostato dev-libs/glib su ~amd64 in /etc/portage/packege.keywords e ho lanciato la ricompilazione (solo 290 pacchetti).

Grazie.
_________________
proud user of faKeDE-4.7.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum