Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HAL+KERNEL+KDE-4.3]montage des disques usb (résolu ...)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Fri Nov 13, 2009 12:00 pm    Post subject: [HAL+KERNEL+KDE-4.3]montage des disques usb (résolu ...) Reply with quote

Bonjour,

J'ai un souci de montage auto de mes disques usb sous kde-4.3.3 avec la série de kernel 2.6.31.

le disque est très lent à monter , plusieurs minute alors que la série 2.6.30 fonctionne très bien avec les mêmes options ensuite je peux naviguer sans soucis ....

Je n'ai aucune erreur de log .

Code:

lspci
00:00.0 Host bridge: ATI Technologies Inc RD790 Northbridge only dual slot PCI-e_GFX and HT3 K8 part
00:02.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (external gfx0 port A)
00:04.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port A)
00:09.0 PCI bridge: ATI Technologies Inc RD790 PCI to PCI bridge (PCI express gpp port E)
00:11.0 SATA controller: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode]
00:12.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:12.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:12.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:13.0 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller
00:13.1 USB Controller: ATI Technologies Inc SB700 USB OHCI1 Controller
00:13.2 USB Controller: ATI Technologies Inc SB700/SB800 USB EHCI Controller
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: ATI Technologies Inc SB700/SB800 IDE Controller
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB700/SB800 LPC host controller
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:14.5 USB Controller: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
02:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. Device 3403
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
04:00.0 VGA compatible controller: ATI Technologies Inc RV730XT [Radeon HD 4670]
04:00.1 Audio device: ATI Technologies Inc R700 Audio Device [Radeon HD 4000 Series]


Code:

grep OHCI /usr/src/linux/.config
CONFIG_USB_ARCH_HAS_OHCI=y
CONFIG_USB_OHCI_HCD=y
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_LITTLE_ENDIAN=y
CONFIG_PROVIDE_OHCI1394_DMA_INIT=y


Code:

grep EHCI /usr/src/linux/.config
CONFIG_USB_ARCH_HAS_EHCI=y
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
# CONFIG_USB_EHCI_TT_NEWSCHED is not set


SCSI est bien activé ...
Code:

grep CONFIG_BLK /usr/src/linux/.config
CONFIG_BLK_DEV_INITRD=y
CONFIG_BLK_DEV_BSG=y
# CONFIG_BLK_DEV_INTEGRITY is not set
CONFIG_BLK_DEV=y
# CONFIG_BLK_DEV_FD is not set
# CONFIG_BLK_CPQ_DA is not set
# CONFIG_BLK_CPQ_CISS_DA is not set
# CONFIG_BLK_DEV_DAC960 is not set
# CONFIG_BLK_DEV_UMEM is not set
# CONFIG_BLK_DEV_COW_COMMON is not set
CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_CRYPTOLOOP=y
# CONFIG_BLK_DEV_NBD is not set
# CONFIG_BLK_DEV_SX8 is not set
# CONFIG_BLK_DEV_UB is not set
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_COUNT=16
CONFIG_BLK_DEV_RAM_SIZE=16384
# CONFIG_BLK_DEV_XIP is not set
# CONFIG_BLK_DEV_HD is not set
CONFIG_BLK_DEV_SD=y
CONFIG_BLK_DEV_SR=y
CONFIG_BLK_DEV_SR_VENDOR=y
# CONFIG_BLK_DEV_3W_XXXX_RAID is not set
CONFIG_BLK_DEV_MD=y
CONFIG_BLK_DEV_DM=y
# CONFIG_BLK_DEV_DM_BBR is not set
CONFIG_BLK_DEV_IO_TRACE=y


Les disques usb sont en fat ou ntfs ...
Code:

grep FAT /usr/src/linux/.config
# DOS/FAT/NT Filesystems
CONFIG_FAT_FS=y
CONFIG_VFAT_FS=y
CONFIG_FAT_DEFAULT_CODEPAGE=437
CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"


Ntfs par ntfs-3g

Mes locales sont bien configurées:
Code:

locale
LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=fr_FR.UTF-8


Je ne sais pas si hal ou le logiciel de montage de kde qui fait des siennes avec ces noyaux mais j'aimerais bien trouver une soluce...

Code:

eix -I  sys-apps/hal
[I] sys-apps/hal
     Available versions:  0.5.11-r9 (~)0.5.12_rc1-r6 0.5.12_rc1-r7 0.5.12_rc1-r8 (~)0.5.13-r2 {X acpi apm consolekit crypt debug dell disk-partition doc kernel_FreeBSD kernel_linux laptop policykit selinux}
     Installed versions:  0.5.13-r2(08:31:45 04/10/2009)(X acpi consolekit crypt kernel_linux -apm -debug -dell -disk-partition -doc -kernel_FreeBSD -laptop -policykit -selinux)
     Homepage:            http://www.freedesktop.org/wiki/Software/hal
     Description:         Hardware Abstraction Layer


Si vous avez une idée ... merci de la partager .

@+
_________________
Get Up and Go !


Last edited by man in the hill on Sat Nov 14, 2009 12:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
mrpouet
Retired Dev
Retired Dev


Joined: 29 Jul 2008
Posts: 87
Location: Bordeaux, France

PostPosted: Fri Nov 13, 2009 10:14 pm    Post subject: Reply with quote

retournes moi la sortie de
Code:

# groups


stp, ensuite :

    * Hal est t'il lancé ?
    * Ca donne quoi coté ~/.xsession-errors ?


Edit: mhhh... apparement pas un problême de polkit non plus, tu n'a pas le USE...
Back to top
View user's profile Send private message
man in the hill
Veteran
Veteran


Joined: 15 Dec 2005
Posts: 1552
Location: Madinina

PostPosted: Sat Nov 14, 2009 12:12 pm    Post subject: Reply with quote

mrpouet wrote:
retournes moi la sortie de
Code:

# groups


stp, ensuite :

    * Hal est t'il lancé ?
    * Ca donne quoi coté ~/.xsession-errors ?


Edit: mhhh... apparement pas un problême de polkit non plus, tu n'a pas le USE...


Salut,

Code:

groups
lp wheel mail audio video games cdrw usb users ssmtp plugdev scanner dry oerp kvm ddclient pulse-access pulse


Hal est bien lancé ...

Je suis en testing, j'ai tjrs compilé mon kernel et la c'est un soucis avec la série 2.6.31 que je n'arrive pas a saisir ....
Bon, j'ai compilé le kernel vanilla-2.6.32-rc6 et le montage via dolphin de mes disques usb est redevenu normal ... (je garde donc )

Du coup ce nouveau kernel, qui est trop avancé pour les drivers proprio ati, m'a obligé de passé au driver radeon avec une 3D résonnable pour ma carte HD4670 et c'est pas plus mal .... (radeonhd plantais tous les jeux et aussi des choses bizarres côté console ...)

Je dirais que j'ai contourné le probème, je te remercie de m'avoir répondu !

@+
_________________
Get Up and Go !
Back to top
View user's profile Send private message
Leander256
l33t
l33t


Joined: 05 Jul 2003
Posts: 909
Location: Singapour

PostPosted: Sat Nov 14, 2009 7:36 pm    Post subject: Reply with quote

Je viens d'avoir un problème similaire avec ce 2.6.31.6, impossible de voir mon disque externe dans /dev, j'en branche un second pour vérifier et d'un seul coup les deux disques apparaissent... Je vais pas trainer longtemps sur cette version moi, je sens.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum