Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -uavND world java/ icedtea6-bin issues, solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Odysseus
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 246
Location: Miami, FL. I miss San Francisco!!!

PostPosted: Mon Nov 09, 2009 3:13 am    Post subject: emerge -uavND world java/ icedtea6-bin issues, solved Reply with quote

I'm running Gentoo stable with the following exceptions: Portage2.2_rc49, Mozilla/xulrunner, Nvidia-drivers/settings and KDE4.3.3-meta and the few dependencies needed to compile it. Since updating to KDE4.3.3 from 4.3.2 earlier in the week there have been no issues and everything seems to be running great.

This evening I go to emerge -uavND world and get the following mesg:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "dev-java/icedtea6-bin" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/icedtea6-bin-1.6.1 (masked by: ~x86 keyword)                       

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.                         
(dependency required by "virtual/jdk-1.6.0" [installed])           
(dependency required by "dev-libs/soprano-2.3.1" [installed])     
(dependency required by "kde-base/kdelibs-4.3.3" [installed])     
(dependency required by "kde-base/keditfiletype-4.3.3" [installed])
(dependency required by "kde-base/kdebase-meta-4.3.3" [installed])
(dependency required by "kde-base/kde-meta-4.3.3" [installed])     
(dependency required by "@world" [argument])


WTF? I don't use icedtea6! I use sun-jdk/jce, which should provide any java needed. Why is icedtea6 being pulled in as a dependency? Especially since java is being provided already by sun-jdk and by gcc? I don't need nor want any other java-vm or plugin. Can somebody please clue me in. What's going on here?

My make.conf
Code:
USE="aalib akonadi autoipd avahi bash-completion bonjour cdparanoia cleartype
     connection-sharing corefonts dell designer-plugin desktopglobe dga
     dhclient dhcpcd djvu dv dvb ebook editor emovix exif faac faad fame
     ffmpeg gadu gcj gnokii google-gadgets gphoto2 groupwise hyperestraier
     ieee1394 imagemagick inotify ioctl jack java jce joystick jpeg2k kerberos
     kig-scripting kipi konqueror ladspa lame laptop libcaca libsamplerate
     lm_sensors lzma lzo mdnsresponder-compat meanwhile mjpeg mmx mng mplayer
     msn musicbrainz mysql networkmanager nsplugin objc objc++ objc-gc openexr
     oscar otr phonon plasma pnm policykit pulseaudio rdp resolvconf rss samba
     schroedinger semantic-desktop sndfile solver sox speex sql sqlite sse
     sse2 symlink theora threads thumbnail tidy tk v4l v4l2 vcd vhook vidix
     vnc wavpack webkit webpresence wicd wifi winpopup xcb xcomposite xinerama
     xmlpatterns xscreensaver xvmc yahoo yv12 zeroconf zip -3dfx -3dnow
     -3dnowext -gnome -sse3 -sse4 -sse4a -sse5 -ssse3"
CHOST="i686-pc-linux-gnu"
ACCEPT_KEYWORDS="x86"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
LDFLAGS="-Wl,-O1,--as-needed"
MAKEOPTS="-j2 -s"
PORTAGE_NICENESS="8"
FEATURES="parallel-fetch collision-protect"
CONFIG_PROTECT="/usr/share/config/kdm /etc"
CONFIG_PROTECT_MASK="/etc/skel"
PORTAGE_ELOG_CLASSES="warn info log"
PORTAGE_ELOG_SYSTEM="save"
LINGUAS="en en_US"
#APACHE2_MPMS="prefork"
ALSA_CARDS="intel8x0 intel8x0m"
SANE_BACKENDS="epson epson2"
INPUT_DEVICES="evdev keyboard mouse synaptics joystick"
VIDEO_CARDS="nv nvidia"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://gentoo.netnitco.net http://osmirrors.cerias.purdue.edu/pub/gentoo/ http://www.cyberuse.com/gentoo/ http://gentoo.mirrors.hoobly.com/ ftp://gentoo.imj.fr/pub/gentoo/ http://130.59.10.35/ftp/mirror/gentoo/"


Edit: As a side note I thought I'd try just to emerge -uav world to see what would happen. The output:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NSF  ] dev-java/sun-jdk-1.4.2.19 [1.6.0.17] USE="X alsa jce -doc -examples (-nsplugin) -odbc" 35,547 kB

Total: 1 package (1 in new slot), Size of downloads: 35,547 kB
Fetch Restriction: 1 package (1 unsatisfied)

Now it want's to slot a downgrade to my Java installation? Why does protage want to slot in sun-jdk1.4.2? I haven't installed anything new in weeks except for upgrading portage and KDE from 4.3.1 to 4.3.3 and surely neither doesn't need an older java. What in the heck is going on here?

Any ideas / solutions would be greatly appreciated. TIA

Edit #2: I found this post with the solution https://forums.gentoo.org/viewtopic-t-801666.html Apparently there is a licensing issue. We need to create in /etc/portage a package.license file and add dev-java/sun-jdk dlj-1.1 or add to /etc/make.conf ACCEPT_LICENSE="dlj-1.1".

Why whenever Gentoo makes big changes l.ike this they don't make a major announcement so everyone can be on the same page?

Ciao
Back to top
View user's profile Send private message
matze_na
n00b
n00b


Joined: 04 Apr 2007
Posts: 54
Location: Germany

PostPosted: Mon Nov 09, 2009 3:44 pm    Post subject: Reply with quote

Thanks, I just had the same problem and was wondering what the hell was going on.
It's really not quite optimal that something as simple as this essentially breaks portage, or at least the update method, and the user isn't notified as to what the cause is.

While the problem itself cannot be avoided because the user has to manually accept this new license and that's it, portage should tell us that there is an already installed package which requires a license that isn't accepted.
That way the solving of the problem would have been straightforward and wouldn't have required a forum search.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Tue Nov 10, 2009 3:45 am    Post subject: Reply with quote

Odysseus wrote:
Edit #2: I found this post with the solution https://forums.gentoo.org/viewtopic-t-801666.html Apparently there is a licensing issue. We need to create in /etc/portage a package.license file and add dev-java/sun-jdk dlj-1.1 or add to /etc/make.conf ACCEPT_LICENSE="dlj-1.1".
Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum