Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mount di condivisioni di rete
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Fri Nov 06, 2009 7:06 pm    Post subject: Mount di condivisioni di rete Reply with quote

Vi illustro il problema, in grassetto le mie richieste, se mi potete aiutare

Sto cercando di montare automaticamente all'avvio del mio portatile alcune condivisioni di rete, e ci son riuscito usando cifs in /etc/fstab.
Fin qui tutto bene ma era da molto che volevo togliere le mie credenziali che uso in rete da /etc/fstab per metterle in un file da richiamare con l'opzione credentials=/path/... (sempre in fstab)

Detto cio' ieri cambiavo la password (e ne ho trovata una di bella con punti, virgole, spazi etc...) e quindi ho colto l'occasione per realizzare quanto citato sopra (anche se sarebbe mio desiderio cifrare quel file o comunque renderlo non così facilmente disponibile)

Detto cio' sembra che cifs abbia qualche bug con la gestione di quell'opzione "credentials" di cui parlavo sopra (almeno ho letto in rete così), poi son riuscito a fare tutto usando smbfs. Pero' riavviando il pc mi dice che il supporto è deprecated da non ricordo che versione del kernel e che devo usare cifs, ma con cifs non riesco a fare quanto sopra.

Inoltre in system:/media non vedo piu' quel che riesco a montare (con cifs ci riuscivo mi par di ricordare), ora vedo tutto ma solo in /mnt

Quindi:
- come usare cifs in /etc/fstab per caricare delle condivisioni samba? - [RISOLTO]
- come cifrare eventualmente un file che comprende username e password? - [WORKAROUND]
- come fare in modo che io trovi le mie condivisioni anche in system:/media? - [APERTO]


Last edited by lsegalla on Thu Dec 31, 2009 11:39 am; edited 3 times in total
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Nov 18, 2009 7:31 pm    Post subject: Reply with quote

Qualcuno sa darmi qualche dritta?
Non riesco a lavorare in rete come si deve in questo modo...
(anzi non ci riesco proprio)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Nov 19, 2009 9:29 am    Post subject: Reply with quote

io uso questa linea in fstab:
Code:

:~$ grep cifs /etc/fstab
//RHSERVER/public /home/samba cifs credentials=/root/smbpw,umask=000,iocharset=utf8,mode_dirs=0777,mode_files=0777,noperm 0 0
~# cat /root/smbpw
username=amministratore
password=password

per il mount, è necessario il file mount.cifs:
Code:

 # qfile mount.cifs
net-fs/samba-client (/sbin/mount.cifs)
# eix cifs
...
* net-fs/mount-cifs

non cripto il file delle password, ma lo proteggo in lettura dagli utenti non provilegiati.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Nov 19, 2009 3:08 pm    Post subject: Reply with quote

Il mio problema era evidentemente il fatto di non avere il pacchetto che hai citato perchè ora riesco a fare tutto.
Ho usato la tua configurazione, ovviamente modificata coi parametri che mi servono.
Solo alcune cose non vanno, allego un dmesg
Code:
user8-gentoo luca # dmesg |tail
[   55.359563] NET: Registered protocol family 10
[   55.360293] lo: Disabled Privacy Extensions
[   58.560443] CIFS: Unknown mount option umask
[   58.560451] CIFS: Unknown mount option mode_dirs
[   58.560454] CIFS: Unknown mount option mode_files


Penso pero' che per me sia sufficiente così, vedo come va e poi marco il thread come risolto in caso.
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Fri Nov 20, 2009 6:57 pm    Post subject: Reply with quote

Effettivamente ho ancora dei problemi, ma non vedo nessun log che possa ricondurmi a un qualche problema.
In buona sostanza tutti i mount sono stati eseguiti e non mi dà piu' l'errore delle credenziali errate.
Detto cio' pero' in alcune cartelle di rete provviste delle opportune restrizioni il mio utente non riesce a scrivere (mentre prima ci riuscivo)
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Fri Nov 20, 2009 7:07 pm    Post subject: Reply with quote

Come hai configurato il supporto a CIFS nel kernel?
Code:

zgrep -i cifs /proc/config.gz

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Fri Nov 27, 2009 3:33 pm    Post subject: Reply with quote

Code:
luca@user8-gentoo ~ $ zgrep -i cifs /proc/config.gz
CONFIG_CIFS=y
CONFIG_CIFS_STATS=y
CONFIG_CIFS_STATS2=y
CONFIG_CIFS_WEAK_PW_HASH=y
CONFIG_CIFS_UPCALL=y
CONFIG_CIFS_XATTR=y
CONFIG_CIFS_POSIX=y
# CONFIG_CIFS_DEBUG2 is not set
CONFIG_CIFS_EXPERIMENTAL=y
CONFIG_CIFS_DFS_UPCALL=y


Va detto anche che ho sempre lo stesso kernel, non ho cambiato nulla... l'unico messaggio che mi esce all'avvio è che devo togliere l'opzione Kernel CONFIG_SYSFS_DEPRECATED (vado a memoria). Poi c'erano dei comandi che non trovava piu' in /bin qualche giorno fa, ma niente che non potessi risolvere con un link simbolico (magari non saro' stato lungimirante ma per ora il sistema funziona come prima, eccetto sta cosa delle cartelle di rete)
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Dec 31, 2009 11:38 am    Post subject: Reply with quote

PUNTO 1
Ho scoperto che non avevo installato net-fs/mount-cifs, con quello son riuscito a usare il file delle credenziali nuovamente!

PUNTO 2
Ho effettuato un chmod a-rw sul file delle credenziali che così risulta leggibile solo da root (e anche modificabile da root), non è la mia risposta al mio punto ma è un workaround efficace intanto

PUNTO 3
Rimane aperto
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum