Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Dipendenze e conflitti nell'update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
wiklex
n00b
n00b


Joined: 20 Aug 2009
Posts: 26

PostPosted: Wed Nov 04, 2009 10:31 am    Post subject: [Risolto] Dipendenze e conflitti nell'update Reply with quote

Buongiorno a tutti,
il mio aggiornamento periodico non è andato a buon fine... inizialmente mi diceva che alcuni pacchetti erano mascherati, e li ho aggiunti in /etc/portage/packages.keyword
(precisamente questi pacchetti:
>=x11-proto/fixesproto-4.1 ~x86
>=x11-proto/xextproto-7.0.99.1
>=x11-proto/xf86vidmodeproto-2.2.99.1
>=x11-proto/renderproto-0.11
>=x11-proto/recordproto-1.13.99.1
>=x11-proto/inputproto-1.9.99.902
>=x11-proto/xineramaproto-1.1.3
>=x11-proto/bigreqsproto-1.1.0
>=x11-proto/xf86driproto-2.1.0
>=x11-proto/xf86dgaproto-2.0.99.1
>=x11-proto/xcmiscproto-1.2.0)

Dopo avermi rotto le scatole con queste dipendenze, che fa? un bel conflitto:

Code:

emerge -uDNpv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-util/gperf-3.0.4 [3.0.3] 961 kB
[ebuild     U ] sys-apps/usbutils-0.82 [0.73] USE="zlib -network-cron" 237 kB
[ebuild     U ] dev-db/sqlite-3.6.18 [3.6.17] USE="readline threadsafe -debug -doc -icu% -soundex -tcl" 2,880 kB
[ebuild     U ] x11-base/xorg-drivers-1.7 [1.6] INPUT_DEVICES="evdev keyboard mouse synaptics -acecad -aiptek -joystick -tslib -virtualbox -vmmouse -void (-citron%) (-elographics%) (-fpit%) (-hyperpen%) (-mutouch%) (-penmount%) (-wacom%)" VIDEO_CARDS="radeon -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -imstt -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -vesa -via -virtualbox -vmware (-voodoo) -xgi" 0 kB
[ebuild     U ] media-libs/schroedinger-1.0.8 [1.0.7] USE="(-gstreamer%*)" 844 kB
[ebuild     U ] x11-proto/inputproto-2.0 [1.5.1] 137 kB
[ebuild     U ] x11-proto/recordproto-1.14 [1.13.2] 83 kB
[ebuild     U ] x11-proto/xextproto-7.1.1 [7.0.5] 70 kB
[ebuild     U ] x11-proto/renderproto-0.11 [0.9.3] 65 kB
[ebuild     U ] x11-proto/xf86vidmodeproto-2.3 [2.2.2] 83 kB
[ebuild     U ] x11-proto/xineramaproto-1.2 [1.1.2] 82 kB
[ebuild     U ] x11-proto/bigreqsproto-1.1.0 [1.0.2] 48 kB
[ebuild     U ] x11-proto/xf86driproto-2.1.0 [2.0.4] 49 kB
[ebuild     U ] x11-proto/xf86dgaproto-2.1 [2.0.3] 84 kB
[ebuild     U ] x11-proto/xcmiscproto-1.2.0 [1.1.2] 48 kB
[ebuild     U ] x11-proto/fixesproto-4.1.1 [4.0] 90 kB
[ebuild     U ] dev-libs/openssl-0.9.8k-r1 [0.9.8k] USE="kerberos zlib -bindist -gmp -sse2 -test" 0 kB
[ebuild     U ] app-admin/syslog-ng-3.0.4 [2.1.4] USE="ipv6 pcre%* ssl%* tcpd -caps% -hardened (-selinux) -spoof-source -sql -static" 536 kB
[ebuild     U ] app-admin/eselect-opengl-1.0.9 [1.0.8-r1] 57 kB
[ebuild     U ] dev-python/setuptools-0.6.4 [0.6-r1] 508 kB
[ebuild     U ] net-libs/gnutls-2.8.4 [2.8.3] USE="cxx nls zlib -bindist -doc -examples -guile -lzo" 6,048 kB
[ebuild     U ] net-misc/neon-0.29.0 [0.28.6] USE="kerberos nls ssl zlib -doc -expat -gnutls -libproxy% -pkcs11 (-socks5%)" LINGUAS="-cs -de -fr -ja -nn -pl -ru -tr -zh_CN" 859 kB
[ebuild     U ] dev-libs/cyrus-sasl-2.1.23-r1 [2.1.23] USE="berkdb crypt gdbm java kerberos ldap pam ssl -authdaemond -mysql -ntlm_unsupported_patch -postgres -sample -sqlite% -srp -urandom" 0 kB
[ebuild     U ] x11-base/xorg-server-1.7.1 [1.6.5] USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib" 4,778 kB
[ebuild     U ] x11-libs/libgksu-2.0.12 [2.0.9] USE="nls -doc (-debug%)" 467 kB
[ebuild     U ] x11-libs/qt-core-4.5.3-r2 [4.5.2] USE="glib iconv qt3support ssl -debug -doc -pch" 122,446 kB
[ebuild     U ] x11-libs/qt-dbus-4.5.3-r1 [4.5.2] USE="-debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blocking x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)
[ebuild     U ] x11-libs/qt-script-4.5.3-r1 [4.5.2] USE="iconv -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3)
[ebuild     U ] x11-libs/qt-sql-4.5.3 [4.5.2] USE="iconv qt3support sqlite -debug -firebird -mysql -odbc -pch -postgres" 0 kB
[blocks b     ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-script-4.5.3-r1)
[ebuild     U ] x11-libs/qt-gui-4.5.3-r1 [4.5.2-r2] USE="accessibility cups dbus glib gtk qt3support tiff -debug -mng -nas -nis -pch -raster -xinerama" 0 kB
[blocks b     ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)
[blocks b     ] >x11-libs/qt-qt3support-4.5.2-r9999 (">x11-libs/qt-qt3support-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[ebuild     U ] x11-libs/qt-qt3support-4.5.3 [4.5.2] USE="accessibility -debug -kde -pch -phonon" 0 kB
[blocks b     ] >x11-libs/qt-dbus-4.5.2-r9999 (">x11-libs/qt-dbus-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-script-4.5.2)
[blocks b     ] >x11-libs/qt-core-4.5.2-r9999 (">x11-libs/qt-core-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks b     ] >x11-libs/qt-sql-4.5.2-r9999 (">x11-libs/qt-sql-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks b     ] >x11-libs/qt-gui-4.5.2-r9999 (">x11-libs/qt-gui-4.5.2-r9999" is blocking x11-libs/qt-sql-4.5.2, x11-libs/qt-core-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2)
[blocks b     ] >x11-libs/qt-script-4.5.2-r9999 (">x11-libs/qt-script-4.5.2-r9999" is blocking x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-sql-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-core-4.5.2)
[blocks b     ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.3" is blocking x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-sql-4.5.3, x11-libs/qt-script-4.5.3-r1)
[blocks B     ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
[blocks B     ] <x11-libs/libXinerama-1.0.99.1 ("<x11-libs/libXinerama-1.0.99.1" is blocking x11-proto/xineramaproto-1.2)
[blocks B     ] <x11-libs/libXxf86dga-1.0.99.1 ("<x11-libs/libXxf86dga-1.0.99.1" is blocking x11-proto/xf86dgaproto-2.1)
[blocks B     ] <x11-libs/libXtst-1.0.99.2 ("<x11-libs/libXtst-1.0.99.2" is blocking x11-proto/recordproto-1.14)
[blocks B     ] >=x11-base/xorg-server-1.7.0 (">=x11-base/xorg-server-1.7.0" is blocking x11-drivers/ati-drivers-9.10)
[blocks B     ] <x11-libs/libXi-1.2.99 ("<x11-libs/libXi-1.2.99" is blocking x11-proto/inputproto-2.0)
[blocks B     ] <x11-libs/libXxf86vm-1.0.99.1 ("<x11-libs/libXxf86vm-1.0.99.1" is blocking x11-proto/xf86vidmodeproto-2.3)

Total: 31 packages (31 upgrades), Size of downloads: 141,451 kB
Conflict: 18 blocks (7 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'x11-libs/libXxf86dga-1.0.2', 'nomerge') pulled in by
    x11-libs/libXxf86dga required by world

  ('installed', '/', 'x11-drivers/ati-drivers-9.10', 'nomerge') pulled in by
    x11-drivers/ati-drivers required by world

  ('ebuild', '/', 'x11-proto/xextproto-7.1.1', 'merge') pulled in by
    >=x11-proto/xextproto-7.0.99.3 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.1', 'merge')
    x11-proto/xextproto required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r1', 'merge')
    >=x11-proto/xextproto-7.0.99.1 required by ('ebuild', '/', 'x11-proto/fixesproto-4.1.1', 'merge')

  ('installed', '/', 'x11-libs/libXinerama-1.0.3', 'nomerge') pulled in by
    x11-libs/libXinerama required by ('installed', '/', 'x11-drivers/ati-drivers-9.10', 'nomerge')
    x11-libs/libXinerama required by ('installed', '/', 'x11-libs/wxGTK-2.8.10.1-r1', 'nomerge')

  ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge') pulled in by
    x11-libs/libXi required by ('installed', '/', 'x11-libs/gtk+-2.16.6', 'nomerge')
    x11-libs/libXi required by ('installed', '/', 'app-emulation/wine-1.1.12', 'nomerge')
    x11-libs/libXi required by ('installed', '/', 'dev-java/sun-jdk-1.6.0.15', 'nomerge')
    (and 6 more)

  ('ebuild', '/', 'x11-base/xorg-server-1.7.1', 'merge') pulled in by
    >=x11-base/xorg-server-1.5.3 required by ('installed', '/', 'x11-drivers/xf86-input-evdev-2.2.5', 'nomerge')
    >=x11-base/xorg-server-1.2[-minimal] required by ('installed', '/', 'x11-drivers/xf86-video-ati-6.12.4', 'nomerge')
    >=x11-base/xorg-server-1.0.99 required by ('installed', '/', 'x11-drivers/xf86-input-mouse-1.4.0', 'nomerge')
    (and 3 more)

  ('installed', '/', 'x11-libs/libXext-1.0.5', 'nomerge') pulled in by
    x11-libs/libXext required by ('installed', '/', 'x11-apps/xdpyinfo-1.0.3', 'nomerge')
    x11-libs/libXext required by ('installed', '/', 'x11-libs/libwnck-2.26.2-r2', 'nomerge')
    x11-libs/libXext required by ('installed', '/', 'x11-libs/libXfontcache-1.0.4', 'nomerge')
    (and 38 more)

  ('ebuild', '/', 'x11-proto/inputproto-2.0', 'merge') pulled in by
    >=x11-proto/inputproto-1.5 required by ('installed', '/', 'x11-libs/libXi-1.2.1', 'nomerge')
    x11-proto/inputproto required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.3-r1', 'merge')
    >=x11-proto/inputproto-1.9.99.902 required by ('ebuild', '/', 'x11-base/xorg-server-1.7.1', 'merge')

  ('installed', '/', 'x11-libs/libXtst-1.0.3', 'nomerge') pulled in by
    x11-libs/libXtst required by ('installed', '/', 'dev-java/sun-jdk-1.6.0.15', 'nomerge')
    x11-libs/libXtst required by ('installed', '/', 'media-gfx/gthumb-2.10.11', 'nomerge')
    x11-libs/libXtst required by ('installed', '/', 'x11-apps/xdpyinfo-1.0.3', 'nomerge')
    (and 2 more)

  ('installed', '/', 'x11-libs/libXxf86vm-1.0.2', 'nomerge') pulled in by
    x11-libs/libXxf86vm required by ('installed', '/', 'x11-libs/wxGTK-2.8.10.1-r1', 'nomerge')
    x11-libs/libXxf86vm required by ('installed', '/', 'media-video/mplayer-1.0_rc2_p20090731', 'nomerge')
    x11-libs/libXxf86vm required by ('installed', '/', 'x11-apps/xdpyinfo-1.0.3', 'nomerge')
    (and 3 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Non ho capito perchè se prima mi fa sbloccare alcuni pacchetti, utili a xorg fra l'altro, poi mi dice che gli stessi sono in conflitto con altri nel sistema...


Last edited by wiklex on Fri Nov 06, 2009 3:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Nov 04, 2009 12:18 pm    Post subject: Reply with quote

Prima di smascherare xorg-1.7 risolvi i conflitti delle qt e aggiorna il resto del sistema, in quello che hai scritto c'è troppa confusione.
Poi credo, ma è solo una supposizione, che ti basti emergere uno alla volta i pacchetti corrispondenti alle righe [blocks B ]: se guardi per esempio
Quote:
[blocks B ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
ti dice che avere libXext ad una versione inferiore alla 1.0.99 blocca l'installazione di xextproto; aggiornando a mano libXext il blocco dovrebbe risolversi.
Back to top
View user's profile Send private message
wiklex
n00b
n00b


Joined: 20 Aug 2009
Posts: 26

PostPosted: Thu Nov 05, 2009 7:09 pm    Post subject: Reply with quote

riverdragon wrote:
Prima di smascherare xorg-1.7 risolvi i conflitti delle qt e aggiorna il resto del sistema, in quello che hai scritto c'è troppa confusione.
Poi credo, ma è solo una supposizione, che ti basti emergere uno alla volta i pacchetti corrispondenti alle righe [blocks B ]: se guardi per esempio
Quote:
[blocks B ] <x11-libs/libXext-1.0.99 ("<x11-libs/libXext-1.0.99" is blocking x11-proto/xextproto-7.1.1)
ti dice che avere libXext ad una versione inferiore alla 1.0.99 blocca l'installazione di xextproto; aggiornando a mano libXext il blocco dovrebbe risolversi.


Innanzitutto grazie per la risposta...
comunque ho provato a seguire il tuo consiglio ma facendo l'update del pacchetto pare che abbia già l'ultima versione installata (1.0.5).
Adesso mi chiedo, la .99 è più piccola o più grande della .5? Perchè ho fatto l'emerge --sync, anche con diversi mirrors (svizzero e napoli) ma l'ultima versione che mi dà è quella...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Nov 06, 2009 12:08 am    Post subject: Reply with quote

Allora abbiamo scoperto la causa dei blocchi, non hai smascherato tutti i pacchetti! In portage c'è la versione 1.1.1 che probabilmente risolve il problema.
Back to top
View user's profile Send private message
wiklex
n00b
n00b


Joined: 20 Aug 2009
Posts: 26

PostPosted: Fri Nov 06, 2009 3:45 pm    Post subject: Reply with quote

ecco, emerge non mi aveva detto di smascherarmi libXext...

grazie!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum