Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[bluetooth] Fallo al compilar bluez [solucionado]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
chaim
Apprentice
Apprentice


Joined: 11 Jul 2008
Posts: 172

PostPosted: Thu Oct 29, 2009 4:55 pm    Post subject: [bluetooth] Fallo al compilar bluez [solucionado] Reply with quote

Al actualizar el sistema quiere compilar bluez y esto es lo que me sale:

Code:

 *
 * ERROR: net-wireless/bluez-4.39-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2745:  Called _eapi2_src_compile
 *               ebuild.sh, line  634:  Called die
 * The specific snippet of code:
 *         emake || die "emake failed"
 *  The die message:
 *   emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/net-wireless/bluez-4.39-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-wireless/bluez-4.39-r2/temp/environment'.
 *

>>> Failed to emerge net-wireless/bluez-4.39-r2, Log file:

>>>  '/var/tmp/portage/net-wireless/bluez-4.39-r2/temp/build.log'


Alguna idea? Decidme que datos puedo poner..
_________________
Mi Blog - Universo Binario


Last edited by chaim on Thu Oct 29, 2009 11:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2631
Location: En la otra punta del cable

PostPosted: Thu Oct 29, 2009 6:29 pm    Post subject: Reply with quote

Pega por favor un poco mas del log. Lo relevante está inmediatamente antes de lo que has pegado que no indica absolutamente nada mas que "emake failed".

Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
chaim
Apprentice
Apprentice


Joined: 11 Jul 2008
Posts: 172

PostPosted: Thu Oct 29, 2009 9:06 pm    Post subject: Reply with quote

He copiado el log en pastebin

http://pastebin.com/m73c9d5c1

Saludos y gracias
_________________
Mi Blog - Universo Binario
Back to top
View user's profile Send private message
Coghan
l33t
l33t


Joined: 25 Jul 2007
Posts: 789
Location: Gran Canaria (Spain)

PostPosted: Thu Oct 29, 2009 9:45 pm    Post subject: Reply with quote

Quote:
libtool: link: cannot find the library `/usr/lib/libogg.la' or unhandled argument `/usr/lib/libogg.la'

Según este bug la versión del paquete media-libs/libogg-1.1.4 no crea el archivo /usr/lib/libogg.la, motivo del error que tienes al compilar net-wireless/bluez. Sin embargo la versión anterior 1.1.3 si que lo instala. Podrías añadir una entrada a este bug para avisar de que también falla con bluez y que lo arreglen, mientras tanto podrías enmascarar la versión 1.1.4 y continuar instalando.
_________________
Salu2.
Alguien, muy acertadamente, dijo una vez wrote:
'El buen informático es como un bibliotecario, no lo sabe todo, pero sabe donde buscarlo'


Last edited by Coghan on Thu Oct 29, 2009 10:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Diabliyo
Guru
Guru


Joined: 12 May 2008
Posts: 384
Location: Mexico

PostPosted: Thu Oct 29, 2009 10:43 pm    Post subject: Reply with quote

Coghan wrote:
Quote:
libtool: link: cannot find the library `/usr/lib/libogg.la' or unhandled argument `/usr/lib/libogg.la'

Según este bug la versión del paquete media-libs/libogg-1.1.4 no crea el archivo /usr/lib/libogg.la, motivo del error que tienes al compilar net-wireless/bluez. Sin embargo la versión anterior 1.1.3 si que lo instala. Podrías añadir una entrada a este bug para avisa de que también falla con bluez y que lo arreglen, mientras tanto podrías enmascarar la versión 1.1.4 y continuar instalando.


Por lo tanto, tendria que hacer esto:

Code:
shell# emerge -C libogg
shell# echo "media-libs/libogg-1.1.4" > /etc/portage/package.mask  # enmascaramos
shell# emerge -vp libogg  # verificas que sea la 1.1.3
shell#  emerge libogg  # la emergemos
shell# emerge bluez
Back to top
View user's profile Send private message
chaim
Apprentice
Apprentice


Joined: 11 Jul 2008
Posts: 172

PostPosted: Thu Oct 29, 2009 11:56 pm    Post subject: Reply with quote

Coghan wrote:
Quote:
libtool: link: cannot find the library `/usr/lib/libogg.la' or unhandled argument `/usr/lib/libogg.la'

Según este bug la versión del paquete media-libs/libogg-1.1.4 no crea el archivo /usr/lib/libogg.la, motivo del error que tienes al compilar net-wireless/bluez. Sin embargo la versión anterior 1.1.3 si que lo instala. Podrías añadir una entrada a este bug para avisar de que también falla con bluez y que lo arreglen, mientras tanto podrías enmascarar la versión 1.1.4 y continuar instalando.


Ok. ya está solucinado y puesto el aviso del bug.
_________________
Mi Blog - Universo Binario
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum