Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Installazione kde-meta 4.3
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Nov 04, 2009 7:27 pm    Post subject: Reply with quote

Ho visto adesso che il tuo emerge --info sputa fuori un
Code:

PORTDIR_OVERLAY="/usr/local/portage/layman/python /usr/local/portage/layman/multimedia /usr/local/portage/layman/x11 /usr/local/portage/layman/vdr-xine /usr/local/portage/layman/gentoo-china /usr/local/portage/layman/gentoo-quebec /usr/local/portage/layman/gentoo-taiwan /usr/local/portage/layman/gentoo-arm /usr/local/portage/layman/sabayon /usr/local/portage/layman/zen-sources /usr/local/portage/layman/mozilla /usr/local/portage/layman/voip /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/kde-testing"

8O 8O 8O

Masochismo estremo? :roll:

Commenta o rimuovi la variabile PORTDIR_OVERLAY in /etc/make.conf, oppure se stai usando layman commenta o togli la riga
Code:

source /usr/local/portage/layman/make.conf


Con tutti quegli overlay, sfido chiunque ad avere un sistema pulito 8O

In parole povere: rimuovi temporaneamente tutti gli overlay, che rompo solamente le scatole in questo momento 8)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Wed Nov 04, 2009 9:05 pm    Post subject: Reply with quote

Ho fatto tutto ciò che mi hai detto poi emerge --sync -v quindi emerge -ptDNuv-with --bdeps y world ma l'output prima mi chiede di settare +gnome come flag use ( ed io l'ho fatto) successivamente ripetendo il comando di aggiornamento del sistema mi fa rilevare i seguenti blocchi:

Quote:
[blocks b ] <x11-libs/qt-qt3support-4.5.3 ("<x11-libs/qt-qt3support-4.5.
3" is blocking x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt
-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/
qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs
/qt-sql-4.5.3)
[nomerge ] x11-libs/qt-core-4.4.2-r2 USE="glib iconv qt3support ssl -debug
-doc -pch" [0]
[blocks b ] >x11-libs/qt-dbus-4.4.2-r9999 (">x11-libs/qt-dbus-4.4.2-r9999"
is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-
gui-4.4.2-r1, x11-libs/qt-core-4.4.2-r2, x11-libs/qt-sql-4.4.2-r1)
[blocks b ] >x11-libs/qt-opengl-4.4.2-r9999 (">x11-libs/qt-opengl-4.4.2-r99
99" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gu
i-4.4.2-r1, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-
core-4.4.2-r2)
[blocks b ] >x11-libs/qt-svg-4.4.2-r9999 (">x11-libs/qt-svg-4.4.2-r9999" is
blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.
2-r1, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-core-4
.4.2-r2)
[nomerge ] x11-libs/qt-gui-4.4.2-r1 USE="accessibility cups dbus mng qt3su
pport tiff -debug -glib -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom" [?]
[blocks b ] >x11-libs/qt-core-4.4.2-r9999 (">x11-libs/qt-core-4.4.2-r9999"
is blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-
dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-sql-4.4.2-r1)
[blocks b ] >x11-libs/qt-webkit-4.4.2-r9999 (">x11-libs/qt-webkit-4.4.2-r99
99" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gu
i-4.4.2-r1, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-
core-4.4.2-r2)
[blocks b ] >x11-libs/qt-sql-4.4.2-r9999 (">x11-libs/qt-sql-4.4.2-r9999" is
blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-db
us-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-core-4.4.2-r2)
[nomerge ] x11-libs/qt-core-4.4.2-r2 USE="glib iconv qt3support ssl -debug
-doc -pch" [0]
[blocks b ] >x11-libs/qt-gui-4.4.2-r9999 (">x11-libs/qt-gui-4.4.2-r9999" is
blocking x11-libs/qt-qt3support-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-db
us-4.4.2, x11-libs/qt-core-4.4.2-r2, x11-libs/qt-sql-4.4.2-r1)
[ebuild U ] x11-libs/qt-qt3support-4.5.3 [4.4.2] USE="accessibility kde%*
-debug -pch -phonon%" 0 kB [0]
[blocks b ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking
x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2,
x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5.
3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5
.3)
[blocks b ] >x11-libs/qt-qt3support-4.4.2-r9999 (">x11-libs/qt-qt3support-4
.4.2-r9999" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-li
bs/qt-gui-4.4.2-r1, x11-libs/qt-core-4.4.2-r2, x11-libs/qt-sql-4.4.2-r1)
[ebuild U ] x11-libs/qt-gui-4.5.3-r1 [4.4.2-r1] USE="accessibility cups db
us glib* mng qt3support tiff -debug -gtk% -nas -nis -pch -raster% -xinerama" INP
UT_DEVICES="(-wacom%)" 0 kB [?=>0]
[blocks b ] <x11-libs/qt-dbus-4.5.3 ("<x11-libs/qt-dbus-4.5.3" is blockin
g x11-libs/qt-test-4.5.3-r1, x11-libs/qt-core-4.5.3-r2, x11-libs/qt-opengl-4.5.3
-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-svg-4.5
.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.
5.3)
[ebuild U ] x11-libs/qt-dbus-4.5.3-r1 [4.4.2] USE="-debug -pch" 0 kB [0]
[nomerge ] kde-base/kdepimlibs-4.3.1 USE="handbook ldap (-aqua) -debug (-k
deprefix) -test" [0]
[ebuild N ] x11-libs/qt-test-4.5.3-r1 USE="iconv -debug -pch" 0 kB [0]
[blocks b ] <x11-libs/qt-script-4.5.3 ("<x11-libs/qt-script-4.5.3" is bloc
king x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.
3-r2, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-qt3supp
ort-4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4
.5.3)
[ebuild U ] x11-libs/qt-script-4.5.3-r1 [4.4.2] USE="iconv%* -debug -pch"
0 kB [0]
[blocks b ] <x11-libs/qt-sql-4.5.3 ("<x11-libs/qt-sql-4.5.3" is blocking
x11-libs/qt-test-4.5.3-r1, x11-libs/qt-dbus-4.5.3-r1, x11-libs/qt-core-4.5.3-r2
, x11-libs/qt-opengl-4.5.3-r1, x11-libs/qt-gui-4.5.3-r1, x11-libs/qt-qt3support-
4.5.3, x11-libs/qt-svg-4.5.3-r1, x11-libs/qt-script-4.5.3-r1, x11-libs/qt-webkit
-4.5.3)


Sono sempre quei maledetti qt....
Ciao
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 6:47 pm    Post subject: Reply with quote

Siccome ho installato in modo maldestro le qt-gui e cioè senza l'opzione --oneshot non è che rimuovendo con emerge --unmerge le qt installate (Installed versions: 4.4.2-r1(4)[1](21:05:13 31/10/2009)(accessibility cups dbus mng qt3support tiff -debug -glib -input_devices_wacom -nas -nis -pch -xinerama) potrei risolvere il mio problema e finalmente aggiornare il sistema?
Ciao
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Thu Nov 05, 2009 7:14 pm    Post subject: Reply with quote

Epicuro wrote:
Siccome ho installato in modo maldestro le qt-gui e cioè senza l'opzione --oneshot non è che rimuovendo con emerge --unmerge le qt installate (Installed versions: 4.4.2-r1(4)[1](21:05:13 31/10/2009)(accessibility cups dbus mng qt3support tiff -debug -glib -input_devices_wacom -nas -nis -pch -xinerama) potrei risolvere il mio problema e finalmente aggiornare il sistema?
Ciao

In tal caso basterebbe modificare
Code:
/var/lib/portage/world
e cancellare la riga
Code:
x11-libs/qt-gui

_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 7:56 pm    Post subject: Reply with quote

L'avevo fatto in precedenza su suggerimento di Scen. Evidentemente sono troppo newbie se ho posto tale domanda.Comunque i blocchi non spariscono e a questo punto posso solo sperare nel vostro aiuto per risolvere.
Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 05, 2009 8:12 pm    Post subject: Reply with quote

Uhm... proviamo con le maniere forti:

  1. Vediamo che versione hai installato dei vari pacchetti qt* (incollaci l'output del seguente comando):
    Code:

    eix -Ic -C x11-libs qt

  2. Se te la senti, procedi così:
  3. Fatti una copia di sicurezza di tali pacchetti:
    Code:

    eix -Inc --only-names -C x11-libs qt | xargs quickpkg --include-config=y

  4. Salvati l'elenco dei pacchetti qt, in modo da poterli installare manualmente dopo:
    Code:

    eix -Inc --only-names -C x11-libs qt > pacchetti_qt.txt

  5. RIMUOVI questi pacchetti bloccanti:
    Code:

    eix -Inc --only-names -C x11-libs qt | xargs emerge -aC

  6. Infine prova ad installare manualmente le versioni attuali di tali pacchetti:
    Code:

    cat pacchetti_qt.txt | xargs emerge --oneshot --ask


Spero ti possa risolvere il problema (purtroppo ho la sensazione che tu abbia un bel po' di casino nel tuo sistema, molto probabilmente a causa del precedente utilizzo di tutti quegli orverlay :? )
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 8:29 pm    Post subject: Reply with quote

Quote:
Hall9000 eddie # eix -Ic -C x11-libs qt
[I] x11-libs/qt (3.3.8b-r1(3)@27/08/2009): The Qt toolkit is a comprehensive C++ application development framework.
[U] x11-libs/qt-core (4.4.2-r2(4)@31/10/2009 -> 4.5.3-r2(4)): The Qt toolkit is a comprehensive C++ application development framework
[U] x11-libs/qt-dbus (4.4.2(4)@31/10/2009 -> 4.5.3-r1(4)): The DBus module for the Qt toolkit
[U] x11-libs/qt-gui (4.4.2-r1(4)[1]@31/10/2009 -> 4.5.3-r1(4)): The GUI module for the Qt toolkit
[U] x11-libs/qt-qt3support (4.4.2(4)@31/10/2009 -> 4.5.3(4)): The Qt3 support module for the Qt toolkit
[U] x11-libs/qt-script (4.4.2(4)@31/10/2009 -> 4.5.3-r1(4)): The ECMAScript module for the Qt toolkit
[U] x11-libs/qt-sql (4.4.2-r1(4)@31/10/2009 -> 4.5.3(4)): The SQL module for the Qt toolkit
[1] "gentoo-taiwan" /usr/local/portage/layman/gentoo-taiwan
[2] "sabayon" /usr/local/portage/layman/sabayon

Found 7 matches.



Ti ringrazio, ci proverò e ti farò sapere.
Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 05, 2009 8:42 pm    Post subject: Reply with quote

Epicuro wrote:
Code:
Hall9000 eddie # eix -Ic -C x11-libs qt
[I] x11-libs/qt (3.3.8b-r1(3)@27/08/2009): The Qt toolkit is a comprehensive C++ application development framework.


Spè spè spè, momento momento monento! (come direbbe Peter Griffin :P )

Vedo che hai installato anche la versione 3* di qt, per cui meglio evitare di rimuoverle!

Modifica il comando per la rimozione
Code:

eix -Inc --only-names -C x11-libs qt | xargs emerge -aC

in
Code:

eix -Inc --only-names -C x11-libs qt- | xargs emerge -aC

(c'è il segno "meno" dopo "qt")
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 9:16 pm    Post subject: Reply with quote

Quote:
Hall9000 eddie # eix -Inc --only-names -C x11-libs qt- | xargs emerge -aC
!!! "--ask" should only be used in a terminal. Exiting.


Forse mi sta dicendo che devo abbandonare il server grafico?
Ciao
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Thu Nov 05, 2009 9:22 pm    Post subject: Reply with quote

si devi uscire da X
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 05, 2009 9:45 pm    Post subject: Reply with quote

Epicuro wrote:
Quote:
Hall9000 eddie # eix -Inc --only-names -C x11-libs qt- | xargs emerge -aC
!!! "--ask" should only be used in a terminal. Exiting.


Forse mi sta dicendo che devo abbandonare il server grafico?

Pork.. >_< Pardon :P

Toglie la a:
Code:

eix -Inc --only-names -C x11-libs qt- | xargs emerge -C


N.B. Non ti chiederà conferma della rimozione (ma tanto DEVI rimuoverli in qualche modo :) )
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 9:50 pm    Post subject: Reply with quote

Quote:
cat pacchetti_qt.txt | xargs emerge --oneshot --ask


Anche qui devo togliere --ask?
Te lo chiedo perchè mi ha già respinto la richiesta come prima.
Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Nov 05, 2009 9:56 pm    Post subject: Reply with quote

Epicuro wrote:
Quote:
cat pacchetti_qt.txt | xargs emerge --oneshot --ask


Anche qui devo togliere --ask?

Sì, certo! Chiedo venia, mi ero dimenticato di questa restrizione :?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Thu Nov 05, 2009 10:35 pm    Post subject: Reply with quote

Sto reinstallando i pacchetti.
Al termine effettuerò un emerge --sync e poi, che Dio me la mandi buona, emerge -ptDNuv --with-bdeps y world .
Ti farò sapere.
Ciao e ancora grazie
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Sat Nov 07, 2009 9:29 am    Post subject: Reply with quote

Alla fine dopo aver eseguito gli ultimi comandi suggeriti da Scen sono riuscito ad aggiornare tutto il sistema senza intoppi. L'unica nota negativa è stata la mancata installazione del pacchetto dev-pyton/setuptools.
Adesso sto procedendo anche all'installazione di kde 4.3 meta.
Se sono riuscito ad ottenere questo risultato lo devo a voi ragazzi e in paticolare a Scen.
Vi ringrazio.
Ciao
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum