Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Installazione kde-meta 4.3
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Sun Oct 25, 2009 6:12 pm    Post subject: [Risolto]Installazione kde-meta 4.3 Reply with quote

Saluto gli amici del forum.
Tempo fa, in un altro post, avevo ricevuto dei suggerimenti da djinnZ su come passare in futuro da kde 3.5.10 a kde 4.3.
in particolare:
Quote:
Guarda che non ti avevo suggerito di passare a kde4 ma a qt4 con supporto alle qt3 così quando finalmente il kde3.5 andrà in pensione non dovrai ricompilare mezzo mondo e potrai togliertelo dai piedi un pezzo alla volta; però la cosa implica alcuni problemi nella risoluzione automatica delle dipendenze (ovvero devi rimuovere manualmente un paio di librerie e poi installarne altre con -1, nulla di esoterico).

Adesso sarei intenzionato a passare alla versione 4.3 e lanciando il comando seguente :
#emerge -pv kde-meta:4.3
ottengo la lista completa dei pacchetti e alla fine questo output:
Quote:
Total: 311 packages (6 downgrades, 276 new, 28 in new slots, 1 reinstall), Size of downloads: 631,031 kB
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/vdr-xine
[2] /usr/local/portage/layman/gentoo-taiwan

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')

('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdeartwork-colorschemes-4.3.1', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/ksquares-4.3.1', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kwallet-4.3.1', 'merge')
(and 231 more)

x11-libs/qt-core:4

('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/ktimezoned-4.3.1', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/ktimetracker-4.3.1', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kdenetwork-filesharing-4.3.1', 'merge')
(and 240 more)

('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
(and 7 more)

x11-libs/qt-sql:4

('ebuild', '/', 'x11-libs/qt-sql-4.5.2', 'merge') pulled in by
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kmix-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kcminit-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kcheckpass-4.3.1', 'merge')
(and 232 more)

('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')

('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kcminit-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kcheckpass-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kdeartwork-kscreensaver-4.3.1', 'merge')
(and 231 more)

x11-libs/qt-dbus:4

('installed', '/', 'x11-libs/qt-dbus-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-dbus-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
(and 3 more)

('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')
(and 3 more)

x11-libs/qt-gui:4

('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/libkdeedu-4.3.1', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/konqueror-4.3.1', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/phonon-kde-4.3.1', 'merge')
(and 239 more)

('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge')
>=x11-libs/qt-gui-4.4.0:4[mng] required by ('ebuild', '/', 'kde-base/kopete-4.3.1', 'merge')
(and 5 more)

x11-libs/qt-qt3support:4

('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r1', 'merge')

('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kmines-4.3.1', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kdepim-wizards-4.3.1', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kurifilter-plugins-4.3.1', 'merge')
(and 230 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

Mi sembra di aver capito che i seguenti pacchetti non possono essere installati simultaneamente pena un conflitto tra le dipendenze.
Nel suggerimento di djiniZ avrei dovuto rimuovere manualmente alcune librerie ed installarle altre con -1.
Confesso di non capire a causa della mia inesperienza.
Quel poco che riesco ad intendere è che potrei utilizzare il file package.mask per prevenire che venga selezionato uno dei pacchetti in questione ma questo forse potrebbe portare il sistema a diventare instabile.
O dovrei installare quei pacchetti uno alla volta?
Grazie per eventuali suggerimenti.


Last edited by Epicuro on Sat Nov 07, 2009 9:33 am; edited 1 time in total
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Sun Oct 25, 2009 6:24 pm    Post subject: Reply with quote

personalmente quando ho avuto un problema simile (anche con le qt) ho rimosso tutto con emerge -C e poi ho proseguito..e alla fine ho lanciato un aggiornamento per verificare se c'era qualcosa se mi mancava....non so se puo essere una soluzione per te
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Oct 25, 2009 9:28 pm    Post subject: Reply with quote

Sembra che tu abbia dei conflitti tra due versioni di qt (4.4 e 4.5), fai un po' di pacchetti (giusto nel caso in cui vada male e tu debba tornare indietro, ti risparmi un po' di ricompilazioni) con quickpkg, rimuovi le versioni vecchie di qt e prova ad aggiornare world.
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Oct 26, 2009 5:03 pm    Post subject: Reply with quote

Intanto vi ringrazio per i rapidi suggerimenti.
Se non ho capito male dovrei provare a rimuovere le seguenti versioni qt:
Quote:
'x11-libs/qt-script-4.4.2' 'x11-libs/qt-core-4.4.2-r2' 'x11-libs/qt-sql-4.4.2-r1' 'x11-libs/qt-dbus-4.4.2' 'x11-libs/qt-gui-4.4.2-r1' 'x11-libs/qt-qt3support-4.4.2'


Poi quali pacchetti dovrei fare con quickpkg?
E in caso qualche cosa dovesse andar storto dovrei riemergere i pacchetti salvati con quickpkg vero?
Ciao
Back to top
View user's profile Send private message
ago
Developer
Developer


Joined: 01 Mar 2008
Posts: 1518
Location: Cosenza, Italy

PostPosted: Mon Oct 26, 2009 7:37 pm    Post subject: Reply with quote

personalmente non consoco il metodo di riverdragon...ma in generale di solito quando si hanno problemi si cerca di tracciare un strada per risolverli....se nel tuo caso quei pacchetti ti danno problemi..una soluzione puo essere toglierli..vedere se si eliminano i conflitti, emergere ciò che ti serve...e lanciare un aggiornamento completo per verificare che non ti manca nulla di quello che hai tolto precedentemente....semplice ;)
P.s. alla fine un revdep non guasta mai
_________________
Contattami se vuoi contribuire in:
-Arch tester
-Chromium tester
-Traduzione doc. it
-Security
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Sun Nov 01, 2009 4:12 pm    Post subject: Reply with quote

Ho seguito il tuo suggerimento ago88 e cioè ho eliminato i pacchetti in questione,lanciato emerge --sync quindi emerge --update --newuse --deep world che mi ha rilasciato il seguente output:
Quote:
!! All ebuilds that could satisfy ">=x11-libs/qt-gui-4.5.1:4[accessibility,dbus]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.6.0_beta1 (masked by: package.mask, ~x86 keyword)
/usr/portage/profiles/package.mask:
# Alex Alexander <wired@gentoo.org> (16 Oct 2009)
# Qt 4.6.0 beta - masking before adding for testing

- x11-libs/qt-gui-4.5.3-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.3-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r3 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "app-office/openoffice-3.1.1-r1" [ebuild])
(dependency required by "world" [argument])


Invece lanciando : # emerge -pv kde-meta:4.3
ottengo il seguente output:
Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-libs/qt-gui-4.5.1:4[accessibility,dbus]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.6.0_beta1 (masked by: package.mask, ~x86 keyword)
/usr/portage/profiles/package.mask:
# Alex Alexander <wired@gentoo.org> (16 Oct 2009)
# Qt 4.6.0 beta - masking before adding for testing

- x11-libs/qt-gui-4.5.3-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.3-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r3 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "kde-base/kcalc-4.3.2" [ebuild])
(dependency required by "kde-base/kdeutils-meta-4.3.2" [ebuild])
(dependency required by "kde-base/kde-meta-4.3.2" [ebuild])
(dependency required by "kde-meta:4.3" [argument])


Cosa mi suggerisci?
Ciao e grazie.
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Sun Nov 01, 2009 5:06 pm    Post subject: Reply with quote

Secondo me il sync che hai fatto non è andato a buon fine. Io ho appena syncato e qt-gui non è mascherato. Puoi controllare su http://packages.gentoo.org
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Sun Nov 01, 2009 5:50 pm    Post subject: Reply with quote

Ho appena fatto il --sync e poi # emerge --update --newuse --deep world
Il risultato è il medesimo.
Durante il sync e alla fine non ho ricevuto messaggi che mi indicavano problemi.
Mi ero dimenticato di riferire che per la disperazione ieri avevo lanciato anche un emerge qt-gui.
Sono in stallo, come potrei verificare che il mio sistema è ok?
Ciao
Back to top
View user's profile Send private message
table
Apprentice
Apprentice


Joined: 17 Feb 2007
Posts: 279
Location: Gazzaniga (BG) Italy

PostPosted: Sun Nov 01, 2009 8:46 pm    Post subject: Reply with quote

sicuro di non avere dei pacchetti volutamente masckerati nel package.mask?
verifica il contenuto dei file package.mask, packege.unmask e package.keywords nella directory /etc/portage/

e se possibile posta il loro contenuto relativo
_________________
Pulisci l'html con:
Code:
sed 's/<[Bb][Rr][ \t]*\/*>/\n/g;s/<\/*[^>]\+\/*>//g'

skype: matteopinguino
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 1:17 pm    Post subject: Reply with quote

File Package.keywords

Quote:
# Autogenerated by regenerate-files, DO NOT EDIT.
# You can use this file to keyword/unkeyword the KDE 4.3 release.
# Edit Documentation/package.keywords/kde-4.3.d/ files instead.
kde-base/kdeplasma-addons:4.3
kde-base/kde-l10n:4.3
kde-base/kdeaccessibility-colorschemes:4.3
kde-base/kdeaccessibility-iconthemes:4.3
kde-base/kmag:4.3
kde-base/kmousetool:4.3
kde-base/kmouth:4.3
kde-base/kttsd:4.3
kde-base/kcron:4.3
kde-base/knetworkconf:4.3
kde-base/ksystemlog:4.3
kde-base/kuser:4.3
kde-base/system-config-printer-kde:4.3
kde-base/kdeartwork-colorschemes:4.3
kde-base/kdeartwork-desktopthemes:4.3
kde-base/kdeartwork-emoticons:4.3
kde-base/kdeartwork-iconthemes:4.3
kde-base/kdeartwork-kscreensaver:4.3
kde-base/kdeartwork-sounds:4.3
kde-base/kdeartwork-styles:4.3
kde-base/kdeartwork-wallpapers:4.3
kde-base/kdeartwork-weatherwallpapers:4.3
kde-base/dolphin:4.3
kde-base/drkonqi:4.3
kde-base/kappfinder:4.3
kde-base/kcheckpass:4.3
kde-base/kcminit:4.3
kde-base/kcmshell:4.3
kde-base/kcontrol:4.3
kde-base/kdebase-cursors:4.3
kde-base/kdebase-data:4.3
kde-base/kdebase-desktoptheme:4.3
kde-base/kdebase-kioslaves:4.3
kde-base/kdebase-menu:4.3
kde-base/kdebase-menu-icons:4.3
kde-base/kdebase-startkde:4.3
kde-base/kdebase-wallpapers:4.3
kde-base/kdebugdialog:4.3
kde-base/kglobalaccel:4.3
kde-base/kdepasswd:4.3
kde-base/kdesu:4.3
kde-base/kdialog:4.3
kde-base/kdm:4.3
kde-base/keditbookmarks:4.3
kde-base/keditfiletype:4.3
kde-base/kephal:4.3
kde-base/kfile:4.3
kde-base/kfind:4.3
kde-base/kfmclient:4.3
kde-base/khelpcenter:4.3
kde-base/khotkeys:4.3
kde-base/kiconfinder:4.3
kde-base/kinfocenter:4.3
kde-base/kioclient:4.3
kde-base/klipper:4.3
kde-base/kmenuedit:4.3
kde-base/kmimetypefinder:4.3
kde-base/knetattach:4.3
kde-base/knewstuff:4.3
kde-base/knotify:4.3
kde-base/konqueror:4.3
kde-base/konsole:4.3
kde-base/kpasswdserver:4.3
kde-base/kquitapp:4.3
kde-base/kreadconfig:4.3
kde-base/krunner:4.3
kde-base/kscreensaver:4.3
kde-base/ksmserver:4.3
kde-base/ksplash:4.3
kde-base/kstart:4.3
kde-base/kstartupconfig:4.3
kde-base/kstyles:4.3
kde-base/ksysguard:4.3
kde-base/ksystraycmd:4.3
kde-base/ktimezoned:4.3
kde-base/ktraderclient:4.3
kde-base/kuiserver:4.3
kde-base/kurifilter-plugins:4.3
kde-base/kwalletd:4.3
kde-base/kwin:4.3
kde-base/kwrite:4.3
kde-base/kwrited:4.3
kde-base/libkonq:4.3
kde-base/libkworkspace:4.3
kde-base/libplasmaclock:4.3
kde-base/libtaskmanager:4.3
kde-base/nepomuk:4.3
kde-base/nsplugins:4.3
kde-base/phonon-kde:4.3
kde-base/plasma-apps:4.3
kde-base/plasma-runtime:4.3
kde-base/plasma-workspace:4.3
kde-base/policykit-kde:4.3
kde-base/powerdevil:4.3
kde-base/renamedlg-plugins:4.3
kde-base/solid:4.3
kde-base/solid-hardware:4.3
kde-base/solidautoeject:4.3
kde-base/soliduiserver:4.3
kde-base/systemsettings:4.3
kde-base/kdebindings-csharp:4.3
kde-base/krossjava:4.3
kde-base/krosspython:4.3
kde-base/krossruby:4.3
kde-base/pykde4:4.3
kde-base/smoke:4.3
kde-base/blinken:4.3
kde-base/kalgebra:4.3
kde-base/kalzium:4.3
kde-base/kanagram:4.3
kde-base/kbruch:4.3
kde-base/kgeography:4.3
kde-base/khangman:4.3
kde-base/kig:4.3
kde-base/kiten:4.3
kde-base/klettres:4.3
kde-base/kmplot:4.3
kde-base/kstars:4.3
kde-base/ktouch:4.3
kde-base/kturtle:4.3
kde-base/kwordquiz:4.3
kde-base/libkdeedu:4.3
kde-base/marble:4.3
kde-base/parley:4.3
kde-base/step:4.3
kde-base/bomber:4.3
kde-base/bovo:4.3
kde-base/kapman:4.3
kde-base/katomic:4.3
kde-base/kbattleship:4.3
kde-base/kblackbox:4.3
kde-base/kblocks:4.3
kde-base/kbounce:4.3
kde-base/kbreakout:4.3
kde-base/kdiamond:4.3
kde-base/kfourinline:4.3
kde-base/kgoldrunner:4.3
kde-base/killbots:4.3
kde-base/kiriki:4.3
kde-base/kjumpingcube:4.3
kde-base/klines:4.3
kde-base/kmahjongg:4.3
kde-base/kmines:4.3
kde-base/knetwalk:4.3
kde-base/kolf:4.3
kde-base/kollision:4.3
kde-base/konquest:4.3
kde-base/kpat:4.3
kde-base/kreversi:4.3
kde-base/ksame:4.3
kde-base/kshisen:4.3
kde-base/ksirk:4.3
kde-base/kspaceduel:4.3
kde-base/ksquares:4.3
kde-base/ksudoku:4.3
kde-base/ktron:4.3
kde-base/ktuberling:4.3
kde-base/kubrick:4.3
kde-base/libkdegames:4.3
kde-base/libkmahjongg:4.3
kde-base/lskat:4.3
kde-base/gwenview:4.3
kde-base/kamera:4.3
kde-base/kcolorchooser:4.3
kde-base/kgamma:4.3
kde-base/kolourpaint:4.3
kde-base/kruler:4.3
kde-base/ksaneplugin:4.3
kde-base/ksnapshot:4.3
kde-base/libkdcraw:4.3
kde-base/libkexiv2:4.3
kde-base/libksane:4.3
kde-base/libkipi:4.3
kde-base/okular:4.3
kde-base/svgpart:4.3
kde-base/kdegraphics-strigi-analyzer:4.3
kde-base/thumbnailers:4.3
kde-base/kde-env:4.3
kde-base/kdelibs:4.3
kde-base/kdepimlibs:4.3
kde-base/libknotificationitem:4.3
kde-base/oxygen-icons:4.3
kde-base/dragonplayer:4.3
kde-base/juk:4.3
kde-base/kdemultimedia-kioslaves:4.3
kde-base/kmix:4.3
kde-base/kscd:4.3
kde-base/libkcddb:4.3
kde-base/libkcompactdisc:4.3
kde-base/mplayerthumbs:4.3
kde-base/kdenetwork-filesharing:4.3
kde-base/kdnssd:4.3
kde-base/kget:4.3
kde-base/kopete:4.3
kde-base/kppp:4.3
kde-base/krdc:4.3
kde-base/krfb:4.3
kde-base/lilo-config:4.3
kde-base/kfloppy:4.3
kde-base/kdelirc:4.3
kde-base/akonadi:4.3
kde-base/akregator:4.3
kde-base/kabcclient:4.3
kde-base/kaddressbook:4.3
kde-base/kalarm:4.3
kde-base/kdepim-icons:4.3
kde-base/kdepim-kresources:4.3
kde-base/kdepim-strigi-analyzer:4.3
kde-base/kdepim-wizards:4.3
kde-base/kjots:4.3
kde-base/kleopatra:4.3
kde-base/kmail:4.3
kde-base/kmailcvt:4.3
kde-base/knode:4.3
kde-base/knotes:4.3
kde-base/konsolekalendar:4.3
kde-base/kontact:4.3
kde-base/kontact-specialdates:4.3
kde-base/kontactinterfaces:4.3
kde-base/korganizer:4.3
kde-base/kpilot:4.3
kde-base/ktimetracker:4.3
kde-base/libkdepim:4.3
kde-base/libkleo:4.3
kde-base/libkpgp:4.3
kde-base/libksieve:4.3
kde-base/mimelib:4.3
kde-base/cervisia:4.3
kde-base/kapptemplate:4.3
kde-base/kate:4.3
kde-base/kbugbuster:4.3
kde-base/kcachegrind:4.3
kde-base/kdeaccounts-plugin:4.3
kde-base/kdesdk-kioslaves:4.3
kde-base/kdesdk-misc:4.3
kde-base/kdesdk-scripts:4.3
kde-base/kdesdk-strigi-analyzer:4.3
kde-base/kompare:4.3
kde-base/kstartperf:4.3
kde-base/kuiviewer:4.3
kde-base/lokalize:4.3
kde-base/umbrello:4.3
kde-base/amor:4.3
kde-base/kteatime:4.3
kde-base/ktux:4.3
kde-base/kweather:4.3
kde-base/ark:4.3
kde-base/kcalc:4.3
kde-base/kcharselect:4.3
kde-base/kdessh:4.3
kde-base/kdf:4.3
kde-base/kgpg:4.3
kde-base/ktimer:4.3
kde-base/kwallet:4.3
kde-base/okteta:4.3
kde-base/printer-applet:4.3
kde-base/superkaramba:4.3
kde-base/sweeper:4.3
kde-base/kfilereplace:4.3
kde-base/kimagemapeditor:4.3
kde-base/klinkstatus:4.3
kde-base/kommander:4.3
kde-base/kxsldbg:4.3
kde-base/kdeaccessibility-meta:4.3
kde-base/kdeadmin-meta:4.3
kde-base/kdeartwork-meta:4.3
kde-base/kdebase-meta:4.3
kde-base/kdeedu-meta:4.3
kde-base/kdegames-meta:4.3
kde-base/kdegraphics-meta:4.3
kde-base/kde-meta:4.3
kde-base/kdemultimedia-meta:4.3
kde-base/kdenetwork-meta:4.3
kde-base/kdepim-meta:4.3
kde-base/kdesdk-meta:4.3
kde-base/kdetoys-meta:4.3
kde-base/kdeutils-meta:4.3
kde-base/kdewebdev-meta:4.3
=app-admin/system-config-printer-common-1.1*
app-arch/xz-utils
=app-misc/hal-cups-utils-0.6*
=dev-python/pycups-1.9*
x11-misc/google-gadgets


File Package.unmask

Quote:
# Autogenerated by regenerate-files, DO NOT EDIT.
# You can use this file to mask/unmask KDE 4.3 release.
# Edit Documentation/package.unmask/kde-4.3.d/ files instead.
kde-base/kdeplasma-addons:4.3
kde-base/kde-l10n:4.3
kde-base/kdeaccessibility-colorschemes:4.3
kde-base/kdeaccessibility-iconthemes:4.3
kde-base/kmag:4.3
kde-base/kmousetool:4.3
kde-base/kmouth:4.3
kde-base/kttsd:4.3
kde-base/kcron:4.3
kde-base/knetworkconf:4.3
kde-base/ksystemlog:4.3
kde-base/kuser:4.3
kde-base/system-config-printer-kde:4.3
kde-base/kdeartwork-colorschemes:4.3
kde-base/kdeartwork-desktopthemes:4.3
kde-base/kdeartwork-emoticons:4.3
kde-base/kdeartwork-iconthemes:4.3
kde-base/kdeartwork-kscreensaver:4.3
kde-base/kdeartwork-sounds:4.3
kde-base/kdeartwork-styles:4.3
kde-base/kdeartwork-wallpapers:4.3
kde-base/kdeartwork-weatherwallpapers:4.3
kde-base/dolphin:4.3
kde-base/drkonqi:4.3
kde-base/kappfinder:4.3
kde-base/kcheckpass:4.3
kde-base/kcminit:4.3
kde-base/kcmshell:4.3
kde-base/kcontrol:4.3
kde-base/kdebase-cursors:4.3
kde-base/kdebase-data:4.3
kde-base/kdebase-desktoptheme:4.3
kde-base/kdebase-kioslaves:4.3
kde-base/kdebase-menu:4.3
kde-base/kdebase-menu-icons:4.3
kde-base/kdebase-startkde:4.3
kde-base/kdebase-wallpapers:4.3
kde-base/kdebugdialog:4.3
kde-base/kglobalaccel:4.3
kde-base/kdepasswd:4.3
kde-base/kdesu:4.3
kde-base/kdialog:4.3
kde-base/kdm:4.3
kde-base/keditbookmarks:4.3
kde-base/keditfiletype:4.3
kde-base/kephal:4.3
kde-base/kfile:4.3
kde-base/kfind:4.3
kde-base/kfmclient:4.3
kde-base/khelpcenter:4.3
kde-base/khotkeys:4.3
kde-base/kiconfinder:4.3
kde-base/kinfocenter:4.3
kde-base/kioclient:4.3
kde-base/klipper:4.3
kde-base/kmenuedit:4.3
kde-base/kmimetypefinder:4.3
kde-base/knetattach:4.3
kde-base/knewstuff:4.3
kde-base/knotify:4.3
kde-base/konqueror:4.3
kde-base/konsole:4.3
kde-base/kpasswdserver:4.3
kde-base/kquitapp:4.3
kde-base/kreadconfig:4.3
kde-base/krunner:4.3
kde-base/kscreensaver:4.3
kde-base/ksmserver:4.3
kde-base/ksplash:4.3
kde-base/kstart:4.3
kde-base/kstartupconfig:4.3
kde-base/kstyles:4.3
kde-base/ksysguard:4.3
kde-base/ksystraycmd:4.3
kde-base/ktimezoned:4.3
kde-base/ktraderclient:4.3
kde-base/kuiserver:4.3
kde-base/kurifilter-plugins:4.3
kde-base/kwalletd:4.3
kde-base/kwin:4.3
kde-base/kwrite:4.3
kde-base/kwrited:4.3
kde-base/libkonq:4.3
kde-base/libkworkspace:4.3
kde-base/libplasmaclock:4.3
kde-base/libtaskmanager:4.3
kde-base/nepomuk:4.3
kde-base/nsplugins:4.3
kde-base/phonon-kde:4.3
kde-base/plasma-apps:4.3
kde-base/plasma-runtime:4.3
kde-base/plasma-workspace:4.3
kde-base/policykit-kde:4.3
kde-base/powerdevil:4.3
kde-base/renamedlg-plugins:4.3
kde-base/solid:4.3
kde-base/solid-hardware:4.3
kde-base/solidautoeject:4.3
kde-base/soliduiserver:4.3
kde-base/systemsettings:4.3
kde-base/kdebindings-csharp:4.3
kde-base/krossjava:4.3
kde-base/krosspython:4.3
kde-base/krossruby:4.3
kde-base/pykde4:4.3
kde-base/smoke:4.3
kde-base/blinken:4.3
kde-base/kalgebra:4.3
kde-base/kalzium:4.3
kde-base/kanagram:4.3
kde-base/kbruch:4.3
kde-base/kgeography:4.3
kde-base/khangman:4.3
kde-base/kig:4.3
kde-base/kiten:4.3
kde-base/klettres:4.3
kde-base/kmplot:4.3
kde-base/kstars:4.3
kde-base/ktouch:4.3
kde-base/kturtle:4.3
kde-base/kwordquiz:4.3
kde-base/libkdeedu:4.3
kde-base/marble:4.3
kde-base/parley:4.3
kde-base/step:4.3
kde-base/bomber:4.3
kde-base/bovo:4.3
kde-base/kapman:4.3
kde-base/katomic:4.3
kde-base/kbattleship:4.3
kde-base/kblackbox:4.3
kde-base/kblocks:4.3
kde-base/kbounce:4.3
kde-base/kbreakout:4.3
kde-base/kdiamond:4.3
kde-base/kfourinline:4.3
kde-base/kgoldrunner:4.3
kde-base/killbots:4.3
kde-base/kiriki:4.3
kde-base/kjumpingcube:4.3
kde-base/klines:4.3
kde-base/kmahjongg:4.3
kde-base/kmines:4.3
kde-base/knetwalk:4.3
kde-base/kolf:4.3
kde-base/kollision:4.3
kde-base/konquest:4.3
kde-base/kpat:4.3
kde-base/kreversi:4.3
kde-base/ksame:4.3
kde-base/kshisen:4.3
kde-base/ksirk:4.3
kde-base/kspaceduel:4.3
kde-base/ksquares:4.3
kde-base/ksudoku:4.3
kde-base/ktron:4.3
kde-base/ktuberling:4.3
kde-base/kubrick:4.3
kde-base/libkdegames:4.3
kde-base/libkmahjongg:4.3
kde-base/lskat:4.3
kde-base/gwenview:4.3
kde-base/kamera:4.3
kde-base/kcolorchooser:4.3
kde-base/kgamma:4.3
kde-base/kolourpaint:4.3
kde-base/kruler:4.3
kde-base/ksaneplugin:4.3
kde-base/ksnapshot:4.3
kde-base/libkdcraw:4.3
kde-base/libkexiv2:4.3
kde-base/libksane:4.3
kde-base/libkipi:4.3
kde-base/okular:4.3
kde-base/svgpart:4.3
kde-base/kdegraphics-strigi-analyzer:4.3
kde-base/thumbnailers:4.3
kde-base/kde-env:4.3
kde-base/kdelibs:4.3
kde-base/kdepimlibs:4.3
kde-base/libknotificationitem:4.3
kde-base/oxygen-icons:4.3
kde-base/dragonplayer:4.3
kde-base/juk:4.3
kde-base/kdemultimedia-kioslaves:4.3
kde-base/kmix:4.3
kde-base/kscd:4.3
kde-base/libkcddb:4.3
kde-base/libkcompactdisc:4.3
kde-base/mplayerthumbs:4.3
kde-base/kdenetwork-filesharing:4.3
kde-base/kdnssd:4.3
kde-base/kget:4.3
kde-base/kopete:4.3
kde-base/kppp:4.3
kde-base/krdc:4.3
kde-base/krfb:4.3
kde-base/lilo-config:4.3
kde-base/kfloppy:4.3
kde-base/kdelirc:4.3
kde-base/akonadi:4.3
kde-base/akregator:4.3
kde-base/kabcclient:4.3
kde-base/kaddressbook:4.3
kde-base/kalarm:4.3
kde-base/kdepim-icons:4.3
kde-base/kdepim-kresources:4.3
kde-base/kdepim-strigi-analyzer:4.3
kde-base/kdepim-wizards:4.3
kde-base/kjots:4.3
kde-base/kleopatra:4.3
kde-base/kmail:4.3
kde-base/kmailcvt:4.3
kde-base/knode:4.3
kde-base/knotes:4.3
kde-base/konsolekalendar:4.3
kde-base/kontact:4.3
kde-base/kontact-specialdates:4.3
kde-base/kontactinterfaces:4.3
kde-base/korganizer:4.3
kde-base/kpilot:4.3
kde-base/ktimetracker:4.3
kde-base/libkdepim:4.3
kde-base/libkleo:4.3
kde-base/libkpgp:4.3
kde-base/libksieve:4.3
kde-base/mimelib:4.3
kde-base/cervisia:4.3
kde-base/kapptemplate:4.3
kde-base/kate:4.3
kde-base/kbugbuster:4.3
kde-base/kcachegrind:4.3
kde-base/kdeaccounts-plugin:4.3
kde-base/kdesdk-kioslaves:4.3
kde-base/kdesdk-misc:4.3
kde-base/kdesdk-scripts:4.3
kde-base/kdesdk-strigi-analyzer:4.3
kde-base/kompare:4.3
kde-base/kstartperf:4.3
kde-base/kuiviewer:4.3
kde-base/lokalize:4.3
kde-base/umbrello:4.3
kde-base/amor:4.3
kde-base/kteatime:4.3
kde-base/ktux:4.3
kde-base/kweather:4.3
kde-base/ark:4.3
kde-base/kcalc:4.3
kde-base/kcharselect:4.3
kde-base/kdessh:4.3
kde-base/kdf:4.3
kde-base/kgpg:4.3
kde-base/ktimer:4.3
kde-base/kwallet:4.3
kde-base/okteta:4.3
kde-base/printer-applet:4.3
kde-base/superkaramba:4.3
kde-base/sweeper:4.3
kde-base/kfilereplace:4.3
kde-base/kimagemapeditor:4.3
kde-base/klinkstatus:4.3
kde-base/kommander:4.3
kde-base/kxsldbg:4.3
kde-base/kdeaccessibility-meta:4.3
kde-base/kdeadmin-meta:4.3
kde-base/kdeartwork-meta:4.3
kde-base/kdebase-meta:4.3
kde-base/kdeedu-meta:4.3
kde-base/kdegames-meta:4.3
kde-base/kdegraphics-meta:4.3
kde-base/kde-meta:4.3
kde-base/kdemultimedia-meta:4.3
kde-base/kdenetwork-meta:4.3
kde-base/kdepim-meta:4.3
kde-base/kdesdk-meta:4.3
kde-base/kdetoys-meta:4.3
kde-base/kdeutils-meta:4.3
kde-base/kdewebdev-meta:4.3


Il file package.mask non esiste nella mia cartella /etc/portage.
Esistono package.use e le seguenti cartelle: bin; postsync.d; savedconfig.
Poi il package.keywords e il package.unmask non esistevano fino a quando li ho creati seguendo la gentoo guide relativa all'installazione di kde 4.
Ieri prima di rieseguire il --sync li avevo spostati su una cartella temporanea, ma il risultato non è cambiato.
Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Nov 02, 2009 1:35 pm    Post subject: Reply with quote

Epicuro wrote:
Mi ero dimenticato di riferire che per la disperazione ieri avevo lanciato anche un emerge qt-gui.

Senza l'opzione --oneshot (abbreviato -1) :?: :?: :?:

MALE :evil:

Togli subito la voce relativa a qt-gui dal file /var/lib/portage/world (è un file di testo, magari prima per sicurezza fai una copia di sicurezza, per non rischiare di rovinarlo incautamente).

Inoltre:

  • Rimuovi le voci relative ai pacchetti di KDE4 da package.unmask: ormai la versione 4.3.1 è stabile sulle principali architetture
  • Rifai il sync di Portage e poi incollaci l'output COMPLETO di
    Code:

    emerge -ptDNuv --with-bdeps y world



_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 2:07 pm    Post subject: Reply with quote

Ecco l'output:

Quote:
Hall9000 eddie # emerge -ptDNuv --with-bdeps y world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=x11-libs/qt-gui-4.5.1:4[accessibility,dbus]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.6.0_beta1 (masked by: package.mask, ~x86 keyword)
/usr/portage/profiles/package.mask:
# Alex Alexander <wired@gentoo.org> (16 Oct 2009)
# Qt 4.6.0 beta - masking before adding for testing

- x11-libs/qt-gui-4.5.3-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.3-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r3 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "app-office/openoffice-3.1.1-r1" [ebuild])
(dependency required by "world" [argument])


Ho rimosso la voce x11-libs/qt-gui dal file world.
Rimosso le voci relative a kde 4 nel il file package.unmask, praticamente tutte.
Il file package.keywords la avevo spostato in una crtella temporanea.
Ti posto anche il file world:
Quote:
app-admin/syslog-ng
app-cdr/k3b
app-dicts/ispell-it
app-office/openoffice
app-portage/eix
app-portage/genlop
app-portage/gentoolkit
app-portage/layman
app-text/acroread
app-text/evince
app-text/uudeview
dev-java/sun-jdk
dev-util/git
dev-util/lafilefixer
dev-util/subversion
kde-base/kde-i18n
kde-base/kdebase-startkde
kde-base/kdelibs
kde-base/kdemultimedia-meta
kde-base/kdm
kde-base/kmix
kde-base/konsole
kde-base/kopete
mail-client/mozilla-thunderbird
media-libs/alsa-lib
media-libs/libv4l
media-libs/mesa
media-libs/win32codecs
media-sound/alsa-utils
media-sound/lame
media-sound/mpg123
media-sound/vorbis-tools
media-tv/xawtv
media-video/camorama
media-video/mplayer
media-video/nvidia-settings
media-video/setpwc
media-video/smplayer
media-video/totem
media-video/w3cam
net-ftp/filezilla
net-im/skype
net-libs/libsoup:2.4
net-libs/xulrunner
net-misc/wicd
net-print/cups
net-print/gutenprint
net-voip/ekiga
net-wireless/iwl3945-ucode
net-wireless/wireless-tools
net-wireless/wpa_supplicant
sys-apps/ivman
sys-apps/man-pages-posix
sys-apps/pciutils
sys-apps/pcmciautils
sys-boot/grub
sys-kernel/gentoo-sources
sys-kernel/gentoo-sources:2.6.30-r4
sys-kernel/module-rebuild
sys-libs/e2fsprogs-libs
sys-process/vixie-cron
www-client/mozilla-firefox
www-plugins/adobe-flash
x11-apps/xdm
x11-base/xorg-server
x11-drivers/nvidia-drivers
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-synaptics
x11-libs/cairo

Ciao e grazie.
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Nov 02, 2009 2:38 pm    Post subject: Reply with quote

Epicuro wrote:
Code:

!!! All ebuilds that could satisfy ">=x11-libs/qt-gui-4.5.1:4[accessibility,dbus]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.6.0_beta1 (masked by: package.mask, ~x86 keyword)
/usr/portage/profiles/package.mask:
# Alex Alexander <wired@gentoo.org> (16 Oct 2009)
# Qt 4.6.0 beta - masking before adding for testing

- x11-libs/qt-gui-4.5.3-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.3-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.2-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r3 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)
...


C'è qualcosa di strano, in quanto sembra che il tuo portage tree non sia aggiornato, in quanto la versione 4.5.2 di qt-gui è stabile su x86. Sei sicuro che emerge --sync -v vada a buon fine?

Epicuro wrote:

Ti posto anche il file world:
Code:

app-admin/syslog-ng
app-cdr/k3b
app-dicts/ispell-it
app-office/openoffice
app-portage/eix
app-portage/genlop
app-portage/gentoolkit
app-portage/layman
app-text/acroread
app-text/evince
app-text/uudeview
dev-java/sun-jdk
dev-util/git
dev-util/lafilefixer
dev-util/subversion
kde-base/kde-i18n
kde-base/kdebase-startkde
kde-base/kdelibs
kde-base/kdemultimedia-meta
kde-base/kdm
kde-base/kmix
kde-base/konsole
kde-base/kopete
mail-client/mozilla-thunderbird
media-libs/alsa-lib
media-libs/libv4l
media-libs/mesa
media-libs/win32codecs
media-sound/alsa-utils
media-sound/lame
media-sound/mpg123
media-sound/vorbis-tools
media-tv/xawtv
media-video/camorama
media-video/mplayer
media-video/nvidia-settings
media-video/setpwc
media-video/smplayer
media-video/totem
media-video/w3cam
net-ftp/filezilla
net-im/skype
net-libs/libsoup:2.4
net-libs/xulrunner
net-misc/wicd
net-print/cups
net-print/gutenprint
net-voip/ekiga
net-wireless/iwl3945-ucode
net-wireless/wireless-tools
net-wireless/wpa_supplicant
sys-apps/ivman
sys-apps/man-pages-posix
sys-apps/pciutils
sys-apps/pcmciautils
sys-boot/grub
sys-kernel/gentoo-sources
sys-kernel/gentoo-sources:2.6.30-r4
sys-kernel/module-rebuild
sys-libs/e2fsprogs-libs
sys-process/vixie-cron
www-client/mozilla-firefox
www-plugins/adobe-flash
x11-apps/xdm
x11-base/xorg-server
x11-drivers/nvidia-drivers
x11-drivers/xf86-input-evdev
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-synaptics
x11-libs/cairo


8O

Ti consiglio di rimuovere da subito da codesto file:

  • kde-base/kdelibs
  • media-libs/alsa-lib
  • media-libs/libv4l
  • media-libs/mesa
  • media-libs/win32codecs
  • net-libs/libsoup:2.4
  • net-libs/xulrunner
  • sys-libs/e2fsprogs-libs
  • x11-drivers/nvidia-drivers
  • x11-drivers/xf86-input-evdev
  • x11-drivers/xf86-input-mouse
  • x11-drivers/xf86-input-synaptics
  • x11-libs/cairo

Sono tutte librerie o driver che non devono mai essere installati esplicitamente, in quanto sono sempre dipendenze di altri pacchetti (per esempio x11-drivers/* vengono richiamati tramite la variabile VIDEO_CARDS o INPUT_DEVICES del pacchetto xorg-server)
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 2:58 pm    Post subject: Reply with quote

Questo la parte finale del comando emerge --sync

Quote:
Number of files: 136479
Number of files transferred: 371
Total file size: 181857169 bytes
Total transferred file size: 2164964 bytes
Literal data: 2164964 bytes
Matched data: 0 bytes
File list size: 3419156
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 78373
Total bytes received: 4262090

sent 78373 bytes received 4262090 bytes 18995.46 bytes/sec
total size is 181857169 speedup is 41.90


Non ci sono segnalazioni di errori almeno così mi sembra.
Come hai potuto vedere non ho aggiunto l'opzione -v al comando emerge --sync.
Forse era meglio?
Comunque ho rimosso,come hai detto tu, le voci dal file world.
Adesso dovrei rieffettuare un sync nuovamente?
Non è che il server mi sbatta fuori per aver effettuato troppi sync in pochi giorni?
Così ho capito dal manuale gentoo.
Ciao
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Mon Nov 02, 2009 3:26 pm    Post subject: Reply with quote

l'opzione -v di emerge e' il verbose, in pratica ti mostra piu' informazioni in output. Non hai bisogno di syncare nuovamente, al massimo puoi dare un
Code:
emerge --depclean -p

per vedere se ci sono pacchetti da rimuovere (per rimuoverli poi ti basta lanciare lo stesso comando senza l'opzione "-p")
per il resto, da come ho capito tu vorresti installare l'ultima versione di kde4 stabile, giusto? se e' cosi non ti servono le voci relative a kde nel file package.keywords
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 3:48 pm    Post subject: Reply with quote

Questo l'output:

Quote:
emerge --depclean -p

* Depclean may break link level dependencies. Thus, it is
* recommended to use a tool such as `revdep-rebuild` (from
* app-portage/gentoolkit) in order to detect such breakage.
*
* Always study the list of packages to be cleaned for any obvious
* mistakes. Packages that are part of the world set will always
* be kept. They can be manually added to this set with
* `emerge --noreplace <atom>`. Packages that are listed in
* package.provided (see portage(5)) will be removed by
* depclean, even if they are part of the world set.
*
* As a safety measure, depclean will not remove any packages
* unless *all* required dependencies have been resolved. As a
* consequence, it is often necessary to run `emerge --update
* --newuse --deep world` prior to depclean.

Calculating dependencies... done!
* Dependencies could not be completely resolved due to
* the following required packages not being installed:
*
* x11-libs/qt-svg:4 pulled in by:
* net-wireless/wpa_supplicant-0.6.9
*
* ~net-libs/libsoup-gnome-2.26.3 pulled in by:
* net-libs/libsoup-2.26.3-r3
*
* Have you forgotten to run `emerge --update --newuse --deep world` prior
* to depclean? It may be necessary to manually uninstall packages that no longe r
* exist in the portage tree since it may not be possible to satisfy their
* dependencies. Also, be aware of the --with-bdeps option that is documented
* in `man emerge`.


Si vorrei kde 4 ma come vedi non riesco nemmeno ad aggiornare il sistema.
Il file package.keywords l'ho spostato da /etc/portage ad una cartella temporanea nella mia home.

Devo aver combinato qualche pasticcio in passato.
Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Nov 02, 2009 5:02 pm    Post subject: Reply with quote

Se non l'hai già fatto, installa eix:
Code:

# emerge eix

seguito da un
Code:

# eix-update

Poi incollaci l'output di
Code:

eix -n qt-gui

tanto per capire la situazione di sto pacchetto.

Inoltre incollaci l'attuale output di
Code:

ls -lR /etc/portage/

nonchè, per scrupolo, di
Code:

emerge --info

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 5:29 pm    Post subject: Reply with quote

Quote:
Hall9000 eddie # eix -n qt-gui
[U] x11-libs/qt-gui
Available versions: (4) 4.4.2-r1[1] 4.4.2-r3 ~4.4.2-r3[1] 4.5.1 ~4.5.1[1] ~4.5.1-r1 ~4.5.1-r1[1] ~4.5.1-r2 ~4.5.1-r2[1] ~4.5.1-r3[2] ~4.5.2-r1 ~4.5.2-r1[1] 4.5.2-r2 ~4.5.2-r2[1] 4.5.3-r1 ~4.5.3-r1[1] ~4.5.3-r2 [M]~4.6.0_beta1
{accessibility cups dbus debug glib gtk gtkstyle input_devices_wacom mng nas nis pch qt3support raster tiff xinerama}
Installed versions: 4.4.2-r1(4)[1](21:05:13 31/10/2009)(accessibility cups dbus mng qt3support tiff -debug -glib -input_devices_wacom -nas -nis -pch -xinerama)
Homepage: http://qt.nokia.com/
Description: The GUI module for the Qt toolkit

[1] "gentoo-taiwan" /usr/local/portage/layman/gentoo-taiwan
[2] "sabayon" /usr/local/portage/layman/sabayon


Poi

Quote:
Hall9000 eddie # ls -lR /etc/portage/
/etc/portage/:
totale 20
drwxr-xr-x 2 root root 4096 22 ago 18:05 bin
-rw-r--r-- 1 root root 169 2 nov 14:51 package.unmask
-rw-r--r-- 1 root root 75 23 ott 19:37 package.use
drwxr-xr-x 2 root root 4096 22 ago 18:05 postsync.d
drwxr-xr-x 3 root root 4096 18 ago 18:09 savedconfig

/etc/portage/bin:
totale 4
-rwxr-xr-x 1 root root 254 22 ago 18:05 post_sync

/etc/portage/postsync.d:
totale 4
-rw-r--r-- 1 root root 36 22 ago 18:05 q-reinitialize

/etc/portage/savedconfig:
totale 4
drwxr-xr-x 2 root root 4096 18 ago 18:09 sys-apps

/etc/portage/savedconfig/sys-apps:
totale 20
-rw-r--r-- 1 root root 20212 18 ago 18:09 busybox-1.13.2


Infine

Quote:
Hall9000 ~ # emerge --info
Portage 2.1.6.13 (default/linux/x86/10.0/desktop, gcc-4.1.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r61 i686)
=================================================================
System uname: Linux-2.6.30-gentoo-r61-i686-Genuine_Intel-R-_CPU_T2300_@_1.66GHz-with-gentoo-1.12.11.1
Timestamp of tree: Mon, 02 Nov 2009 16:20:02 +0000
app-shells/bash: 4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python: 2.4.6, 2.5.4-r3, 2.6.2-r1
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo "
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/python /usr/local/portage/layman/multimedia /usr/local/portage/layman/x11 /usr/local/portage/layman/vdr-xine /usr/local/portage/layman/gentoo-china /usr/local/portage/layman/gentoo-quebec /usr/local/portage/layman/gentoo-taiwan /usr/local/portage/layman/gentoo-arm /usr/local/portage/layman/sabayon /usr/local/portage/layman/zen-sources /usr/local/portage/layman/mozilla /usr/local/portage/layman/voip /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/kde-testing"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups dbus dga dri dts dv dvb dvd dvdr eds emboss encode esd evo fam ffmpeg firefox firefox3 flac fortran gif gpm gstreamer hal iconv ipv6 jpeg kde ldap libnotify lirc mad midi mikmod mmx mng modules motif mozilla mp3 mp3rtp mp4 mpeg msn mudflap mysql mythtv ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session sndfile spell spl sql ssl startup-notification svg symlink sysfs tcpd theora thunar tiff truetype unicode usb v4l v4l2 vorbis webkit win32codecs x264 x86 xext xml xorg xulrunner xv xvid zlib zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Grazie per la pazienza che mi concedi.
Ciao
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Mon Nov 02, 2009 6:07 pm    Post subject: Reply with quote

Quote:
gcc-4.1.2
8O
puoi postare l'output di
Code:
gcc-config -l

e
Code:
eix -I -c qt

?
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 6:26 pm    Post subject: Reply with quote

Quote:
Hall9000 ~ # gcc-config -l
[1] i686-pc-linux-gnu-4.1.2 *
[2] i686-pc-linux-gnu-4.3.2


Poi

Quote:
Hall9000 ~ # eix -I -c qt
[I] dev-libs/dbus-qt3-old (0.70@27/08/2009): D-BUS Qt3 bindings compatible with old application API and new dbus
[I] x11-libs/qt (3.3.8b-r1(3)@27/08/2009): The Qt toolkit is a comprehensive C++ application development framework.
[U] x11-libs/qt-core (4.4.2-r2(4)@31/10/2009 -> 4.5.3-r2(4)): The Qt toolkit is a comprehensive C++ application development framework
[U] x11-libs/qt-dbus (4.4.2(4)@31/10/2009 -> 4.5.3-r1(4)): The DBus module for the Qt toolkit
[U] x11-libs/qt-gui (4.4.2-r1(4)[1]@31/10/2009 -> 4.5.3-r1(4)): The GUI module for the Qt toolkit
[U] x11-libs/qt-qt3support (4.4.2(4)@31/10/2009 -> 4.5.3(4)): The Qt3 support module for the Qt toolkit
[U] x11-libs/qt-script (4.4.2(4)@31/10/2009 -> 4.5.3-r1(4)): The ECMAScript module for the Qt toolkit
[U] x11-libs/qt-sql (4.4.2-r1(4)@31/10/2009 -> 4.5.3(4)): The SQL module for the Qt toolkit
[1] "gentoo-taiwan" /usr/local/portage/layman/gentoo-taiwan
[2] "sabayon" /usr/local/portage/layman/sabayon

Found 8 matches.


Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Nov 02, 2009 6:41 pm    Post subject: Reply with quote

Epicuro wrote:

[U] x11-libs/qt-gui
Available versions: (4) 4.4.2-r1[1] 4.4.2-r3 ~4.4.2-r3[1] 4.5.1 ~4.5.1[1] ~4.5.1-r1 ~4.5.1-r1[1] ~4.5.1-r2 ~4.5.1-r2[1] ~4.5.1-r3[2] ~4.5.2-r1 ~4.5.2-r1[1] 4.5.2-r2 ~4.5.2-r2[1] 4.5.3-r1 ~4.5.3-r1[1] ~4.5.3-r2 [M]~4.6.0_beta1
{accessibility cups dbus debug glib gtk gtkstyle input_devices_wacom mng nas nis pch qt3support raster tiff xinerama}
Installed versions: 4.4.2-r1(4)[1](21:05:13 31/10/2009)(accessibility cups dbus mng qt3support tiff -debug -glib -input_devices_wacom -nas -nis -pch -xinerama)
Homepage: http://qt.nokia.com/
Description: The GUI module for the Qt toolkit

[1] "gentoo-taiwan" /usr/local/portage/layman/gentoo-taiwan
[2] "sabayon" /usr/local/portage/layman/sabayon
[/code]

TEEK!
Rimuovi all'istante l'overlay gentoo-taiwan e non pensarci più.

Ma.... non è che stai usando Sabayon Linux? :roll:
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Mon Nov 02, 2009 6:47 pm    Post subject: Reply with quote

ti direi anche di usare le gcc 4.3.2
_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Mon Nov 02, 2009 7:26 pm    Post subject: Reply with quote

Rimosso l'overlay gentoo-taiwan.
Per quanto riguarda la tua domanda su Sabayon linux posso dirti che è presente, come directory, nell'overlay.
Digitando:
Quote:
Hall9000 layman # uname -r
2.6.30-gentoo-r61


Quindi non starei utilizzando Sabayon.

Ciao
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Tue Nov 03, 2009 9:47 am    Post subject: Reply with quote

Per sicurezza rimuovi anche questo overlay sabayon, in quanto non so cosa contiene, e quasi sicuramente potrebbe crearti problemi durante l'aggiornamento del sistema.

Fatto questo, secondo me, l'aggiornamento del sistema e l'installazione di KDE4 dovrebbe proseguire senza problemi.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Epicuro
Tux's lil' helper
Tux's lil' helper


Joined: 15 Feb 2007
Posts: 91

PostPosted: Wed Nov 04, 2009 5:24 pm    Post subject: Reply with quote

Questa è l'attuale situazione:
la parte finale del comando emerge --sync -v

Quote:
Number of files: 136993
Number of files transferred: 2368
Total file size: 182765363 bytes
Total transferred file size: 11026811 bytes
Literal data: 11026811 bytes
Matched data: 0 bytes
File list size: 3204311
File list generation time: 0.001 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 87174
Total bytes received: 6892884

sent 87174 bytes received 6892884 bytes 47972.91 bytes/sec
total size is 182765363 speedup is 26.18
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/layman/gentoo-taiwan'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/layman/sabayon'


Questo l'output dell'aggiornamento:

Quote:
Hall9000 eddie # emerge -ptDNuv --with-bdeps y world
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/layman/gentoo-taiwan'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage/layman/sabayon'

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libsoup:2.4

('ebuild', '/', 'net-libs/libsoup-2.26.3-r3', 'merge') pulled in by
>=net-libs/libsoup-2.4 required by ('ebuild', '/', 'gnome-extra/evolution-data-server-2.26.3', 'merge')
~net-libs/libsoup-2.26.3 required by ('ebuild', '/', 'net-libs/libsoup-gnome-2.26.3-r1', 'merge')
>=net-libs/libsoup-2.25.90 required by ('ebuild', '/', 'net-libs/webkit-gtk-1.1.10', 'merge')

('installed', '/', 'net-libs/libsoup-2.26.3-r3', 'nomerge') pulled in by
>=net-libs/libsoup-2.25.1:2.4[gnome] required by ('ebuild', '/', 'dev-libs/libgweather-2.26.2.1', 'merge')
>=net-libs/libsoup-2.25.1[gnome] required by ('installed', '/', 'gnome-base/gvfs-1.2.3', 'nomerge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=sys-devel/libtool-2" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-devel/libtool-9999 (masked by: missing keyword)
- sys-devel/libtool-2.2.6a (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "dev-libs/redland-1.0.9-r1" [ebuild])
(dependency required by "app-office/openoffice-3.1.1" [ebuild])
(dependency required by "world" [argument])


Ho rimosso le directory che mi hai suggerito con un rm -r.
Ho paura che dovrò chiedere ancora il tuo aiuto.
Ciao
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum