Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub Error 17
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
snakeo2
Veteran
Veteran


Joined: 01 Jan 2006
Posts: 1237

PostPosted: Sun Oct 25, 2009 6:35 pm    Post subject: Reply with quote

Ok, no luck so far. Here is what i did. Edit my grub.conf file :

title Windows 7
map (hd0) (hd1)
map (hd1) (hd0)
roonoverify (hd1,0) &(hd1,1)
chainloader+1

and I get the following error when I select windows 7

map (hd0)(hd1)
Error: 11: unrecognized device string
_________________
Gigabyte MA790X-UD4P Motherboard
AMD Phenom II X4 940 Black Edition
MSI ATI R4650 PCIe2
250GB SATA Drive
4GB Corsair DDR2
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 374
Location: La Louviere (Belgique)

PostPosted: Sun Oct 25, 2009 7:14 pm    Post subject: Reply with quote

Can you verify : /boot/grub/device.map, fd0 are not required but hd0 to hd2 y
--------------
(fd0) /dev/fd0
(hd0) /dev/hda
(hd1) /dev/sda
(hd2) /dev/sdb
-----------

About grub.conf

title Windows 7
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
makeactive
chainloader +1

Attention if (hd1,0) can't work, try with (hd1,1)
Back to top
View user's profile Send private message
snakeo2
Veteran
Veteran


Joined: 01 Jan 2006
Posts: 1237

PostPosted: Sun Oct 25, 2009 8:22 pm    Post subject: Reply with quote

USTruck,

didnt see your post till now, but after doing some search I arrived at the same solution you proposed. I'm no able to boot into xp & windows 7. Now comes the hard part, getting my nic to work in gentoo, finding out whats wrong with the kernel symlink, re-configuring alsa, xorg, and a few other things. But at least im half there. Thanks for all your great help...without you I'll prob still be stuck on error 17. I will post later to provide update. I have to step away for now. Thanks again.
_________________
Gigabyte MA790X-UD4P Motherboard
AMD Phenom II X4 940 Black Edition
MSI ATI R4650 PCIe2
250GB SATA Drive
4GB Corsair DDR2
Back to top
View user's profile Send private message
Deathwing00
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Fri Apr 02, 2010 12:19 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads.

Check The Grub Error Collection
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum