Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[BOOT] Kernel panic - VFS (résolu)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Wed Oct 21, 2009 10:19 am    Post subject: [BOOT] Kernel panic - VFS (résolu) Reply with quote

Bonjour la comu,

J'essaye pour le moment de compiler mon propre Kernel, pour le moment ma gentoo tourne sur un genkernel en multiboot, je voulais correctement l'installer avant de faire mon kernel.

Lorsque je boot j'ai l'erreur suivante :

VFS :cannot open root device "sbb4" or unknown -block (0,0)
Please append a correct "root" = boot option
Kernel panic - not syncing : VFS : unable to mount root fs on unknown-block (0,0)


je vous met ici mon grub.conf (je n'ai pas encore changer le nom

Code:

title Gentoo Linux 2.6.30-r5
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.30-gentoo-r5 root=/dev/sdb4

title Gentoo Linux 2.6.30-r5 (rescue)
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-2.6.30-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sdb4
initrd /boot/initramfs-genkernel-x86_64-2.6.30-gentoo-r5


un petit ls /boot donne :

kernel-2.6.30-gentoo-r5 (Manuel)
kernel-genkernel-x86_64-2.6.30-gentoo-r5 (Genkernel)
initramfs-genkernel-x86_64-2.6.30-gentoo-r5 (genkernel)

fdisk /dev/sdb -l :

Code:
/dev/sdb1   *           1           5       40131   83  Linux
/dev/sdb2            2551       30401   223713157+   7  HPFS/NTFS
/dev/sdb3               6          68      506047+  82  Linux swap / Solaris
/dev/sdb4              69        2550    19936665   83  Linux


voici la partie file system de ma config manuelle :

Code:
#
# File systems
#
CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT2_FS_SECURITY=y
# CONFIG_EXT2_FS_XIP is not set
CONFIG_EXT3_FS=y
# CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
CONFIG_EXT3_FS_XATTR=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y
# CONFIG_EXT4_FS is not set
CONFIG_JBD=y
CONFIG_FS_MBCACHE=y
# CONFIG_REISERFS_FS is not set
CONFIG_JFS_FS=m
CONFIG_JFS_POSIX_ACL=y
CONFIG_JFS_SECURITY=y
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_STATISTICS is not set
CONFIG_FS_POSIX_ACL=y
CONFIG_XFS_FS=y
CONFIG_XFS_QUOTA=y
CONFIG_XFS_POSIX_ACL=y
CONFIG_XFS_RT=y
# CONFIG_XFS_DEBUG is not set
# CONFIG_GFS2_FS is not set
# CONFIG_OCFS2_FS is not set
# CONFIG_BTRFS_FS is not set
CONFIG_FILE_LOCKING=y
CONFIG_DNOTIFY=y
CONFIG_INOTIFY=y


udev est bien installe

le sata semble pas avoir de souci non plus :

Code:
lux ~ # cat /usr/src/linux/premierkernel.config |grep -i sata
# CONFIG_BLK_DEV_IDE_SATA is not set
CONFIG_SATA_PMP=y
CONFIG_SATA_AHCI=m
CONFIG_SATA_SIL24=m
CONFIG_SATA_SVW=m
CONFIG_SATA_MV=m
CONFIG_SATA_NV=m
CONFIG_SATA_QSTOR=m
CONFIG_SATA_PROMISE=m
CONFIG_SATA_SX4=m
CONFIG_SATA_SIL=m
CONFIG_SATA_SIS=m
CONFIG_SATA_ULI=m
CONFIG_SATA_VIA=m
CONFIG_SATA_VITESSE=m
CONFIG_SATA_INIC162X=m


voila je sais pas trop quoi vous donner d'autres comme information, a part que quand je boot sur mon genkernel ben ma gentoo tourne normalement, au premier essai je m'étais trompe dans le nom du kernel dans le grub.conf, apres rectification il a trouve le kernel mais ne peut pas monter mon root.

Que me conseillez vous ?
_________________
un noob parmis tant d'autre noob


Last edited by skizorager on Thu Oct 22, 2009 12:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Wed Oct 21, 2009 10:41 am    Post subject: Reply with quote

Salut,

Apparemment, il te manque des configs "en dur" (pas en module).

Vérifie :
- le pilote PATA/SATA
- le filesystem

Le reste peut être en module, udev (= le cold/hot plug-and-play de linux) est lancé dans les premiers services
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Wed Oct 21, 2009 11:12 am    Post subject: Reply with quote

Hellow xa, decidement tu es toujours un des premiers a me donner ta lumiere, merci beaucoup

Mon ext3 etait bien en dur, mais la partie pilote était :

<M> Serial ATA (prod) and Parallel ATA (experimental) drivers --->
<M> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support

j'ai transforme en :
<*> Serial ATA (prod) and Parallel ATA (experimental) drivers --->
<*> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support

et voici le resultat de la config, est-ce que cela vous semble plus correcte ? (je suis en ssh pour compiler le kernel donc je dois attendre ce soir pour booter sur le nouveau noyau)

Code:
lux ~ # cat /usr/src/linux/3.config |grep -i sata
# CONFIG_BLK_DEV_IDE_SATA is not set
CONFIG_SATA_PMP=y
CONFIG_SATA_AHCI=m
CONFIG_SATA_SIL24=m
CONFIG_SATA_SVW=m
CONFIG_SATA_MV=y
CONFIG_SATA_NV=m
CONFIG_SATA_QSTOR=m
CONFIG_SATA_PROMISE=m
CONFIG_SATA_SX4=m
CONFIG_SATA_SIL=m
CONFIG_SATA_SIS=m
CONFIG_SATA_ULI=m
CONFIG_SATA_VIA=m
CONFIG_SATA_VITESSE=m
CONFIG_SATA_INIC162X=m

_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Wed Oct 21, 2009 11:18 am    Post subject: Reply with quote

Je pense que ça devrait aller.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Wed Oct 21, 2009 6:03 pm    Post subject: Reply with quote

rep,

désolé mais ca fait le meme probleme

Code:
 <*> Ext3 journalling file system support                                                       │ │ 
  │ │                         [ ]   Default to 'data=ordered' in ext3 (legacy option)                                        │ │ 
  │ │                         [*]   Ext3 extended attributes                                                                 │ │ 
  │ │                         [*]     Ext3 POSIX Access Control Lists                                                        │ │ 
  │ │                         [*]     Ext3 Security Labels         

_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Wed Oct 21, 2009 8:01 pm    Post subject: Reply with quote

Et tu n'as pas la main via busybox ? Normalement genkernel intègre busybox et si tu t'es planté sur le real_root au boot il te permet ou d'avoir une console pour le retrouver (pratique quand le liveCD monte le bordel en hdXy et ton kernel tout neuf en sdXy) ou de renseigner directement un correct real_root.

Enfin bon sinon pour dire "chezmoiçamarche" j'ai un chip intel, de l'ext3, genkernel à l'arrache et tout en module (ou presque) ... et significativement la même chose que toi pour booter depuis grub :roll:

Tu as modifié un truc au .config ? fait un genkernel sans clean/proper ? ou à partir d'un oldconfig ? avec des options particulières ? (on sait jamais mais j'y crois pas)
_________________
Ez.
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Wed Oct 21, 2009 8:42 pm    Post subject: Reply with quote

j'ai les deux, mon but ici est justement d'optimiser mon kernel, de me défaire de genkernel.

j'ai toujours mon genkernel (voir grub.conf, system rescue) c'est grace a lui que je compile le nouveau.
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Wed Oct 21, 2009 9:03 pm    Post subject: Reply with quote

'alute

il faudrait que tu nous poste la sortie exacte du boot maintenant que tu as fait les modifs, recompilé et réinstallé le kernel et les initramfs (cad après la correction de "sdd4", l'ajout du support des fs en dur, etc) sinon on va chercher midi à 14h pour rien - cad être sûr que tu lances pas l'ancien kernel i.e. :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 423
Location: La Louviere (Belgique)

PostPosted: Wed Oct 21, 2009 9:20 pm    Post subject: Reply with quote

Bonsoir

Il y a peux être un problème entre la config kernel de genkernel, grub et le tient.

Genkernel parle d'un 'sdd'
Le fdisk lui d'un 'sdb' !!
et grub d'un disque (hd0,0) !!!!!!!

Quelle est la configuration exacte des disques et sur quel connecteur (ide/sata)
Pour chaque disque quelle sont les partitions (1 -> ext3 , 2-> swap, ..... par exemple)

Vérifie également dans le bios que le controleur SATA n'émule pas de l'IDE pour un ou plusieurs port SATA.

Du coup si effectivement il y a un problème a ce niveau, il te faudra aussi modifier le fstab d'ou l'importance d'avoir les boot messages

Merci
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 8:36 am    Post subject: Reply with quote

hello,

je suis confus, dans mon premier message je vous ai indiqué

VFS :cannot open root device "sbb4" or unknown -block (0,0) alors que l'erreur était VFS :cannot open root device "sdb4" or unknown -block (0,0), comme cela restait bloqué ainsi, je ne pouvais pas copier coller le rapport, alors j'ai googler et me suis trompé dans la retranscription.

pour précision c'est le kernel et non genkernel ki fait l'erreur bien sur,
donc pour UsTruck, genkernel = sdb4 > ca fonctionne, au moment du boot je vois check root sdb4 et il continue, kernel = sdb4 > foire, et grub = hd0,0

une chose p-e importante, lorsque j'ai suivi mon install gentoo, j'ai installé grub des 2 manieres, cad en éditant le grub.conf ET en faisant la commande grub --no-floppy, est-ce que cela aurait avoir dans mon probleme ?

UsTruck, quand tu demande la config exacte de mes disque est-ce que ceci te donne assé d'infos ?

Code:
lux sda3 # fdisk -l

Disque /dev/sda: 500.1 Go, 500107862016 octets
255 têtes, 63 secteurs/piste, 60801 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xe7bd328a

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               2        7649    61432560    f  W95 Etendue (LBA)
/dev/sda2   *        7650       33146   204804652+   7  HPFS/NTFS
/dev/sda3           33147       60801   222138787+   7  HPFS/NTFS
/dev/sda5               2        7649    61432528+   7  HPFS/NTFS

Disque /dev/sdb: 250.0 Go, 250059350016 octets
255 têtes, 63 secteurs/piste, 30401 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0xb0f9b0f9

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdb1   *           1           5       40131   83  Linux
/dev/sdb2            2551       30401   223713157+   7  HPFS/NTFS
/dev/sdb3               6          68      506047+  82  Linux swap / Solaris
/dev/sdb4              69        2550    19936665   83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Disque /dev/sdc: 500.1 Go, 500107862016 octets
255 têtes, 63 secteurs/piste, 60801 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Identifiant de disque : 0x8d399bc0

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sdc1               1       25496   204796588+   7  HPFS/NTFS
/dev/sdc2   *       25497       50992   204796620    7  HPFS/NTFS
/dev/sdc3           50993       56722    46026225    7  HPFS/NTFS
/dev/sdc4           56723       60801    32764567+   c  W95 FAT32 (LBA)


sda est en sata, sdb est en sata et sdc est mon hdd en usb

Pour la question de connaitre la sortie du kernel au boot, je suis incapable de te répondre, je comprends tout simplement pas ce que tu me demande, je vais tout de meme essayer de te donner quelques infos :

Code:
lux sda3 # cat /usr/src/linux/3.config |grep -i EXT3
CONFIG_EXT3_FS=y
# CONFIG_EXT3_DEFAULTS_TO_ORDERED is not set
CONFIG_EXT3_FS_XATTR=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT3_FS_SECURITY=y


Code:
lux sda3 # cat /usr/src/linux/3.config |grep -i EXT2
CONFIG_EXT2_FS=y
CONFIG_EXT2_FS_XATTR=y
CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT2_FS_SECURITY=y
# CONFIG_EXT2_FS_XIP is not set


Code:
lux sda3 # cat /usr/src/linux/3.config |grep -i sata
# CONFIG_BLK_DEV_IDE_SATA is not set
CONFIG_SATA_PMP=y
CONFIG_SATA_AHCI=m
CONFIG_SATA_SIL24=m
CONFIG_SATA_SVW=m
CONFIG_SATA_MV=y
CONFIG_SATA_NV=m
CONFIG_SATA_QSTOR=m
CONFIG_SATA_PROMISE=m
CONFIG_SATA_SX4=m
CONFIG_SATA_SIL=m
CONFIG_SATA_SIS=m
CONFIG_SATA_ULI=m
CONFIG_SATA_VIA=m
CONFIG_SATA_VITESSE=m
CONFIG_SATA_INIC162X=m


autre info qui pourrait parler plus vite à certain qu'à moi, dans le boot, j'ai remarqué qu'il listait les "available root device" et là je n'ai aucun periph sata, j'ai que mon CD-ROM IDE,

Et je comprends pas trop bozoo, car pour le genkernel il y a bien un initiframs, mais le kernel je n'en ai pas, (voir mon grub.conf)

et pour le hd0,0 le souci devrait egalement aparaitre avec le genkernel alors non?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Thu Oct 22, 2009 8:40 am    Post subject: Reply with quote

Salut,

Peux-tu aussi nous montrer ton grub.conf ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 8:56 am    Post subject: Reply with quote

biensur, meme si il n'a pas changer :

Code:
# Which listing to boot as default. 0 is the first, 1 the second etc.
default 0
# How many seconds to wait before the default listing is booted.
timeout 10
# Nice, fat splash-image to spice things up :)
# Comment out if you don't have a graphics card installed
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.30-r5
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.30-gentoo-r5 root=/dev/sdb4

title Gentoo Linux 2.6.30-r5 (rescue)
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-2.6.30-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sdb4
initrd /boot/initramfs-genkernel-x86_64-2.6.30-gentoo-r5


Code:
lux sda3 # ls /boot/
boot
config-kernel
grub
initramfs-genkernel-x86_64-2.6.30-gentoo-r5
kernel-2.6.30-gentoo-r5
kernel-genkernel-x86_64-2.6.30-gentoo-r5
lost+found
System.map-genkernel-x86_64-2.6.30-gentoo-r5

_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 22, 2009 8:57 am    Post subject: Reply with quote

bon alors on laisse tomber les infos relatives à genkernel car c'est ok avec lui.

On se concentre sur le kernel à la mano => soit c'est ton .config manuel auquel il manque encore quelques choses soit tu ne boote pas sur le bzImage fraichement recompilé - aurais-tu oublié de le copier dans la partition /boot montée après les modifications par hasard ?

Edit: merci de nous coller également la sortie exacte du message d'erreur au boot stp

Edit 2: heuu... c'est moi où...
Quote:
lux sda3 # ls /boot/
boot
config-kernel
grub
initramfs-genkernel-x86_64-2.6.30-gentoo-r5
kernel-2.6.30-gentoo-r5
kernel-genkernel-x86_64-2.6.30-gentoo-r5
lost+found
System.map-genkernel-x86_64-2.6.30-gentoo-r5

Quote:
Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 2 7649 61432560 f W95 Etendue (LBA)
/dev/sda2 * 7650 33146 204804652+ 7 HPFS/NTFS
/dev/sda3 33147 60801 222138787+ 7 HPFS/NTFS
/dev/sda5 2 7649 61432528+ 7 HPFS/NTFS

_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "


Last edited by boozo on Thu Oct 22, 2009 9:03 am; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Thu Oct 22, 2009 8:59 am    Post subject: Reply with quote

Ton kernel à la mano, tu l'as fait comment ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 9:25 am    Post subject: Reply with quote

boozo wrote:


Edit: merci de nous coller également la sortie exacte du message d'erreur au boot stp


je demande pas mieux, mais je ne sais pas faire de copier, je reboot, j ecris ca sur un papier et je te le dit,

Edit 2: heuu... c'est moi où...
Citation:
lux sda3 # ls /boot/
boot
config-kernel
grub
initramfs-genkernel-x86_64-2.6.30-gentoo-r5
kernel-2.6.30-gentoo-r5
kernel-genkernel-x86_64-2.6.30-gentoo-r5
lost+found
System.map-genkernel-x86_64-2.6.30-gentoo-r5

Citation:
Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 2 7649 61432560 f W95 Etendue (LBA)
/dev/sda2 * 7650 33146 204804652+ 7 HPFS/NTFS
/dev/sda3 33147 60801 222138787+ 7 HPFS/NTFS
/dev/sda5 2 7649 61432528+ 7 HPFS/NTFS

c'est toi, j'ai simplement lancer la commande depuis mon disque sda3, voici le meme resultat lancé depuis ma racine gentoo :

lux / # ls /boot/
boot
config-kernel
grub
initramfs-genkernel-x86_64-2.6.30-gentoo-r5
kernel-2.6.30-gentoo-r5
kernel-genkernel-x86_64-2.6.30-gentoo-r5
lost+found
System.map-genkernel-x86_64-2.6.30-gentoo-r5

j'ai bien lancer ls /boot et non ls boot/

oui j'ai bien recopier le nouveau bzimage, j'ai lancer après l'avoir recompiler :

cp arch/x86_64/boot/bzImage /boot/kernel-2.6.30-gentoo-r5

pour le faire :

je me suis rendu dans /usr/src/linux et j'ai fai un make menuconfig, ensuite j'ai rajouter kk truc et ai enregistrer sous 3.config, ensuite j'ai refait make menuconfig et loader le 3.config pr etre sur ke c t bien changer, ensuite il m'a pas demander d enregistrer, et j'ai fai make && make modules_install après ca j'ai fais un mount /boot/, un ls /boot/ pour etre sur qu'il était monter j'ai fai le fameux cp arch/x86_64/boot/bzImage /boot/kernel-2.6.30-gentoo-r5 et modifier mon grub.conf
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Thu Oct 22, 2009 9:32 am    Post subject: Reply with quote

As-tu mis les pilotes PATA/SATA ? Dans ce cas, vérifie que tu as le support SCSI en dur, ainsi que SCSI disk.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 9:35 am    Post subject: Reply with quote

voici le code d'erreur précis :

VFS: cannot open root device "sdb4" or unknown-block (0,0)
please append a correct "root=" boot option, here are the available partition:

0300 1194302 hda driver : IDE-CDROM

Kernel Panic-not sync: VFS: unable to mouns fs on unknown-block(0,0)

call trace :

[<ffffff

et ca continue pendant 10lignes

j'ai essayer de mettre

title Gentoo Linux 2.6.30-r5
# Partition where the kernel image (or operating system) is located
root (hd1,0)
kernel /boot/kernel-2.6.30-gentoo-r5 root=/dev/sdb4

a la palce de

title Gentoo Linux 2.6.30-r5
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.30-gentoo-r5 root=/dev/sdb4

mais là il n'arrive pas à booter du tout, j'ai un kernel introuvable
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Thu Oct 22, 2009 9:37 am    Post subject: Reply with quote

Es-tu sûr que tu bootes le BON kernel ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 9:56 am    Post subject: Reply with quote

rep,

abselument sur et certain, j'ai revérifier, j'ai fai comme si je voulais editer le grub au boot, et comme entree il me met mon nouveau kernel.


SCSI:
-*- SCSI device support
<*> SCSI disk support

pour le sata:
<*> Serial ATA (prod) and Parallel ATA (experimental) drivers --->
<*> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support

recompiler et recopier dans boot suite à notre convers de hier :

Code:

lux boot # ls -l
total 9985
lrwxrwxrwx 1 root root       1 sept. 30 11:09 boot -> .
-rw-r--r-- 1 root root   78013 oct.  21 00:14 config-kernel
drwxr-xr-x 2 root root    1024 oct.  20 17:25 grub
-rw-r--r-- 1 root root 3011777 oct.  11 19:52 initramfs-genkernel-x86_64-2.6.30-gentoo-r5
-rw-r--r-- 1 root root 2735936 oct.  21 15:19 kernel-2.6.30-gentoo-r5
-rw-r--r-- 1 root root 2717296 oct.  11 19:36 kernel-genkernel-x86_64-2.6.30-gentoo-r5
drwx------ 2 root root   12288 sept. 30 10:32 lost+found
-rw-r--r-- 1 root root 1618874 oct.  11 19:36 System.map-genkernel-x86_64-2.6.30-gentoo-r5


mettre les pilotes pata/sata ? ben je les ai compiler en dur, il faut pas chercher un pilote à part si ?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7898
Location: ~Brussels - Belgique

PostPosted: Thu Oct 22, 2009 10:45 am    Post subject: Reply with quote

Salut,

Essaie en partant d'une config plus simple
- prends l'une des configs de base de Pappy McFae : http://www.kernel-seeds.org/
- fais un "lspci -n" et va sur http://kmuto.jp/debian/hcl/
- Vérifie les options indispensables pour booter (SCSI en dur, EXT3 en dur, PATA/SATA en dur)

Et tu auras un kernel minimal.

Après, tu pourras l'agrandir en ajoutant (en module) les options qui manquaient.

EDIT: TOUT est là : http://www.kernel-seeds.org/working.html 8)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Thu Oct 22, 2009 11:06 am    Post subject: Reply with quote

Tu as bien monté ta partition boot ?

Je demande ça parce que je vois :
Code:
oct.  21 15:19 kernel-2.6.30-gentoo-r5

et ton message de réponse date de "Mer Oct 21, 2009 7:03 pm"

Sinon ça ne peut être qu'un kernel incomplet si tu le fais toi même essaye de partir d'un .config fonctionnel est de le personnaliser par étapes.
_________________
Ez.
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 12:00 pm    Post subject: Reply with quote

rep la comu,

cela me perdurbait que xa me demande sans cesse "tu boot sur le bon kernel, t sur, vraiment sur", ne le prenant pas pour un N00b je me suis dit que ces dires était très certainement fondés, le bootais bien sur le nouveau kernel fraichement compilé, oui, mais de quel config ?

alors voici la commandes toutes betes qui m'ont sortit de là :

cp /usr/src/linux/3.config .config

après il boot nickel chrome, enfin un petit souci avec ntfs-3g mais je me pencherais sur son cas plus tard !

merci de votre énorme patience, c'est le plus souvent grace à vos questions et remarque que j'en tire une conclusion pertinente, merci la comu gentoo :)
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 22, 2009 12:14 pm    Post subject: Reply with quote

-- j'étais en train d'écrire une tartine pour rien :p --

Donc content que ça marche et qu'on ait bien ciblé le problème :-)

C'est vrai qu'on rate souvent des étapes/vérifications de base quand on connais un peu et qu'on refait et refait les même manips x fois on refait systématiquement la même erreur sans la voir (vient da'illeurs d'en faire les frais en sql pas plus tard que ce matin et c'est un devs qui m'a brulé sur place en 2 minutes :lol: )

Bref, faut laisser reposer un peu et reprendre à zéro :wink:

Edit: un petit (Résolu) à la fin du titre stp ?
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Thu Oct 22, 2009 12:51 pm    Post subject: Reply with quote

voilà, titre rectifier,

oui quand on connait ou croit connaitre c'est le pire, parce qu'on tourne en rond sur des choses évidentes.

j'ai des soucis de son etc mais je vais arranger (ou essayer) petit à petit, maintenant que ca boot jv pouvoir bosser ça.

j'avais d'abord essayé la commande

make -f 3.config && make -f 3.config modules_install mais ca n'allait pas, vous avez une commande pour spécifer un fichier de config à la compil a part remplacer le .config ?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Thu Oct 22, 2009 1:12 pm    Post subject: Reply with quote

A ma connaissance non. Le make -f c'est pour spécifier un Makefile donné mais un .config kernel n'est pas un Makefile et je ne crois pas que les devs kernel aient traité ce cas là en temps que fonction mais je ne me suis jamais frappé le Makefile dans le texte pour êtrte sûr :lol:

Cependant si tu fait un grep sur KCONFIG_CONFIG sur le Makefile à la racine tu as un résultat donc à tester plus en profondeur peut-être ? :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum