Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi USB disconnect
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Tue Oct 20, 2009 4:19 pm    Post subject: Problemi USB disconnect Reply with quote

Un mio pc ha da un po' dei problemi con le connessioni USB.
E' una motherboard Asus P4PE, a cui ho attaccati mouse e tastiera USB, che mi sembravano funzionare regolarmente.
Ultimamente, attaccando lo scanner, si resettava continuamente, sebbene su windows funzionasse regolarmente.
Ho poi attaccato un hd esterno via usb, e anche con questo vedo nel syslog continui usb disconnect.
Ho provato praticamente tutte le porte USB, ma le cose non mi sembrano cambiare, e anzi, ho notato adesso che anche il mouse viene disconnesso, ogni tanto me lo ritrovo in una posizione diversa dall'ultima.

C'è un modo per essere sicuri che sia colpa dell'hardware e non del kernel?
Sono partito con un sysrescuecd, e anche lì si presentavano continui usb disconnect.

La cosa sembra un po' discontinua, nel senso che a volte tutto funziona bene, a volte no.
Vorrei aggiungere che al boot, al momento di "decompressing kernel", certe volte il pc si resetta, e poi magari la volta successiva parte normalmente e funziona regolarmente tutto. Ma questo, forse, è un altro problema (sebbene un bel po' di tempo fa non si presentasse)
_________________
rb
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Oct 20, 2009 6:23 pm    Post subject: Reply with quote

Inizia con il verificare la configurazione del kernel, soprattutto nella sezione usb e se si blocca o resetta al messaggio del cmos time verifica la ram.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
rb34
Guru
Guru


Joined: 03 Oct 2004
Posts: 361
Location: Rome, italy

PostPosted: Wed Oct 28, 2009 1:33 pm    Post subject: Reply with quote

djinnZ wrote:
Inizia con il verificare la configurazione del kernel, soprattutto nella sezione usb e se si blocca o resetta al messaggio del cmos time verifica la ram.


Riguardo i problemi al boot, ho controllato la ram con memtest86, 4 passaggi, e non ha dato alcun errore.

Riguardo il problema usb disconnect, credo che il kernel sia a posto, ho confrontato la config con quella di un altro pc dove tutto funziona bene ed è identica.
Il fatto è che... queste mie porte usb fanno come gli pare! Ma.. vorrei cercare di capire, se si può, quale è esattamente il problema.
Qui sotto posto la sezione di syslog apparsa al momento dell'inserimento nella porta usb del cavo del mybook. Come si vede, qui si evidenzia un problema non tanto di disconnect (che per ora, dopo una mezz'ora, pare non esserci su questa porta), ma mi dice che il device è hi speed ma non riesce ad andarci. Non capisco davvero cosa intenda per "connect to a high speed hub", perché se il dispositivo e la porta sono usb 2.0, cosa dovrebbe andare meglio, frapponendo un alt4ro dispositivo? Il dispositivo usb in questione è peraltro autoalimentato

Code:
Oct 28 14:02:37 tux kernel: usb 4-2: new full speed USB device using uhci_hcd and address 3
Oct 28 14:02:37 tux kernel: usb 4-2: not running at top speed; connect to a high speed hub
Oct 28 14:02:37 tux kernel: usb 4-2: configuration #1 chosen from 1 choice
Oct 28 14:02:37 tux kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Oct 28 14:02:37 tux kernel: usb-storage: device found at 3
Oct 28 14:02:37 tux kernel: usb-storage: waiting for device to settle before scanning
Oct 28 14:02:42 tux kernel: scsi 2:0:0:0: Direct-Access     WD       My Book 1110     1028 PQ: 0 ANSI: 4
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: Attached scsi generic sg0 type 0
Oct 28 14:02:42 tux kernel: usb-storage: device scan complete
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: [sda] 1952151552 512-byte hardware sectors: (999 GB/930 GiB)
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: [sda] Write Protect is off
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: [sda] Mode Sense: 23 00 10 00
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: [sda] Assuming drive cache: write through
Oct 28 14:02:42 tux kernel: sd 2:0:0:0: [sda] Assuming drive cache: write through
Oct 28 14:02:49 tux kernel:  sda: sda1 sda2 sda3 < sda5 sda6 >
Oct 28 14:02:49 tux kernel: sd 2:0:0:0: [sda] Attached SCSI disk

_________________
rb
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum