Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnucash startup fails assertion failed: (pixbuf1 && pixbuf2)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
nuuskierig
n00b
n00b


Joined: 04 Sep 2008
Posts: 46
Location: Lake of Constance, Germany

PostPosted: Sun Oct 18, 2009 12:06 pm    Post subject: gnucash startup fails assertion failed: (pixbuf1 && Reply with quote

Hi folks,

i have got a new problem with gnucash. It worked since March without any problems. Since around a week (after a emerge --sync and emerge -avuD world) i can't lunch gnucash anymore.

The messages are following:

gnucash --debug
Code:

gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

**
gnc.gui:ERROR:gnc-icons.c:68:gnc_add_stock_icon_pair: assertion failed: (pixbuf1 && pixbuf2)



strace gnucash
Code:

.
.
.
read(16, "; gnucash GtkAccelMap rc-file    "..., 4000) = 4000
read(16, "iness-actions/BillsDueReminderOpe"..., 4000) = 4000
read(16, "inessTestAction\" \"\")\n; (gtk_accel"..., 4000) = 4000
read(16, "ccel_path \"<Actions>/MenuAddition"..., 4000) = 516
read(16, ""..., 4000)                   = 0
close(16)                               = 0
access("/usr/share/gnucash/pixmaps/gnc-account.png", F_OK) = 0
access("/usr/share/gnucash/pixmaps/gnc-account-16.png", F_OK) = 0
access("/usr/share/gnucash/pixmaps/gnc-account.png", F_OK) = 0
open("/usr/share/gnucash/pixmaps/gnc-account.png", O_RDONLY) = 16
fstat(16, {st_mode=S_IFREG|0644, st_size=1019, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fef9d83b000
read(16, "\211PNG\r\n\32\n\0\0\0\rIHDR\0\0\0\30\0\0\0\30\10\6\0\0\0\340w=\370"..., 4096) = 1019
read(16, ""..., 4096)                   = 0
close(16)                               = 0
munmap(0x7fef9d83b000, 4096)            = 0
write(3, "* 13:03:48  CRIT <gnc.gui> [gnc_g"..., 178) = 178
access("/usr/share/gnucash/pixmaps/gnc-account-16.png", F_OK) = 0
open("/usr/share/gnucash/pixmaps/gnc-account-16.png", O_RDONLY) = 16
fstat(16, {st_mode=S_IFREG|0644, st_size=334, ...}) = 0
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fef9d83b000
read(16, "\211PNG\r\n\32\n\0\0\0\rIHDR\0\0\0\20\0\0\0\20\10\6\0\0\0\37\363\377a"..., 4096) = 334
read(16, ""..., 4096)                   = 0
close(16)                               = 0
munmap(0x7fef9d83b000, 4096)            = 0
write(3, "* 13:03:48  CRIT <gnc.gui> [gnc_g"..., 181) = 181
write(2, "**\ngnc.gui:ERROR:gnc-icons.c:68:g"..., 96**
gnc.gui:ERROR:gnc-icons.c:68:gnc_add_stock_icon_pair: assertion failed: (pixbuf1 && pixbuf2)
) = 96
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
tgkill(4083, 4083, SIGABRT)             = 0
--- SIGABRT (Aborted) @ 0 (0) ---
+++ killed by SIGABRT +++


I recompiled gnucash packages with the same result.

"revdep-rebuild -i" finishes with "Dynamic linking on your system is consistent... All done."


emerge --info
Code:

Portage 2.1.7.1 (default/linux/amd64/2008.0, gcc-4.3.4, glibc-2.10.1-r0, 2.6.31-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8300_@_2.83GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 18 Oct 2009 09:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 1.3.7-r1, 2.1.9-r1
dev-lang/python:     2.6.3, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.1-r1
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib64/fax /usr/share/X11/xkb /usr/share/config /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo"
LANG="de_DE@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j4"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="64bit X a52 acc acl acpi alsa amd64 bash-completion berkdb bzip2 cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread encode fortran gcj gdbm gif gpm gpsi iconv icq ipv6 isdnlog java jpeg kde4 latex mmx modules mozdevelop mozilla mp3 msn mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pcre perl plotutils png pppd python qt3support readline reflection samba science session spell spl sse sse2 ssl svg sysfs tcpd unicode usb v4l vcdi videos vim-syntax vorbis wifi wmf xorg xvid yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum