Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Compilation] erreur a chaque compilation/Regle
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 2:17 pm    Post subject: [Compilation] erreur a chaque compilation/Regle Reply with quote

Hello,

j'ai fai un emerge -C kde car il me... enfin, j'ai donc fai un petit emerge --depclean apres pour nettoyer tout ca :

Code:
lux policy # emerge --depclean

 * Depclean may break link level dependencies.  Thus, it is
 * recommended to use a tool such as `revdep-rebuild` (from
 * app-portage/gentoolkit) in order to detect such breakage.
 *
 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep world` prior to depclean.

Calculating dependencies... done!

 net-misc/mDNSResponder
    selected: 107.6-r5
   protected: none
     omitted: none

 kde-base/kdeutils
    selected: 3.5.9-r1
   protected: none
     omitted: none

 kde-base/kdegraphics
    selected: 3.5.9
   protected: none
     omitted: none

 dev-python/pycrypto
    selected: 2.0.1-r6
   protected: none
     omitted: none

 dev-libs/dbus-qt3-old
    selected: 0.70
   protected: none
     omitted: none

 kde-base/kdenetwork
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdeadmin
    selected: 3.5.9
   protected: none
     omitted: none

 www-misc/htdig
    selected: 3.2.0_beta6-r3
   protected: none
     omitted: none

 sys-devel/gdb
    selected: 6.8-r1
   protected: none
     omitted: none

 kde-base/kdewebdev
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdebase-pam
    selected: 7
   protected: none
     omitted: none

 kde-base/kdeedu
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdeaddons
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdeartwork
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdetoys
    selected: 3.5.9
   protected: none
     omitted: none

 sys-devel/gcc
    selected: 4.1.2
   protected: none
     omitted: 4.3.2-r3

 kde-base/kdemultimedia
    selected: 3.5.9
   protected: none
     omitted: none

 kde-base/kdegames
    selected: 3.5.9
   protected: none
     omitted: none

 app-crypt/qca-tls
    selected: 1.0-r4
   protected: none
     omitted: none

 net-dialup/ppp
    selected: 2.4.4-r23
   protected: none
     omitted: none

 net-dns/libidn
    selected: 1.15
   protected: none
     omitted: none

 net-misc/netkit-talk
    selected: 0.17-r4
   protected: none
     omitted: none

 sys-process/vixie-cron
    selected: 4.1-r10
   protected: none
     omitted: none

 kde-base/kdepim
    selected: 3.5.9-r1
   protected: none
     omitted: none

 media-libs/libart_lgpl
    selected: 2.3.20
   protected: none
     omitted: none

 media-libs/akode
    selected: 2.0.2
   protected: none
     omitted: none

 media-libs/taglib
    selected: 1.5
   protected: none
     omitted: none

 media-sound/cdparanoia
    selected: 3.10.2-r3
   protected: none
     omitted: none

 dev-libs/cyrus-sasl
    selected: 2.1.23
   protected: none
     omitted: none

 sys-process/cronbase
    selected: 0.3.2-r1
   protected: none
     omitted: none

 app-pda/libopensync
    selected: 0.22
   protected: none
     omitted: none

 app-crypt/qca
    selected: 1.0-r3
   protected: none
     omitted: none

 media-libs/libsamplerate
    selected: 0.1.4
   protected: none
     omitted: none

 dev-lang/python
    selected: 2.4.4-r13
   protected: none
     omitted: 2.6.2-r1

 dev-lang/python
    selected: 2.5.4-r3
   protected: none
     omitted: 2.6.2-r1

 app-misc/mime-types
    selected: 7
   protected: none
     omitted: none

 sys-devel/automake
    selected: 1.7.9-r1
   protected: none
     omitted: 1.9.6-r2 1.10.2

 sys-libs/db
    selected: 4.5.20_p2-r1
   protected: none
     omitted: 4.7.25_p4

 sys-libs/db
    selected: 4.3.29-r2
   protected: none
     omitted: 4.7.25_p4

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging net-misc/mDNSResponder-107.6-r5...
>>> Unmerging kde-base/kdeutils-3.5.9-r1...
>>> Unmerging kde-base/kdegraphics-3.5.9...
>>> Unmerging dev-python/pycrypto-2.0.1-r6...
 * Performing Python Module Cleanup .. ...
 * Cleaning orphaned Python bytecode from /usr/lib/python2.4/site-packages ..
 * Purging /usr/lib/python2.4/site-packages/Crypto/Hash/SHA.py[co]
 * Purging /usr/lib/python2.4/site-packages/Crypto/Hash/__init__.py[co]
 * Purging /usr/lib/python2.4/site-packages/Crypto/Hash/MD5.py[co]
 * Purging /usr/lib/python2.4/site-packages/Crypto/__init__.py[co]
 * Cleaning orphaned Python bytecode from /usr/lib/python2.5/site-packages ..
 * Cleaning orphaned Python bytecode from /usr/lib/python2.6/site-packages ..
 * Cleaning orphaned Python bytecode from /usr/lib64/python2.4/site-packages ..
 * Cleaning orphaned Python bytecode from /usr/lib64/python2.5/site-packages ..
 * Cleaning orphaned Python bytecode from /usr/lib64/python2.6/site-packages ..                                                                                                                                                       [ ok ]
>>> Unmerging dev-libs/dbus-qt3-old-0.70...
>>> Unmerging kde-base/kdenetwork-3.5.9...
>>> Unmerging kde-base/kdeadmin-3.5.9...
>>> Unmerging www-misc/htdig-3.2.0_beta6-r3...
>>> Unmerging sys-devel/gdb-6.8-r1...
>>> Unmerging kde-base/kdewebdev-3.5.9...
>>> Unmerging kde-base/kdebase-pam-7...
>>> Unmerging kde-base/kdeedu-3.5.9...
>>> Unmerging kde-base/kdeaddons-3.5.9...
>>> Unmerging kde-base/kdeartwork-3.5.9...
>>> Unmerging kde-base/kdetoys-3.5.9...
>>> Unmerging sys-devel/gcc-4.1.2...
 * Running 'fix_libtool_files.sh 4.1.2'
 * Scanning libtool files for hardcoded gcc library paths...
gcc-config: error: could not run/locate 'gcc'
:0: assertion failed: (gcc -dumpversion) | getline NEWVER)
>>> Unmerging kde-base/kdemultimedia-3.5.9...
>>> Unmerging kde-base/kdegames-3.5.9...
>>> Unmerging app-crypt/qca-tls-1.0-r4...
>>> Unmerging net-dialup/ppp-2.4.4-r23...
>>> Unmerging net-dns/libidn-1.15...
>>> Unmerging net-misc/netkit-talk-0.17-r4...
>>> Unmerging sys-process/vixie-cron-4.1-r10...
>>> Unmerging kde-base/kdepim-3.5.9-r1...
>>> Unmerging media-libs/libart_lgpl-2.3.20...
 * Updating desktop mime database ...
 * Updating shared mime info database ...
>>> Unmerging media-libs/akode-2.0.2...
>>> Unmerging media-libs/taglib-1.5...
>>> Unmerging media-sound/cdparanoia-3.10.2-r3...
>>> Unmerging dev-libs/cyrus-sasl-2.1.23...
>>> Unmerging sys-process/cronbase-0.3.2-r1...
>>> Unmerging app-pda/libopensync-0.22...
>>> Unmerging app-crypt/qca-1.0-r3...
>>> Unmerging media-libs/libsamplerate-0.1.4...
>>> Unmerging dev-lang/python-2.4.4-r13...
 * Linking /usr/bin/python2.6 to /usr/bin/python (relative)
 * Linking /usr/bin/python2.6 to /usr/bin/python2 (relative)
 * Linking /usr/bin/idle2.6 to /usr/bin/idle (relative)
 * Linking /usr/bin/pydoc2.6 to /usr/bin/pydoc (relative)
 * Linking /usr/bin/python-config-2.6 to /usr/bin/python-config (relative)
 * Linking /usr/share/man/man1/python2.6.1.bz2 to /usr/share/man/man1/python.1.bz2 (relative)
 * Cleaning orphaned Python bytecode from /usr/lib/python2.4 ..
find: `/usr/lib/python2.4': No such file or directory
find: `/usr/lib/python2.4': No such file or directory
 * Cleaning orphaned Python bytecode from /usr/lib64/python2.4 ..
find: `/usr/lib64/python2.4': No such file or directory
find: `/usr/lib64/python2.4': No such file or directory
>>> Unmerging dev-lang/python-2.5.4-r3...
Switching to python2.6
 * Cleaning orphaned Python bytecode from /usr/lib/python2.5 ..
 * Cleaning orphaned Python bytecode from /usr/lib64/python2.5 ..
>>> Unmerging app-misc/mime-types-7...
>>> Unmerging sys-devel/automake-1.7.9-r1...
>>> Unmerging sys-libs/db-4.5.20_p2-r1...
 * Creating db.h symlinks to db4.7
>>> Unmerging sys-libs/db-4.3.29-r2...
 * Creating db.h symlinks to db4.7
Packages installed:   578
Packages in world:    41
Packages in system:   50
Required packages:    539
Number removed:       39


apres j'ai fait un revdep-rebuild qui essaye de recompiler lcms et qui aboutu a une erreur :

* ERROR: media-libs/lcms-1.18-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_prepare
* environment, line 2615: Called die
* The specific snippet of code:
* ./swig_lcms || die "swig_lcms failed";
* The die message:
* swig_lcms failed


et un peut plus au dessus :

Applying lcms-CVE-2009-0793.patch ... [ ok ]
swig: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.2/libstdc++.so.6)


la je me dit que ca sent un peut le roussi ^^, donc tout noob que je suis > emerge gcc qui ne fonctionne bien sur pas.

checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.


Faut il que je boot sur un livecd pour remerger gcc ?
_________________
un noob parmis tant d'autre noob


Last edited by skizorager on Fri Oct 16, 2009 3:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
xelif
Apprentice
Apprentice


Joined: 16 Jan 2006
Posts: 152

PostPosted: Fri Oct 16, 2009 2:22 pm    Post subject: Reply with quote

il semblerai que ton gcc verison 4.1.2 ai été désinstallé, ne serait ce pas celui qui était en cours d'utilisation?

peux tu taper :

Code:

gcc-config set 1 && source /etc/profile && env-update


et ensuite essayer d'installer à nouveau un paquet
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 2:28 pm    Post subject: Reply with quote

hello,

merci pour ta reponse rapide

lux policy # gcc-config set 1 && source /etc/profile && env-update
* gcc-config: Could not locate 'set' in '/etc/env.d/gcc/' !

je crois que ce coup la, j ai bien foutu le brun :(
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Fri Oct 16, 2009 2:48 pm    Post subject: Reply with quote

'alute

sent pas bon de prime abord en effet mais y'a toujours des moyen de s'en sortir : avant de partir dans un rescue-mode fait voir la sortie de #eselect python list stp ?
Avant de penser à gcc faut être sûr que python est up car tu as viré 2 slots là, mais ton système était configuré sur quelle version juste avant ? et c'est pareil pour gcc

Edit: Et un #emerge --info aussi tant qu'à y être :wink:
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 2:51 pm    Post subject: Reply with quote

hello,

voici :

Code:
lux ~ # eselect python list
Available python interpreters:
  [1]   python2.6 *
lux ~ #


our info, j ai trouve une commande qui a l air de rouler : gcc-config 1 et non gcc-config set 1 la je recompile gcc pour le moment je n'ai aps d'erreur, ensuite je remetterais mes soruce et un env-update je vous tiens au jus.

Code:
ux ~ # emerge --info
Portage 2.1.6.13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-1.12.11.1
Timestamp of tree: Fri, 16 Oct 2009 13:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     4.0_p28
dev-lang/python:     2.6.2-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="fr_BE.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa amd64 berkdb bidi bzip2 cdda cdio cli cracklib crypt cups dbus dri dts dvd encode ffmpeg flac fortran freetype gdbm gnutls gpm gtk hal httpd iconv ipv6 isdnlog live mad matroska mmx modules mpeg mudflap multilib mysql ncurses nls nptl nptlonly nvidia ogg oggvorbis opengl openmp pam pcre perl png pppd python qt3 qt3support qt4 readline reflection samba session spl sse sse2 ssl stream sysfs tcpd theora unicode vcd vlm wxwindows xcb xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
xelif
Apprentice
Apprentice


Joined: 16 Jan 2006
Posts: 152

PostPosted: Fri Oct 16, 2009 2:52 pm    Post subject: Reply with quote

oki oki désolé j'ai fait un mix entre gcc-config et l'ancien eselect gcc set 1 ... mea culpa est

bonne chance pour ta compilation ;)
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 3:08 pm    Post subject: Reply with quote

xelif wrote:
oki oki désolé j'ai fait un mix entre gcc-config et l'ancien eselect gcc set 1 ... mea culpa est

bonne chance pour ta compilation ;)


y a vraiment pas de malaise, sans toi j aurais pas chercher plus d infos sur gcc-config et j aurais pas trouver ca :)

il compile toujours, je croise tout ske j'ai ^^
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 3:17 pm    Post subject: Reply with quote

et voila, probleme regle via un petit gcc-config 1

j'ai re-merger lcms pour tester et il a tourne nickel :) merci de votre aide si precieuse, je me voyais deja récupérer mon stage5 ^^

mais est-ce normal que gcc se vire avec un emerge --depclean ?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri Oct 16, 2009 4:30 pm    Post subject: Reply with quote

Ben apparement aucun paquet en avait besoin, donc pas protégé, donc conisdéré comme orphelin, donc viré (ouh sa fait bcp de "donc" :P )
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Fri Oct 16, 2009 7:51 pm    Post subject: Reply with quote

donc, si je comprend bien, il faudrait forcer le systeme à le masquer sinon j'aurais le meme souci au prochain --depclean ?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Sun Oct 25, 2009 5:33 pm    Post subject: Reply with quote

Non, lorsque tu mets à jour gcc, il garde l'ancienne version donc tu te retrouves ac 2 versions de gcc dont une qui te sers alors plus à rien. C'est pour ça qu'il te la vire lorsque tu fais emerge --depclean, parce qu'y en a une autre plus récente pour remplacer.
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Mon Oct 26, 2009 6:12 pm    Post subject: Reply with quote

Picani wrote:
Non, lorsque tu mets à jour gcc, il garde l'ancienne version donc tu te retrouves ac 2 versions de gcc dont une qui te sers alors plus à rien. C'est pour ça qu'il te la vire lorsque tu fais emerge --depclean, parce qu'y en a une autre plus récente pour remplacer.


Merci de ces précisions, d'où le set profile resoud le problème. C'est vachement plus clair. Merci beaucoup
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum