Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] pb Blocked Packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
titoomonster
n00b
n00b


Joined: 22 Mar 2009
Posts: 17

PostPosted: Mon Oct 12, 2009 7:23 am    Post subject: [emerge] pb Blocked Packages Reply with quote

Bonjour,

Voici mon pb, j'ai un pb lorsque je fais un emerge -DNupv world. Je me trouve devant un conflit de paquet que je ne sais pas résoudre, vraisemblablement lié au paquet kdelibs.

Voici le résultat

[blocks B ] >x11-libs/qt-test-4.5.1-r9999 (">x11-libs/qt-test-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-script-4.5.1-r9999 (">x11-libs/qt-script-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-sql-4.5.1-r9999 (">x11-libs/qt-sql-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-qt3support-4.5.1-r9999 (">x11-libs/qt-qt3support-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-core-4.5.1-r9999 (">x11-libs/qt-core-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] <x11-libs/qt-gui-4.5.3 ("<x11-libs/qt-gui-4.5.3" is blocking x11-libs/qt-opengl-4.5.3, x11-libs/qt-core-4.5.3-r1, x11-libs/qt-script-4.5.3, x11-libs/qt-dbus-4.5.3, x11-libs/qt-svg-4.5.3, x11-libs/qt-test-4.5.3, x11-libs/qt-qt3support-4.5.3, x11-libs/qt-webkit-4.5.3, x11-libs/qt-sql-4.5.3)
[blocks B ] >x11-libs/qt-svg-4.5.1-r9999 (">x11-libs/qt-svg-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-dbus-4.5.1-r9999 (">x11-libs/qt-dbus-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-webkit-4.5.1-r9999 (">x11-libs/qt-webkit-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)
[blocks B ] >x11-libs/qt-opengl-4.5.1-r9999 (">x11-libs/qt-opengl-4.5.1-r9999" is blocking x11-libs/qt-gui-4.5.1-r2)

Total: 340 packages (205 upgrades, 128 new, 5 in new slots, 2 reinstalls, 2 uninstalls), Size of downloads: 574,291 kB
Conflict: 13 blocks (10 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage/layman/java-overlay

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-libs/qt-dbus-4.5.3', 'merge') pulled in by
>=x11-libs/qt-dbus-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')
x11-libs/qt-dbus:4 required by ('ebuild', '/', 'dev-libs/soprano-2.3.1', 'merge')
>=x11-libs/qt-dbus-4.4.0:4 required by ('ebuild', '/', 'media-sound/phonon-4.4_pre20090520', 'merge')
(and 2 more)

('ebuild', '/', 'x11-libs/qt-gui-4.5.1-r2', 'merge') pulled in by
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/kscreensaver-4.3.2', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/soliduiserver-4.3.2', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/kdm-4.3.2', 'merge')
(and 91 more)

('ebuild', '/', 'x11-libs/qt-script-4.5.3', 'merge') pulled in by
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/libtaskmanager-4.3.2', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kcmshell-4.3.2', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kfile-4.3.2', 'merge')
(and 82 more)

('ebuild', '/', 'x11-libs/qt-test-4.5.3', 'merge') pulled in by
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/konsole-4.3.2', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/libplasmaclock-4.3.2', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/plasma-runtime-4.3.2', 'merge')
(and 82 more)

('ebuild', '/', 'x11-libs/qt-qt3support-4.5.3', 'merge') pulled in by
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kdebase-startkde-4.3.2', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/phonon-kde-4.3.2', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kstart-4.3.2', 'merge')
(and 81 more)

('ebuild', '/', 'x11-libs/qt-opengl-4.5.3', 'merge') pulled in by
>=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r1', 'nomerge')
>=x11-libs/qt-opengl-4.5.1:4 required by ('installed', '/', 'kde-base/kwin-4.3.2', 'nomerge')
>=x11-libs/qt-opengl-4.4.0:4 required by ('ebuild', '/', 'media-sound/phonon-4.4_pre20090520', 'merge')
(and 1 more)

('ebuild', '/', 'x11-libs/qt-core-4.5.3-r1', 'merge') pulled in by
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kdepimlibs-4.3.2', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kcmshell-4.3.2', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kfile-4.3.2', 'merge')
(and 94 more)

('ebuild', '/', 'x11-libs/qt-webkit-4.5.3', 'merge') pulled in by
>=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.2-r1', 'nomerge')
>=x11-libs/qt-webkit-4.5.1:4 required by ('ebuild', '/', 'dev-python/PyQt4-4.5.4-r4', 'merge')

('ebuild', '/', 'x11-libs/qt-svg-4.5.3', 'merge') pulled in by
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kfile-4.3.2', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/khelpcenter-4.3.2', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdebase-menu-4.3.2', 'merge')
(and 81 more)

('ebuild', '/', 'x11-libs/qt-sql-4.5.3', 'merge') pulled in by
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kdialog-4.3.2', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/dolphin-4.3.2-r1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/libplasmaclock-4.3.2', 'merge')
(and 83 more)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Quelqu'un a été sans doute confronté au pb, si une solution traine par là je suis preneur :o)

Merci par avance
_________________
"each time you reboot a linux, a pingouin dies in the world"
Back to top
View user's profile Send private message
boozo
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3193

PostPosted: Mon Oct 12, 2009 9:45 am    Post subject: Reply with quote

'alute

tu as des infos dans une news (voir eselect news list) - c'est plus que sommaire je suis d'accords - mais c'est la piste
Donc tu dois avoir dans tes useflags "qt3support" et "dbus" je pense (à vérifier dans le package.uses et le make.conf) -

Je te conseille de faire un unmerge des packages <=x11-libs/qt-* qui sont installés puis d'activer le use qt3support et dbus en fonction de tes besoins : soit spécifiquement par packages ou en global.

Personnellement je tourne avec les uses qt3support en global et dbus pour x11-libs/qt-gui uniquement et j'ai eu aucun pb ;-)

Edit: ps/ un titre genre [qt] conflit lors de la migration 4.5.2 serait plus utile à tous ;-)
_________________
" Un psychotique, c'est quelqu'un qui croit dur comme fer que 2 et 2 font 5, et qui en est pleinement satisfait.
Un névrosé, c'est quelqu'un qui sait pertinemment que 2 et 2 font 4, et ça le rend malade ! "
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 384
Location: France

PostPosted: Mon Oct 12, 2009 1:10 pm    Post subject: Reply with quote

Moi je pense que ton problème correspond à ca : https://forums.gentoo.org/viewtopic-t-736457.html

Pour corriger ce problème, il faut supprimer le meta-paquet qt. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum