Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Reseau] Reseau lent à l'interrogation d'une url.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sun Oct 11, 2009 2:52 pm    Post subject: [Reseau] Reseau lent à l'interrogation d'une url. Reply with quote

Hello à tous,

j'ai un petit souci de requete incroyablement lente (+/- 30secondes), je suis configuré en DHCP sur un routeur B-Box en Ethernet sur un Switch relié à ma B-Box, avec une carte gigabit

mise en situation :

- meme probleme sur Konkeror ou Firefox 3.0
- Quand je ping ca va nickel
- J'ai l'impression que les images sont encore plus lentes à etre trouvée.
- J'ai fait des banswish test qui sont tres convenable (je pompe à du 900k/s)
- Sous Windobe, la navigation est fluide
- une fois le site trouvé, le chargement se fait rapidement; meme tres rapidement, c'est vraiment à l'interrogation du site.
- pour autant que je reste sur le meme domaine, il n'y a plus de ralentissement, c'est par exemple lorsque je passe de gentoo.org à forums.gentoo.org que ca met encore des plombes.
- pareil quand je lance le download d'un fichier, il me faut très longtemps avant d'avoir la demande d'enregistrement, mais une fois que c'est fait, ça trace.


je sais pas exactement que vous donner comme info, alors j'y vais au pif :

Résolv.conf:
Code:
nameserver 10.100.88.201

(mon routeur BBox, ma gateway, vous inquietez pas de l'ip, c'est normal, et cela fonctionne bien sous windows.

host:
Code:
# IPv4 and IPv6 localhost aliases
10.100.88.203  Wilfried
127.0.0.1       localhost
::1             localhost

Wilfried est ma seconde gentoo sans interface graphique.

net:
Code:
config_eth0=( "dhcp" )


je sais pas vers où me diriger, vous avez une idée ?
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sun Oct 11, 2009 3:14 pm    Post subject: Reply with quote

Support IPV6 à tous les coups.
Ta machine tente de résoudre et accéder en IPV6, qui ne fonctionne pas, du coup, il faut attendre le timeout avant de passer en IPv4...


Vire le support IPv6 de ton kernel, ou bien décommente la ligne "# alias net-pf-10 off # IPv6" dans /etc/modprobe.d/aliases.conf



Autre solution : agir sur le resolver de la glibc et lui dire de préférer ipv4 à ipv6 pour les résolutions DNS :
dans /etc/gai.conf
décommenter les lignes 22 à 29 et 46 à 49 et 54 de la conf par défaut :
Code:
label ::1/128       0
label ::/0          1
label 2002::/16     2
label ::/96         3
label ::ffff:0:0/96 4
label fec0::/10     5
label fc00::/7      6
label 2001:0::/32   7

precedence  ::1/128       50
precedence  ::/0          40
precedence  2002::/16     30
precedence ::/96          20
precedence ::ffff:0:0/96  100

_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
skizorager
n00b
n00b


Joined: 09 Nov 2006
Posts: 69
Location: Liege

PostPosted: Sun Oct 11, 2009 4:10 pm    Post subject: Reply with quote

YEaaahhhh


dans le mille guilc :), une petite recompil du kernel et c'est repartit :), merci pour tes réponses et tes compléments d'infos

je manquerais pas d'éplucher un petit peut de fichier gai.conf :)

par contre mon /etc/modprobe.d/aliases.conf était bien vide,

encore merci de ta réponse
_________________
un noob parmis tant d'autre noob
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum