Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2.26, spegnimento display
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Sun Oct 11, 2009 4:24 am    Post subject: Gnome 2.26, spegnimento display Reply with quote

Salve a tutti, dopo il recente aggiornamento a gnome 2.26 non mi funziona più lo spegnimento del display del laptop. Dopo 5 minuti parte regolarmente lo screensaver, blank screen, ma lo schermo resta luminoso in eterno, mentre nelle impostazioni di risparmio energetico dice: put display to sleep after 13 minutes. Questo bug https://bugs.gentoo.org/show_bug.cgi?id=272826 sembra essere la stessa cosa, ma non ho capito cosa devo fare in pratica. Grazie in anticipo per l'aiuto!
Ricky
Back to top
View user's profile Send private message
devilheart
l33t
l33t


Joined: 17 Mar 2005
Posts: 837
Location: Villach, Austria

PostPosted: Sun Oct 11, 2009 7:27 am    Post subject: Reply with quote

sembrerebbe un problema risolto con xorg-server-1.6.3.901-r2
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Sun Oct 11, 2009 12:12 pm    Post subject: Reply with quote

Ho l'ultima versione di xorg-server ma il problema c'è lo stesso. Non è esattamente la stessa cosa, infatti se do xset dpms force off (comando trovato nel primo messaggio del bug) lo schermo si spegne.
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Oct 11, 2009 1:53 pm    Post subject: Reply with quote

Cosa ottieni con
Code:
gconftool-2 --get /apps/gnome-power-manager/backlight/dpms_method_ac
e
Code:
gconftool-2 --get /apps/gnome-power-manager/backlight/dpms_method_battery
?
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Sun Oct 11, 2009 2:02 pm    Post subject: Reply with quote

riverdragon wrote:
Cosa ottieni con
Code:
gconftool-2 --get /apps/gnome-power-manager/backlight/dpms_method_ac
e
Code:
gconftool-2 --get /apps/gnome-power-manager/backlight/dpms_method_battery
?

Default in entrambi i casi.
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Oct 11, 2009 8:13 pm    Post subject: Reply with quote

Mi sembra che in gnome-2.26 default=blank, fai così:
Code:
gconftool-2 --set /apps/gnome-power-manager/backlight/dpms_method_ac off
gconftool-2 --set /apps/gnome-power-manager/backlight/dpms_method_battery off
È come andare in gconf-editor, apps->gnome-power-manager->backlight e impostare le voci a off.
Back to top
View user's profile Send private message
Elbryan
Guru
Guru


Joined: 13 Nov 2006
Posts: 523
Location: Rovereto (TN)

PostPosted: Sun Oct 11, 2009 9:02 pm    Post subject: Reply with quote

Capita anche a me (sia mettendo off che default).
A dire il vero prima mi si è spento lo schermo (rimettendo l'impostazione 'default' dopo aver usato 'off' per un paio di giorni senza buoni risultati).

Imho è un bug più profondo :P
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Sun Oct 11, 2009 9:20 pm    Post subject: Reply with quote

Ho notato anche un problema con lo screensaver: se guardo un film con mplayer lo screensaver non parte, il che va bene, però dopo aver chiuso mplayer lo screensaver continua a non partire! I due problemi potrebbero essere collegati?
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Oct 11, 2009 10:36 pm    Post subject: Reply with quote

Probabile. Io che ho aggiornato a gnome-2.26 appena uscito (a marzo) ho avuto questi problemi per sei mesi, lo sviluppatore sul suo blog spiegava che il bug era dovuto ad una serie di cambi in corso d'opera tra xorg, hal e altra roba. Con gnome-2.28 (e xorg-server-1.6.4) il problema si è risolto, valutate se portare pazienza o rischiare il passaggio anticipato.
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Mon Oct 12, 2009 9:44 pm    Post subject: Reply with quote

Spero che non sia necessario passare addirittura a gnome 2.28, vediamo se qualche aggiornamento sistema la cosa! Comunque ci sono diversi comportamenti strani, per esempio ctrl+alt+backspace non fa riavviare il server X! Boh!!
Ricky
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Oct 12, 2009 10:22 pm    Post subject: Reply with quote

Dubito che ci siano aggiornamenti su gnome-power-manager-2.26, a meno che non trovi il bugreport e segnali che ancora non va.
La questione del ctrl+alt+backspace è un comportamento voluto per xorg-1.6, bisogna riabilitarlo a mano, me ne dimentico sempre anche io.
Back to top
View user's profile Send private message
publiosulpicio
Apprentice
Apprentice


Joined: 31 Aug 2008
Posts: 150

PostPosted: Mon Oct 12, 2009 11:01 pm    Post subject: Reply with quote

Vedo solo ora che gnome-power-manager-2.26 è masked, la versione che ho installato è la 2.22.1. Provo ad smascherare e vediamo se cambia. Per lo screensaver che non parte dopo aver usato mplayer qualcuno ha idee?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum