Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU][Disque externe] hitachi neso, détection qui boucle.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
prunkdump
n00b
n00b


Joined: 28 Apr 2009
Posts: 25
Location: France, Bordeaux

PostPosted: Tue Oct 13, 2009 7:57 am    Post subject: [RESOLU][Disque externe] hitachi neso, détection qui boucle. Reply with quote

Bonjours.

Voila mon problème est très simple. J'ai un disque dur externe Hitachi "NESO" que je n'arrive pas à connecter à mon ordinateur.

J'ai mit à jour mon noyau en "gentoo-sources-2.6.30-r6" mais le problème persiste.

le problème:
En fait la reconnaisance de mon disque boucle à l'infinie. Voici ce que me donne le noyau :

Il trouve bien le périphérique :
Code:

[  360.447036] usb 1-1: new high speed USB device using ehci_hcd and address 8
[  360.529245] ehci_hcd 0000:00:02.2: port 1 high speed
[  360.529254] ehci_hcd 0000:00:02.2: GetStatus port 1 status 001005 POWER sig=se0 PE CONNECT

Il trouve bien les caractéristiques :
Code:

[  360.595270] usb 1-1: default language 0x0409
[  360.612282] usb 1-1: New USB device found, idVendor=1bcf, idProduct=0c31
[  360.612288] usb 1-1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  360.612292] usb 1-1: Product: 320GB
[  360.612295] usb 1-1: Manufacturer: NESO
[  360.612298] usb 1-1: SerialNumber: 00021dc3

Il demarre bien l'émulation scsi :
Code:

[  360.612402] usb 1-1: uevent
[  360.612428] usb 1-1: usb_probe_device
[  360.612433] usb 1-1: configuration #1 chosen from 1 choice
[  360.613508] usb 1-1: adding 1-1:1.0 (config #1, interface 0)
[  360.614158] usb 1-1:1.0: uevent
[  360.614193] usb-storage 1-1:1.0: usb_probe_interface
[  360.614202] usb-storage 1-1:1.0: usb_probe_interface - got id
[  360.628091] scsi238 : SCSI emulation for USB Mass Storage devices
[  360.643732] drivers/usb/core/inode.c: creating file '008'
[  360.643795] usb-storage: device found at 8

Mais lorqu'il faut creer le ficher dev, il y à un erreur :
Code:

[  360.643798] usb-storage: waiting for device to settle before scanning
[  360.677308] hub 1-0:1.0: state 7 ports 6 chg 0000 evt 0002
[  360.677324] ehci_hcd 0000:00:02.2: GetStatus port 1 status 001c09 POWER sig=? PEC CONNECT
[  360.677331] hub 1-0:1.0: port 1 enable change, status 00000501
[  360.677338] hub 1-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
[  360.677343] hub 1-0:1.0: port 1, status 0501, change 0002, 480 Mb/s

Et le noyau ferme l'USB :
Code:

[  360.677348] usb 1-1: USB disconnect, address 8
[  360.677351] usb 1-1: unregistering device
[  360.677355] usb 1-1: usb_disable_device nuking all URBs
[  360.677362] usb 1-1: unregistering interface 1-1:1.0
[  360.677707] usb 1-1:1.0: uevent
[  360.677859] usb 1-1: uevent
[  360.781036] hub 1-0:1.0: debounce: port 1: total 100ms stable 100ms status 0x501


Et ceci tourne en boucle. On l'entend sur le disque dur qui fait un bruit répétitif. Je n'ai pas trouvé de drivers spécifique à ce disque dans le noyau. Ma configuration de l'USB est exactement celle décrite dans le guide gentoo usb.

Quelqu'un aurait-il une idée?


Last edited by prunkdump on Tue Oct 13, 2009 9:05 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8109
Location: ~Brussels - Belgique

PostPosted: Tue Oct 13, 2009 8:17 am    Post subject: Reply with quote

Salut,

Apparemment, ça ressemble à un problème d'alimentation USB. Essaie un autre port, USB, ou alimente-le.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
prunkdump
n00b
n00b


Joined: 28 Apr 2009
Posts: 25
Location: France, Bordeaux

PostPosted: Tue Oct 13, 2009 8:35 am    Post subject: Reply with quote

Bravo! et quelle rapidité!

Oui c'est bien un problème d'alimentation USB. Sur le cordon de mon disque dur il y à deux usbs, un pour l'alimentation et un pour le transfert. En brachant celui de transfert sur mon PC et celui d'alimentation sur un portable ça marche!

Je vais essayer de voir le problème de mon PC. Un problème d'alimentation ne peut pas venir d'une configuration logicielle si je me trompe pas? Donc c'est forcément un des ports (de mon pc) qui est cassé?


Merci encore!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8109
Location: ~Brussels - Belgique

PostPosted: Tue Oct 13, 2009 8:39 am    Post subject: Reply with quote

Salut,

Certains ports USB ne sont pas assez puissants. Il arrive que sur certains PC, seuls quelques-uns aient assez de puissance, alors que d'autre sous sous-alimentés.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
prunkdump
n00b
n00b


Joined: 28 Apr 2009
Posts: 25
Location: France, Bordeaux

PostPosted: Tue Oct 13, 2009 8:47 am    Post subject: Reply with quote

Oui c'est ça. Avec une ralonge j'ai réussi à connecter le cable d'alimentation sur un autre usb de mon pc tout en laissant l'autre sur l'USB2 et là ça marche....
Je n'aurais jamais pensé à ça....

Un grand merci et bonne continuation!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8109
Location: ~Brussels - Belgique

PostPosted: Tue Oct 13, 2009 8:48 am    Post subject: Reply with quote

PS: pense à mettre le titre en convention avec le sous-forum ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Tue Oct 13, 2009 10:38 am    Post subject: Reply with quote

XavierMiller wrote:
Salut,

Apparemment, ça ressemble à un problème d'alimentation USB. Essaie un autre port, USB, ou alimente-le.



+1

j'ai déjà eu ce souci avec un disque 2,5" usb
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum