Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ALSA] n'arrive pas à configurer [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
xelif
Apprentice
Apprentice


Joined: 16 Jan 2006
Posts: 152

PostPosted: Sat Oct 10, 2009 11:17 am    Post subject: [ALSA] n'arrive pas à configurer [Solved] Reply with quote

Bonjour à tous

je viens de réinstaller mon pc portable, et je n'arrive plus configurer le son avec alsa

j'ai suivi ce tutoriel http://www.gentoo.org/doc/fr/alsa-guide.xml

j'arrive à avoir du son en utilisant la sortie oss de audacious par exemple mais pour la sortie alsa ca ne marche pas

voici la sortie de la commande pour aplay :
Code:
 
aplay ./un_fichier_son.wav
ALSA lib pcm_dmix.c:977:(snd_pcm_dmix_open) unable to create IPC semaphore
aplay: main:608: audio open error: Fonction non implantée


pensant à une erreur sur alsa-utils j'ai essayé de le réinstaller sans succès

le module noyau de ma carte son est chargé correctement

Code:

lsmod

Module                  Size  Used by
snd_seq_dummy           2488  0
snd_seq_oss            28320  0
snd_seq_midi_event      6420  1 snd_seq_oss
snd_seq                48464  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          6272  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37632  0
snd_mixer_oss          16468  1 snd_pcm_oss
lib80211_crypt_wep      3732  1
snd_intel8x0           30032  1
snd_ac97_codec        100404  1 snd_intel8x0
ac97_bus                1364  1 snd_ac97_codec
snd_pcm                63612  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              20952  2 snd_seq,snd_pcm
snd                    52132  11 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
ipw2200               143008  0
libipw                 27480  1 ipw2200
intel_agp              26300  0
agpgart                30948  1 intel_agp
lib80211                5684  3 lib80211_crypt_wep,ipw2200,libipw
soundcore               6592  1 snd
snd_page_alloc          8220  2 snd_intel8x0,snd_pcm


rien de très important n'apparait dans dmesg :
Code:

[    7.011045] intel8x0_measure_ac97_clock: measured 50308 usecs (2425 samples)
[    7.011052] intel8x0: clocking to 48000


j'utilise la noyau gentoo-sources-2.6.30-r6

est ce que quelqu'un aurait une idée du problème? ce qui me perturbe c'est le son qui marche en oss mais pas avec alsa... :s

merci d'avance pour votre précieuse aide

XeliF


Last edited by xelif on Tue Oct 13, 2009 1:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
xelif
Apprentice
Apprentice


Joined: 16 Jan 2006
Posts: 152

PostPosted: Sat Oct 10, 2009 1:22 pm    Post subject: Reply with quote

re-bonjour les gens ^^

bon ben j'ai pas tout compris, je suppose qu'il devait y avoir un conflit dans mon .config
j'ai donc appelé mr propre
Code:

make mrproper


reconfiguré mon noyau et ca marche

désolé pour le dérangement
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum