Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Problemi con bluez bluez-utils e bluez-libs
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 10, 2009 9:09 am    Post subject: [RISOLTO] Problemi con bluez bluez-utils e bluez-libs Reply with quote

Se installo bluez, e faccio un revdep-rebuild mi vuole reinstallare bluez-libs e bluez-utils, e viceversa.
Cane che si morde la coda.

Come uscirne?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered


Last edited by fbcyborg on Sun Oct 11, 2009 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Oct 10, 2009 11:17 am    Post subject: Reply with quote

Con le dipendenze sei a posto? Magari hai qualche pacchetto che richiama i pacchetti in questione e ti basta aggiornarlo ad una versione testing-
Prova a mascherare bluez-libs e bluez-utils, io non ricordo problemi del genere ma magari ottieni l'effetto sperato.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 10, 2009 11:52 am    Post subject: Reply with quote

No, se li maschero, non va bene.
:(

Quella che pensavo io era la seguente cosa: forse o installi bluez o bluez-utils e bluez-lib. Ma evidentemente non è così.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Oct 10, 2009 5:27 pm    Post subject: Reply with quote

Certo che è così, dall'ebuild di bluez:
Code:
CDEPEND="alsa? ( media-libs/alsa-lib )
        gstreamer? (
                >=media-libs/gstreamer-0.10
                >=media-libs/gst-plugins-base-0.10 )
        usb? ( dev-libs/libusb )
        cups? ( net-print/cups )
        sys-fs/udev
        dev-libs/glib
        sys-apps/dbus
        media-libs/libsndfile
        >=dev-libs/libnl-1.1
        !net-wireless/bluez-libs
        !net-wireless/bluez-utils"
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 10, 2009 5:55 pm    Post subject: Reply with quote

Il problema credo che sia btsco.
Non riesco però a trovare un ebuild di btsco che non necessiti di bluez-lib e bluez-utils.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
oRDeX
Veteran
Veteran


Joined: 19 Oct 2003
Posts: 1308
Location: world

PostPosted: Sat Oct 10, 2009 7:34 pm    Post subject: Reply with quote

quindi da quanto ho capito il sistema prevede
bluez XOR (bluez-utils & bluez-libs).
Tu hai bluez di tuo ma vuoi installare btsco che usa l'altra coppia...Corretto?
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sat Oct 10, 2009 10:00 pm    Post subject: Reply with quote

No a me non importa se viene installato bluez o la coppia, l'importante è che si sblocchi.
A quanto ho capito bluez ha rimpiazzato "la coppia", ma btsco la vuole ancora.
btsco vuole bluez-utils. bluez-utils vuole bluez-lib. E bluez è richiesto da altri pacchetti:
Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'net-wireless/bluez-libs-3.36', 'merge') pulled in by
    net-wireless/bluez-libs required by ('installed', '/', 'net-wireless/ussp-push-0.9', 'nomerge')
    >=net-wireless/bluez-libs-3.36 required by ('ebuild', '/', 'net-wireless/bluez-utils-3.36', 'merge')

  ('installed', '/', 'net-wireless/bluez-4.39-r2', 'nomerge') pulled in by
    net-wireless/bluez required by ('ebuild', '/', 'kde-base/solid-4.3.1', 'merge')
    net-wireless/bluez required by ('installed', '/', 'net-libs/libpcap-1.0.0-r2', 'nomerge')
    net-wireless/bluez required by ('installed', '/', 'gnome-base/gvfs-1.2.3', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'net-wireless/bluez-utils-3.36', 'merge') pulled in by
    >=net-wireless/bluez-utils-2.19 required by ('ebuild', '/', 'net-wireless/btsco-0.41', 'merge')


O si trova un ebuild di btsco che richiede solo bluez, oppure sono costretto a disinstallarlo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 11, 2009 12:48 am    Post subject: Reply with quote

Il problema è che btsco è deprecato, oltre al fatto che usa il vecchio stack bluetooth sul kernel, che per di più andrebbe patchato.

Usa il nuovo metodo di alsa che usa .asoundrc per connettersi a un device audio bluetooth.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 11, 2009 7:57 am    Post subject: Reply with quote

Ah, ottimo.
Infatti il mio kernel è patchato.
Allora lo rimuovo volentieri se c'è un'alternativa. Ma per caso mi puoi segnalare un howto dove spiega come usare il nuovo metodo alsa di cui parli?

Grazie.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 11, 2009 10:12 am    Post subject: Reply with quote

Rimossi btsco btsco-kernel, e aggiornato ussp-push alla versione 0.9-r1, e il blocco si è risolto.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 11, 2009 10:27 am    Post subject: Reply with quote

fbcyborg wrote:
Ma per caso mi puoi segnalare un howto dove spiega come usare il nuovo metodo alsa di cui parli?

Grazie.

http://wiki.bluez.org/wiki/HOWTO/AudioDevices

Per qualunque cosa, chiedi pure. Io sono diventato scemo a capirlo all'inizio.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Sun Oct 11, 2009 10:29 am    Post subject: Reply with quote

Grazie ancora, troppo gentile, appena faccio questa cosa ci provo.

Ora mi tocca un bell'aggiornamento di sistema.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Thu Nov 12, 2009 7:21 pm    Post subject: Reply with quote

Io ho un problema simile.
Il bluetooth di kde4 funziona con i due pacchetti ma non con bluez.
Ma quando aggiorno mi dice:
Quote:
emerge -uDNva world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] net-wireless/bluez-4.39-r2 USE="alsa cups gstreamer old-daemons usb -consolekit -debug -doc -test-programs" 0 kB
[blocks B ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-utils-3.36, net-wireless/bluez-libs-3.36)
[blocks B ] net-wireless/bluez-utils ("net-wireless/bluez-utils" is blocking net-wireless/bluez-4.39-r2)
[blocks B ] net-wireless/bluez-libs ("net-wireless/bluez-libs" is blocking net-wireless/bluez-4.39-r2)

Total: 1 package (1 new), Size of downloads: 0 kB
Conflict: 3 blocks (3 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'net-wireless/bluez-utils-3.36', 'nomerge') pulled in by
net-wireless/bluez-utils required by world

('installed', '/', 'net-wireless/bluez-libs-3.36', 'nomerge') pulled in by
net-wireless/bluez-libs required by ('installed', '/', 'app-mobilephone/obexftp-0.23-r1', 'nomerge')
net-wireless/bluez-libs required by ('installed', '/', 'dev-libs/openobex-1.5', 'nomerge')
>=net-wireless/bluez-libs-3.36 required by ('installed', '/', 'net-wireless/bluez-utils-3.36', 'nomerge')

('ebuild', '/', 'net-wireless/bluez-4.39-r2', 'merge') pulled in by
>=net-wireless/bluez-4.31 required by ('installed', '/', 'app-mobilephone/obex-data-server-0.4.4', 'nomerge')
net-wireless/bluez required by ('installed', '/', 'kde-base/solid-4.3.1', 'nomerge')
net-wireless/bluez required by ('installed', '/', 'gnome-base/gvfs-1.2.3', 'nomerge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Nov 12, 2009 7:26 pm    Post subject: Reply with quote

Anche io avevo quel problema.

In pratica o installi bluez o bluez-utils. Io attualmente ho rimosso tutti i pacchetti, come obexftp ad esempio, visto che non li uso. Ora quindi ho installato solo bluez.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Thu Nov 12, 2009 10:08 pm    Post subject: Reply with quote

Io invece ho appena "risolto" tenendo bluez e mettendo il mio utente nel gruppo plugdev.

Ma qual'è il pacchetto per esplorare il telefonino come fosse una pendrive?
Funzionava tutto su kde3! bastava un click sull'icona in systray e potevo esplorare con konqueror.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Nov 12, 2009 10:10 pm    Post subject: Reply with quote

Credo proprio che si tratti dell'accoppiata openobex + obexftp.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Thu Nov 12, 2009 10:14 pm    Post subject: Reply with quote

e sono installati:
Quote:
eix obex
* app-mobilephone/cobex
Available versions: 0.2.13
Homepage: http://cobex.sourceforge.net/
Description: small implementation of Obex for phones using the DCU-11 USB-to-serial adapter

[I] app-mobilephone/obex-data-server
Available versions: ~0.1 0.3 ~0.3.2 ~0.3.4 0.4.4 {debug gtk imagemagick usb}
Installed versions: 0.4.4(00:26:30 11/11/2009)(usb -debug -gtk -imagemagick)
Homepage: http://tadas.dailyda.com/blog/category/obex-data-server/
Description: A DBus service providing easy to use API for using OBEX

[I] app-mobilephone/obexftp
Available versions: 0.22 ~0.23 0.23-r1 {bluetooth debug perl python ruby swig tcl}
Installed versions: 0.23-r1(00:27:25 11/11/2009)(bluetooth perl python -debug -ruby -swig -tcl)
Homepage: http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp
Description: File transfer over OBEX for mobile phones

* app-mobilephone/sobexsrv
Available versions: 1.0.1 {gtk}
Homepage: http://www.mulliner.org/bluetooth/sobexsrv.php
Description: Scripting/Secure OBEX Server (for BlueZ Linux)

[I] dev-libs/openobex
Available versions: 1.3 ~1.4 1.5 {bluetooth debug irda syslog usb}
Installed versions: 1.5(00:26:02 11/11/2009)(bluetooth usb -debug -irda -syslog)
Homepage: http://sourceforge.net/projects/openobex/
Description: An implementation of the OBEX protocol used for transferring data to mobile devices

* gnome-extra/gnome-vfs-obexftp
Available versions: 0.4
Homepage: http://www.gnome.org
Description: OBEX FTP Client for GNOME-VFS

* sys-fs/obexfs
Available versions: 0.11 ~0.12
Homepage: http://dev.zuckschwerdt.org/openobex/wiki/ObexFs
Description: FUSE filesystem interface for ObexFTP

Found 7 matches.

_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Nov 12, 2009 10:20 pm    Post subject: Reply with quote

Purtroppo non ricordo esattamente come si fa, comunque a grandi linee si doveva configurare l'rfcomm.conf e una volta fatto il pairing del dispositivo, si usava il file manager (a suo tempo era konqueror) e si doveva digitare l'URL del dispositivo in un modo simile a questo: obex://macaddress:canale .
A questo punto potevo fare il browsing del dispositivo.

C'è una guida da qualche parte nel forum che ora non trovo.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Nov 13, 2009 12:21 am    Post subject: Reply with quote

app-mobilephone/obex-data-server
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2410
Location: イタリアのロディで

PostPosted: Fri Nov 13, 2009 7:08 am    Post subject: Reply with quote

riverdragon wrote:
app-mobilephone/obex-data-server


E' installato.
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum