Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libdvdread: Can't seek to block
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 08 Oct 2009
Posts: 5
Location: INTERNET!

PostPosted: Fri Oct 09, 2009 1:54 am    Post subject: libdvdread: Can't seek to block Reply with quote

I have been having this persistent problem for a while now. I can't seem to pinpoint it, but Googling seems to reveal several things:
* That my user can't access /dev/dvd (that doesn't exist)
* That my software needs updating.
I chose to play a region-free DVD I have (Negativland's Our Favorite Things). The DVD is pristine, almost new, and works fine in standalone players. I've tried this with a couple other DVDs I rented, to similar effect. Should this require a bug report, I'll file one. This is what I see after a few chapters/titles.

[0xf92dd8] libmpeg2 decoder error: DpbUnlinkPicture called on an invalid picture
libdvdread: Can't seek to block 524288
QPainter::begin: Paint device returned engine == 0, type: 1

I have the following software playing my DVDs on this tower:
VLC 1.0.2 (I had issues with the unstable, so I masked it)
mplayer 1.0_rc4_p20090919-r2

emerge --info:
Portage (default/linux/amd64/2008.0/desktop, gcc-4.3.4, glibc-2.10.1-r0, 2.6.31-gentoo x86_64)
System uname: Linux-2.6.31-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E4600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 03 Oct 2009 16:45:01 +0000
app-shells/bash: 4.0_p33
dev-java/java-config: 1.3.7-r1, 2.1.9-r1
dev-lang/python: 2.4.6, 2.5.4-r3, 2.6.2-r2, 3.1.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake: 2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.4.3-r5
sys-apps/sandbox: 2.1
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils: 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mtune=core2"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=core2 -mtune=core2"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/layman/gnome /usr/local/portage/layman/gnash-cvs /usr/local/portage/layman/graaff /usr/local/portage/layman/sunrise /usr/local/portage/layman/pro-audio /usr/local/portage/layman/sabayon /usr/local/portage/layman/ruby /usr/local/portage/Channel6"
USE="X a52 aac ac3 acl acpi alsa amd64 aspell automount avahi bash-completion berkdb branding bzip2 cairo cdda cddax cdr cleartype cli consolekit cracklib crypt css curl dbus dirac dri dts dvd dvdr eds emboss encode evo fam fbcondecor ffmpeg firefox flac fortran gdbm gif gimp glitz gnome gnome-keyring gnutls gpm gstreamer gtk hal iconv imagemagick ipv6 isdnlog jack java jpeg lame lcms ldap libnotify live lm_sensors mad man matroska md5sum mdns-responder mikmod mmx modules mono mp3 mp4 mpeg mudflap multilib musepack nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl pidgin png ppds pppd python qt3support quicktime readline reflection sdl session smp spell spl sqlite sse sse2 ssl ssse3 startup-notification svg sysfs tcl tcpd theora threads thunar thunderbird tiff tk truetype unicode usb vim-syntax vorbis x263 x264 xml xorg xprint xulrunner xv xvid zeroconf zlib" ALSA_CARDS="intel-hda" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="i810 intel"

/dev/sda1 /boot ext2 noauto,noatime 1 2
/dev/sda3 / ext3 noatime 0 1
/dev/sda2 none swap sw 0 0
/dev/sr0 /mnt/cdrom auto noauto,ro,user,users 0 0
Back to top
View user's profile Send private message

Joined: 08 Oct 2009
Posts: 5
Location: INTERNET!

PostPosted: Sat Oct 10, 2009 5:06 pm    Post subject: Reply with quote

I hate to bump my own thread, but the problem is solved.
I updated to 2.6.31-gentoo-r2 kernel, and the problem seems to be fixed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum