Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
glibc downgrade?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 751

PostPosted: Tue Oct 06, 2009 5:59 pm    Post subject: glibc downgrade? Reply with quote

Today's emerge --sync brought some interesting problems.

Quote:

# emerge -upD world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] x11-base/xorg-drivers-1.6 INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -citron -elographics -fpit -hyperpen -joystick -mutouch -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="nv nvidia vesa vmware -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 (-impact) -imstt -intel -mach64 -mga -neomagic (-newport) -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vermilion -via -virtualbox (-voodoo) -xgi"
[ebuild U ] x11-misc/util-macros-1.3.0 [1.2.1]
[ebuild U ] x11-proto/xproto-7.0.15 [7.0.14]
[ebuild U ] x11-proto/inputproto-1.5.1 [1.5.0]
[ebuild U ] x11-proto/randrproto-1.3.0 [1.2.2]
[ebuild U ] x11-libs/pixman-0.16.0 [0.14.0-r1]
[ebuild U ] x11-libs/libdrm-2.4.13 [2.4.5]
[ebuild U ] x11-proto/damageproto-1.2.0 [1.1.0]
[ebuild U ] x11-proto/fontsproto-2.1.0 [2.0.2]
[ebuild U ] x11-proto/videoproto-2.3.0 [2.2.2]
[ebuild U ] x11-proto/dri2proto-2.1 [1.99.3]
[ebuild U ] x11-libs/libpciaccess-0.10.6 [0.10.5]
[ebuild U ] x11-proto/resourceproto-1.1.0 [1.0.2]
[ebuild U ] x11-libs/libICE-1.0.5 [1.0.4]
[ebuild U ] x11-libs/libXau-1.0.5 [1.0.4]
[ebuild U ] x11-proto/xextproto-7.0.5 [7.0.4]
[ebuild U ] x11-libs/libFS-1.0.2 [1.0.0]
[ebuild U ] x11-libs/libSM-1.1.1 [1.1.0] USE="uuid%*"
[ebuild U ] sys-apps/coreutils-7.5 [7.4]
[ebuild U ] x11-proto/xcb-proto-1.5 [1.1]
[ebuild U ] x11-libs/libxcb-1.4-r1 [1.1] USE="(-selinux)"
[ebuild U ] x11-libs/libX11-1.2.2 [1.1.5]
[ebuild U ] app-admin/eselect-opengl-1.0.8-r1 [1.0.6-r1]
[ebuild U ] x11-libs/xcb-util-0.3.6 [0.3.3]
[ebuild U ] x11-libs/libXext-1.0.5 [1.0.4]
[ebuild U ] x11-libs/libXt-1.0.6 [1.0.5]
[ebuild UD] sys-libs/glibc-2.5-r4 [2.9_p20081201-r2] USE="nptl%* nptlonly%* -build% -glibc-compat20%"
[ebuild U ] x11-proto/glproto-1.4.10 [1.4.9]
[ebuild N ] x11-apps/xwud-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xcmsdb-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xrefresh-1.0.2 USE="-debug"
[ebuild U ] app-portage/mirrorselect-2.0.0 [1.4.2]
[ebuild U ] x11-libs/libXrandr-1.3.0 [1.2.3]
[ebuild U ] x11-apps/xkbcomp-1.1.0 [1.0.5]
[ebuild U ] x11-libs/libXfont-1.4.0 [1.3.4]
[ebuild U ] x11-apps/setxkbmap-1.1.0 [1.0.4]
[ebuild N ] x11-apps/xkbevd-1.0.2 USE="-debug"
[ebuild U ] x11-libs/libXaw-1.0.6 [1.0.5]
[ebuild N ] x11-apps/xcursorgen-1.0.2
[ebuild N ] x11-apps/smproxy-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xinput-1.4.2 USE="-debug"
[ebuild N ] x11-apps/x11perf-1.5 USE="-debug"
[ebuild N ] x11-apps/xgamma-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xpr-1.0.2 USE="-debug"
[ebuild U ] x11-apps/xrandr-1.3.2 [1.2.3]
[ebuild N ] x11-apps/xsetmode-1.0.0 USE="-debug"
[ebuild N ] x11-apps/xsetroot-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xbacklight-1.1 USE="-debug"
[ebuild N ] x11-apps/xkill-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xlsclients-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xlsatoms-1.0.1 USE="-debug"
[ebuild N ] x11-apps/xwd-1.0.2 USE="-debug"
[ebuild N ] x11-apps/xf86dga-1.0.2 USE="-debug"
[ebuild N ] media-fonts/font-xfree86-type1-1.0.1 USE="X"
[ebuild N ] media-fonts/font-adobe-utopia-100dpi-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-ibm-type1-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-daewoo-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-micro-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-ttf-1.0.0 USE="X"
[ebuild N ] media-fonts/font-misc-ethiopic-1.0.0-r1 USE="X"
[ebuild N ] media-fonts/font-sony-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-adobe-utopia-75dpi-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-speedo-1.0.0 USE="X"
[ebuild N ] media-fonts/font-screen-cyrillic-1.0.1 USE="X nls"
[ebuild N ] media-fonts/font-jis-misc-1.0.0 USE="X nls"
[ebuild N ] x11-themes/xcursor-themes-1.0.1
[ebuild N ] media-fonts/font-misc-meltho-1.0.0 USE="X"
[ebuild N ] media-fonts/font-misc-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-75dpi-1.0.0 USE="X nls"
[ebuild N ] x11-apps/bitmap-1.0.3-r1 USE="-debug"
[ebuild N ] media-fonts/font-arabic-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-100dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-isas-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-75dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-cronyx-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-mutt-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-sun-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-schumacher-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bitstream-type1-1.0.0 USE="X"
[ebuild N ] media-fonts/font-bh-lucidatypewriter-100dpi-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-winitzki-cyrillic-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-dec-misc-1.0.0 USE="X nls"
[ebuild N ] media-fonts/font-bh-100dpi-1.0.0 USE="X nls"
[ebuild N ] x11-apps/xkbutils-1.0.1-r1 USE="-debug"
[ebuild N ] media-fonts/font-bh-lucidatypewriter-75dpi-1.0.0 USE="X nls"
[ebuild U ] x11-apps/xfs-1.1.0-r1 [1.0.8] USE="-doc% -syslog% -xinetd%"
[ebuild U ] x11-terms/xterm-243 [242]
[ebuild U ] media-libs/mesa-7.5.1 [7.3-r1] VIDEO_CARDS="-radeonhd%"
[ebuild N ] media-libs/glew-1.5.1
[ebuild N ] x11-apps/xdriinfo-1.0.2 USE="-debug"
[ebuild U ] x11-apps/mesa-progs-7.5.1 [7.3]
[ebuild U ] dev-python/pygame-1.9.1 [1.8.1] USE="X%*"
[ebuild U ] x11-misc/xkeyboard-config-1.6 [1.5]
[ebuild U ] x11-base/xorg-server-1.6.3.901-r2 [1.5.3-r6]
[ebuild U ] x11-drivers/xf86-video-nv-2.1.14 [2.1.12]
[ebuild U ] x11-drivers/xf86-video-vmware-10.16.7 [10.16.5]
[ebuild U ] x11-drivers/xf86-input-evdev-2.2.5 [2.1.3]
[ebuild U ] x11-drivers/xf86-video-vesa-2.2.1 [2.2.0]
[ebuild U ] x11-drivers/xf86-input-synaptics-1.1.3 [1.0.0]
[ebuild U ] x11-base/xorg-x11-7.4-r1 [7.2]
[ebuild U ] x11-drivers/xf86-video-dummy-0.3.2 [0.3.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/glibc:2.2

('ebuild', '/', 'sys-libs/glibc-2.5-r4', 'merge') pulled in by
>=sys-libs/glibc-2.3[nptl] required by ('installed', '/', 'x11-drivers/nvidia-drivers-185.18.31', 'nomerge')
(and 6 more)

('installed', '/', 'sys-libs/glibc-2.9_p20081201-r2', 'nomerge') pulled in by
>=sys-libs/glibc-2.6 required by ('installed', '/', 'sys-devel/gcc-4.3.2-r3', 'nomerge')
>=sys-libs/glibc-2.7 required by ('installed', '/', 'sys-libs/pam-1.1.0', 'nomerge')
(and 6 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


What's the best strategy for dealing with the glibc downgrade without potentially lobotomizing my system? Or should I keep the existing version?
Back to top
View user's profile Send private message
Mike Hunt
Watchman
Watchman


Joined: 19 Jul 2009
Posts: 5287

PostPosted: Tue Oct 06, 2009 6:11 pm    Post subject: Reply with quote

Do not downgrade glibc.

unmerge nvidia-drivers for now, then re-emerge it later after the world update.
Back to top
View user's profile Send private message
Mikkl
n00b
n00b


Joined: 12 Jan 2006
Posts: 71

PostPosted: Tue Oct 06, 2009 6:25 pm    Post subject: Reply with quote

same here, too.
I don't think downgrading is a good option, since gcc needs >=glibc-2.6 and there is only a glibc <glibc-2.6 (glibc-2.5-r4) with nptl use-flag
and i won't switch to an older gcc version because of that.
But somehow I feel that this is really strange and there is no comfortable solution at all but to wait until it hopefully resolves itself with another emerge --sync on another day.
I think I'll better leave it alone for now.
Back to top
View user's profile Send private message
wu-s
n00b
n00b


Joined: 22 May 2006
Posts: 41

PostPosted: Tue Oct 06, 2009 6:44 pm    Post subject: Reply with quote

same here, too.

but "hopefully resolves itself"..? what needs to be done to fix this issue?

i unmerged nvidia-drivers, just to find myself in big trouble: "emerge --update --deep --ask --newuse world" will pull the drivers in again and with them glibc-2.5-r4!!

so, when i would dare to reboot the box, it will not come up with X as the drivers are gone... :-((( !!!!!!!!
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue Oct 06, 2009 6:48 pm    Post subject: Reply with quote

@wu-s try this:

Code:

emerge -pvO nvidia-drivers nvidia-settings
Back to top
View user's profile Send private message
Luud
Apprentice
Apprentice


Joined: 05 Jun 2003
Posts: 246
Location: Netherlands

PostPosted: Tue Oct 06, 2009 7:00 pm    Post subject: Reply with quote

It seems the nvidia drivers need glibc to be build with the nptl use flag, however, glibc in newer versions seems not to use the nptl use flag any more.

Based on the dependency list, I think the IUSE="nptl" needs to be added back to the glibc ebuild until the other packages can deal with it not having it anymore. This might also be just a bug in the glibc ebuild. Of course, the other packages might well need updating to the new situation.

A bug has been filed for this issue: https://bugs.gentoo.org/show_bug.cgi?id=287938
_________________
"Great minds don't think alike. If they did, the patent office would only have about fifty inventions." - Wally
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Tue Oct 06, 2009 7:03 pm    Post subject: Reply with quote

I have the same problem. Looks like there is some change, caused that the nptl USE flag is not shown:

Code:
emerge: there are no ebuilds built with USE flags to satisfy ">=sys-libs/glibc-2.3[nptl]".
!!! One of the following packages is required to complete your request:
- sys-libs/glibc-2.10.1 (Missing IUSE: nptl)
(dependency required by "x11-drivers/nvidia-drivers-190.36" [installed])
(dependency required by "media-video/nvidia-settings-185.18.31" [installed])


From the ebuild:
Code:
LT_VER=""                                      # version of linuxthreads addon
NPTL_KERN_VER=${NPTL_KERN_VER:-"2.6.9"}        # min kernel version nptl requires
#LT_KERN_VER=${LT_KERN_VER:-"2.4.1"}           # min kernel version linuxthreads requires

IUSE="debug gd glibc-omitfp hardened multilib nls selinux profile vanilla crosscompile_opts_headers-only ${LT_VER:+glibc-compat20 nptl nptlonly}"
S=${WORKDIR}/glibc-${RELEASE_VER}${SNAP_VER:+-${SNAP_VER}}
Back to top
View user's profile Send private message
boomslang
n00b
n00b


Joined: 03 Jun 2007
Posts: 48

PostPosted: Tue Oct 06, 2009 7:12 pm    Post subject: Reply with quote

Experiencing the same problem; subscribing to the thread to get notification of fix when it occurs.

In the meantime, I did
Code:
emerge -pvO nvidia-drivers
with successful completion, will test later.
Back to top
View user's profile Send private message
mack1
Guru
Guru


Joined: 18 Mar 2006
Posts: 315

PostPosted: Tue Oct 06, 2009 7:20 pm    Post subject: Reply with quote

I removed "[nptl]" from the ebuild (line 27) and now it works fine :D :

Code:

COMMON="<x11-base/xorg-server-1.6.99
   elibc_glibc? ( >=sys-libs/glibc-2.3 )


Ciao
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Tue Oct 06, 2009 7:23 pm    Post subject: Reply with quote

The bug was quickly solved.

Quote:
------- Comment #3 From Justin Lecher (jlec) 2009-10-06 19:19:00 0000 [reply] -------

*** Bug 287940 has been marked as a duplicate of this bug. ***


I patched nvidia-drivers ebuild according to https://bugs.gentoo.org/show_bug.cgi?id=286961#c5 and issue was solved.
Back to top
View user's profile Send private message
red-wolf76
l33t
l33t


Joined: 13 Apr 2005
Posts: 714
Location: Rhein-Main Area

PostPosted: Tue Oct 06, 2009 7:35 pm    Post subject: Reply with quote

Yes, I think all glibc versions over a certain version automatically use nptl exclusively. This makes nvidia-drivers depending on the ntpl USE-flage a bit redundant.
_________________
0mFg, G3nt00 r0X0r$ T3h B1g!1111 ;)

Use sane CFLAGS! If for no other reason, do it for the lulz!
Back to top
View user's profile Send private message
chris...
Apprentice
Apprentice


Joined: 26 Sep 2006
Posts: 179
Location: Melbourne, AU

PostPosted: Tue Oct 06, 2009 10:16 pm    Post subject: Reply with quote

You'll also need to run ebuild on the file you edited, e.g.
Code:
ebuild nvidia-drivers-173.14.20.ebuild digest
Back to top
View user's profile Send private message
alfagamma81
Tux's lil' helper
Tux's lil' helper


Joined: 22 Mar 2009
Posts: 86
Location: Finland

PostPosted: Wed Oct 07, 2009 9:25 am    Post subject: Reply with quote

So what's the correct solution to this? Sorry but there are so many suggestion on this , that i'm confused.. Hard masking older glibc? unmerging nvidia-drivers and then updating?

These are the problems that keep "normal" linux users away from gentoo..
Back to top
View user's profile Send private message
mkyral
Apprentice
Apprentice


Joined: 06 May 2007
Posts: 152
Location: Czech Republic

PostPosted: Wed Oct 07, 2009 11:04 am    Post subject: Reply with quote

@alfagamma81: try to sync portage, should be solved.
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 751

PostPosted: Wed Oct 07, 2009 7:11 pm    Post subject: Reply with quote

Yep, it's all looking good today!

Quote:

06 Oct 2009; Jeroen Roovers <jer@gentoo.org>
nvidia-drivers-71.86.09.ebuild, nvidia-drivers-71.86.11.ebuild,
nvidia-drivers-96.43.09.ebuild, nvidia-drivers-96.43.11.ebuild,
nvidia-drivers-96.43.13.ebuild, nvidia-drivers-173.14.15.ebuild,
nvidia-drivers-173.14.18.ebuild, nvidia-drivers-173.14.20.ebuild,
nvidia-drivers-180.29.ebuild, nvidia-drivers-180.60.ebuild,
nvidia-drivers-185.18.14.ebuild, nvidia-drivers-185.18.29.ebuild,
nvidia-drivers-185.18.31.ebuild, nvidia-drivers-190.18.ebuild,
nvidia-drivers-190.25.ebuild, nvidia-drivers-190.32.ebuild,
nvidia-drivers-190.36.ebuild:
Remove elibc_glibc dependency for now as it breaks horribly.
Back to top
View user's profile Send private message
alfagamma81
Tux's lil' helper
Tux's lil' helper


Joined: 22 Mar 2009
Posts: 86
Location: Finland

PostPosted: Wed Oct 07, 2009 9:36 pm    Post subject: Reply with quote

Too hasty.. again :)

Looking good now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum