Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] MSI BToes usb dongle
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sun Oct 04, 2009 12:34 pm    Post subject: [Risolto] MSI BToes usb dongle Reply with quote

Egregi;
Posseggo un adattatore bluetooth di MSI.

Sto seguendo questa guida
Il device è quindi riconosciuto.
Code:

# cat /proc/bus/usb/devices | grep -e^[TPD] | grep -e Cls=e0 -B1 -A1
T:  Bus=04 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0a5c ProdID=2101 Rev= 0.00

lsusb mi restituisce:
Code:

Bus 004 Device 002: ID 0a5c:2101 Broadcom Corp. A-Link BlueUsbA2 Bluetooth


Premesso che nelle USE flags ho inserito "bluetooth", provando ad emergere cme indicato bluez-utils e bluez-libs, mi da conflitto con
Code:
net-wireless/bluez
      Latest version available: 4.39-r2
      Latest version installed: 4.39-r2

Qui, non so che pensare, ne come proseguire.
Grazie per eventuali consigli.


Last edited by ciro64 on Sat Dec 19, 2009 11:38 pm; edited 3 times in total
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 04, 2009 9:08 pm    Post subject: Reply with quote

Dalla versione 4 il pacchetto bluez rimpiazza bluez-utils e bluez-libs. Quindi se hai già bluez sei a posto.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Sun Oct 04, 2009 9:47 pm    Post subject: Reply with quote

Aggiungi la use "old-daemons".
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 04, 2009 10:05 pm    Post subject: Reply with quote

Apetrini wrote:
Aggiungi la use "old-daemons".

Perché? Non è detto che gli servano. O sbaglio?
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sun Oct 04, 2009 10:19 pm    Post subject: Reply with quote

Grazie per le risposte;
ho aggiunto old-daemons quindi ri-emerso bluez, un /etc/init.d/dbus reload
però.. situazione invariata:
Code:

c2qyt ~ # /etc/init.d/bluetooth restart
* Shutting down Bluetooth...                                                [ok]
* Starting Bluetooth...
*     Starting bluetoothd...                                                [ok]
*     Starting rfcomm...                                                    [ok]
c2qyt ~ # hciconfig
c2qyt ~ #


mi sento ultra-ignorante :( :roll:
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 04, 2009 10:27 pm    Post subject: Reply with quote

Hai installato il firmware?
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sun Oct 04, 2009 10:32 pm    Post subject: Reply with quote

avevo preventivamente installato bluez-firmware
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 04, 2009 10:34 pm    Post subject: Reply with quote

Prova a guardare nei log cosa succede quando avvii il servizio o lanci hciconfig (dmesg o /var/log/messages)
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sun Oct 04, 2009 10:42 pm    Post subject: Reply with quote

Togliendo e reinserendo il dispositivo in dmesg:
Code:
[ 3342.454032] usb 4-2: USB disconnect, address 4
[ 3344.263012] usb 4-2: new full speed USB device using uhci_hcd and address 5
[ 3344.421165] usb 4-2: New USB device found, idVendor=0a5c, idProduct=2101
[ 3344.421169] usb 4-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3344.421172] usb 4-2: Product: BCM92045DG-Flash
[ 3344.421174] usb 4-2: Manufacturer: Broadcom Corp
[ 3344.421279] usb 4-2: configuration #1 chosen from 1 choice

riavviando il servizio bluetooth o hciconfig, nulla in dmesg; (/var/log/messages non c'è 8O )
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sun Oct 04, 2009 10:58 pm    Post subject: Reply with quote

ciro64 wrote:
(/var/log/messages non c'è 8O )

Questo non è molto bello... /var/log/syslog c'è? Hai installato syslog-ng o un qualche logger di sistema?

Controlla in lsmod che sia caricato btusb.
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Mon Oct 05, 2009 11:49 am    Post subject: Reply with quote

Accidenti, quando mi è partito il disco ed ho reinstallato mi son scordato d syslog-ng;
adesso è ok.
Quinid con tail -f /var/log/messages, riavviando bluetooth daemon ottengo:
Code:
Oct  5 13:48:20 c2qyt bluetoothd[367]: Can't remove GN bridge
Oct  5 13:48:20 c2qyt bluetoothd[367]: Stopping SDP server
Oct  5 13:48:20 c2qyt bluetoothd[367]: Exit
Oct  5 13:48:20 c2qyt bluetoothd[447]: Bluetooth daemon 4.39
Oct  5 13:48:20 c2qyt bluetoothd[447]: Starting SDP server
Oct  5 13:48:20 c2qyt bluetoothd[447]: Can't create GN bridge
Oct  5 13:48:20 c2qyt bluetoothd[447]: Starting experimental netlink support
Oct  5 13:48:20 c2qyt bluetoothd[447]: Failed to find Bluetooth netlink family


chiaramente con hciconfig non accade nulla.
in lsmod non c'è ombra di btusb
non so se può servire, comunque:
Code:
lsmod|grep hci
ohci1394               23412  0
ieee1394               51584  2 sbp2,ohci1394
ohci_hcd               18292  0
ssb                    27992  1 ohci_hcd
uhci_hcd               16720  0
ehci_hcd               27320  0
usbcore               101732  8 usblp,sl811_hcd,usbhid,ohci_hcd,uhci_hcd,usb_storage,ehci_hcd
ahci                   27256  0
libata                116524  54 libsas,pdc_adma,sata_inic162x,sata_mv,ata_piix,ahci,sata_qstor,sata_vsc,sata_uli,sata_sis,sata_sx4,sata_nv,sata_via,sata_svw,sata_sil24,
sata_sil,sata_promise,pata_sl82c105,pata_cs5530,pata_cs5520,pata_via,pata_jmicron,pata_marvell,pata_sis,pata_netcell,pata_sc1200,p.....
.....[Cut]......

Restando in tema lsmod:
Code:
# lsmod|grep blu
bluetooth              39524  6 sco,bnep,rfcomm,l2cap
rfkill                 10288  1 bluetooth


(Comunque grazie infinite davvero per tutto l'aiuto che mi state dando)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Mon Oct 05, 2009 2:08 pm    Post subject: Reply with quote

Prova a caricare quel modulo. Su un sito indicava quello come driver richiesto.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Mon Oct 05, 2009 6:50 pm    Post subject: Reply with quote

Siiiiiiiiiiiiii :D
era proprio il modulo btusb
Code:

c2qyt ~ # hciconfig
hci0:   Type: USB
   BD Address: 00:02:72:CA:33:F9 ACL MTU: 1017:8 SCO MTU: 64:8
   UP RUNNING PSCAN
   RX bytes:4721 acl:10 sco:0 events:116 errors:0
   TX bytes:792 acl:10 sco:0 commands:57 errors:0

c2qyt ~ #


Immensamente grazie :):):)

(Gentoo: un gioiello di valore incommensurabile :D; mi piace sempre di più :-P )
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Mon Oct 05, 2009 9:17 pm    Post subject: Reply with quote

Una gentoo è per sempre :P

Aggiungi btusb a /etc/conf.d/modules, se vuoi che lo sia anche lui :D
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Mon Oct 05, 2009 9:39 pm    Post subject: Reply with quote

pierino_89 wrote:
Una gentoo è per sempre :P

Me ne sto rendendo conto :)
Quote:

Aggiungi btusb a /etc/conf.d/modules, se vuoi che lo sia anche lui :D

[/quote]
Fatto; ancora 1000 Grazie.
posso offrire (però solo virtualmente) una birretta
dd if=/dev/pint of=/dev/usb/spina/Pierino_89
Ciao :)
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Thu Dec 17, 2009 12:34 pm    Post subject: Reply with quote

'ngiorno.
riapro la discussione:
il mio dispositivo bluetooth da shell sembra funzionare correttamente.
E' presente
Code:
c2qyt ~ # hciconfig
hci0:   Type: USB
   BD Address: 00:02:72:CA:33:F9 ACL MTU: 1017:8 SCO MTU: 64:8
   UP RUNNING PSCAN
   RX bytes:1296 acl:0 sco:0 events:58 errors:0
   TX bytes:448 acl:0 sco:0 commands:46 errors:0


Per prova... ecco che riconosce il mio antennino gps.
Code:
c2qyt ~ # hcitool scan
Scanning ...
   00:02:76:C5:D2:D4   Nokia LD-3W
c2qyt ~ #
In passato avevo provato con gnome-bluetooth e funzionava.

Ora, provando a riemergerlo, ottengo questo errore.
Code:
 # emerge gnome-bluetooth -pvt

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N    ] net-wireless/gnome-bluetooth-0.9.1  USE="-debug" 547 kB
[ebuild  N    ]  net-wireless/libbtctl-0.11.1  USE="-debug -doc" 325 kB
[ebuild  N    ]   dev-libs/openobex-1.5  USE="bluetooth syslog usb -debug -irda" 392 kB
[ebuild  N    ]  net-wireless/bluez-libs-3.36  USE="-debug" 307 kB
[blocks B     ] net-wireless/bluez ("net-wireless/bluez" is blocking net-wireless/bluez-libs-3.36)

Total: 4 packages (4 new), Size of downloads: 1,569 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('installed', '/', 'net-wireless/bluez-4.39-r2', 'nomerge') pulled in by
    net-wireless/bluez required by ('ebuild', '/', 'dev-libs/openobex-1.5', 'merge')
    >=net-wireless/bluez-4 required by ('ebuild', '/', 'net-wireless/libbtctl-0.11.1', 'merge')

  ('ebuild', '/', 'net-wireless/bluez-libs-3.36', 'merge') pulled in by
    >=net-wireless/bluez-libs-2.25 required by ('ebuild', '/', 'net-wireless/gnome-bluetooth-0.9.1', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Qualcuno saprebbe consigliarmi e "sbrogliare" questa piccola matassa ?
Oppure invece di gnome-bluetooth usare qualcos'altro ?

Grazie per eventuali pensieri.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Fri Dec 18, 2009 11:52 pm    Post subject: Reply with quote

Facilissimo. Rimuovi bluez-libs e bluez-utils e installa buez.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 19, 2009 10:02 am    Post subject: Reply with quote

Sono già in questa situazione:
Code:

net-wireless/bluez-4.39-r2 was built with the following:
USE="alsa consolekit cups gstreamer (multilib) usb -debug -doc -old-daemons -test-programs"

Ho emerso allora bluez-gnome

Ora, se avvio per esempio
Code:
$ bluetooth-wizard

ma anche con bluetooth-properties o bluetooth-browse
ottengo
Sementation fault 8O

mmm forse mi sto perdendo in un bichiere d'acqua... però........ :roll:
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sat Dec 19, 2009 6:28 pm    Post subject: Reply with quote

Le due cose sono slegate fra loro... Hai dato revdep-rebuild dopo aver fatto quello che ti ho detto?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 19, 2009 7:27 pm    Post subject: Reply with quote

Si...
Code:

* Dynamic linking on your system is consistent... All done.
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sat Dec 19, 2009 7:57 pm    Post subject: Reply with quote

Immagino tu abbia riavviato quindi non ti dico di riavviare il servizio. Hcitool funziona?
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 19, 2009 8:27 pm    Post subject: Reply with quote

Innanzitutto infinite grazie Pierino_89 per l'aiuto che mi offri :)

Tornando al problemino, hcitool scan per esempio, sia da root che da user, rileva tranquillamente i dispositivi.

potrebbe interessare che ho presenti sia gnome che kde ?

Edit:
Ho smascherato
Code:

net-wireless/kbluetooth ~0.4-rc2


Funziona alla grande :P
Quindi.. il problema è solo, nel mio caso, relativo a Gnome

Io ci ri-piazzerei un risolto;
Oppure.... provare anche a sistemare l'utility per Gnome ?
Attendo pareri "esperti" :)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 522

PostPosted: Sat Dec 19, 2009 11:24 pm    Post subject: Reply with quote

Beh a questo punto aprirei un nuovo thread per le robe di gnome, se ricompilandole o smandrupandole in qualche modo non si rimettono a funzionare.
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Guru
Guru


Joined: 20 Jun 2009
Posts: 424

PostPosted: Sat Dec 19, 2009 11:43 pm    Post subject: Reply with quote

ok; adesso mi stavo interessando riguardo selinux; poi vedrò per questo problemino.

Grazie ancora per l'aiuto.

comunque Questo OS è davvero unico..... incomparabile, ci ho perso la testa :P
Insomma sul mio pc ho messo Gentoo su un hdd, e funtoo e funtoo ~amd64 su un altro.
Sindrome da compilazione sorgenti ?
Bah... è l'invenzione di genii incredibili.
Sono stupefatto.

Se non mi capiterà di scrivere ancora:
Buon Natale... Buon Anno a tutti.

Ciao

e W Gentoo :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum