Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nVidia is a pain in the A$$
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Sallad_Tosser
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 95
Location: Edmonton

PostPosted: Sun Aug 31, 2003 2:46 am    Post subject: nVidia is a pain in the A$$ Reply with quote

Okay after 6 hours of trying to get this thing to work I broke down and came to the PRO's for help.

Alright I just recently gave my Gentoo box a upgrade from a ATI Mach 64 (Yuk) to a GeForce2 GTS but I cant seem to get the damn thing to work in Xfree86. Here is what I have tried.

Older drivers
Trying different Xfree86Configs
Endless chats with friends with help
Recompiling Kernel
and Xfree86

Here is a log of my Xfree86 trying to load and my Xfree86Config

Code:

XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-gentoo-r2 i686 [ELF]
Build Date: 28 April 2003
   Before reporting problems, check http://www.XFree86.Org/
   to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Aug 30 21:17:43 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "Zoltrix!"
(**) |   |-->Device "NVIDIA GeForce"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "microsoft"
(**) XKB: model: "microsoft"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/local/,/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
Using vt 7
(--) using VT number 7

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
   XFree86 ANSI C Emulation: 0.2
   XFree86 Video Driver: 0.6
   XFree86 XInput driver : 0.4
   XFree86 Server Extension : 0.2
   XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 0000,0000 rev 02 class 06,80,00 hdr 00
(II) PCI: 00:0a:0: chip 10ec,8029 card 1025,0201 rev 00 class 02,00,00 hdr 00
(II) PCI: 00:0b:0: chip 100b,0020 card 1385,f311 rev 00 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 10de,0150 card 1043,4016 rev a4 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
   [0] -1   0   0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
   [0] -1   0   0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
   [0] -1   0   0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0088 (VGA_EN is set)
(II) Bus 1 I/O range:
   [0] -1   0   0x0000c000 - 0x0000cfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
   [0] -1   0   0xede00000 - 0xefefffff (0x2100000) MX[B]
(II) Bus 1 prefetchable memory range:
   [0] -1   0   0xd5c00000 - 0xe5cfffff (0x10100000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:7:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV15 [GeForce2 GTS/Pro] rev 164, Mem @ 0xee000000/24, 0xd8000000/27, BIOS @ 0xefef0000/16
(II) Addressable bus resource ranges are
   [0] -1   0   0x00000000 - 0xffffffff (0x0) MX[B]
   [1] -1   0   0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
   [0] -1   0   0xffe00000 - 0xffffffff (0x200000) MX[B](B)
   [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [5] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [6] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xe8000000 from 0xebffffff to 0xe7ffffff
(II) Active PCI resource ranges:
   [0] -1   0   0xeffff000 - 0xefffffff (0x1000) MX[B]
   [1] -1   0   0xe8000000 - 0xe7ffffff (0x0) MX[B]O
   [2] -1   0   0xefef0000 - 0xefefffff (0x10000) MX[B](B)
   [3] -1   0   0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
   [4] -1   0   0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
   [5] -1   0   0x0000de00 - 0x0000deff (0x100) IX[B]
   [6] -1   0   0x0000dd80 - 0x0000dd9f (0x20) IX[B]
   [7] -1   0   0x0000dd00 - 0x0000dd1f (0x20) IX[B]
   [8] -1   0   0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
   [0] -1   0   0xeffff000 - 0xefffffff (0x1000) MX[B]
   [1] -1   0   0xe8000000 - 0xe7ffffff (0x0) MX[B]O
   [2] -1   0   0xefef0000 - 0xefefffff (0x10000) MX[B](B)
   [3] -1   0   0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
   [4] -1   0   0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
   [5] -1   0   0x0000de00 - 0x0000deff (0x100) IX[B]
   [6] -1   0   0x0000dd80 - 0x0000dd9f (0x20) IX[B]
   [7] -1   0   0x0000dd00 - 0x0000dd1f (0x20) IX[B]
   [8] -1   0   0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
   [0] -1   0   0xffe00000 - 0xffffffff (0x200000) MX[B](B)
   [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [5] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [6] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
   [0] -1   0   0xffe00000 - 0xffffffff (0x200000) MX[B](B)
   [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [5] -1   0   0xeffff000 - 0xefffffff (0x1000) MX[B]
   [6] -1   0   0xe8000000 - 0xe7ffffff (0x0) MX[B]O
   [7] -1   0   0xefef0000 - 0xefefffff (0x10000) MX[B](B)
   [8] -1   0   0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
   [9] -1   0   0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
   [10] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [11] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
   [12] -1   0   0x0000de00 - 0x0000deff (0x100) IX[B]
   [13] -1   0   0x0000dd80 - 0x0000dd9f (0x20) IX[B]
   [14] -1   0   0x0000dd00 - 0x0000dd1f (0x20) IX[B]
   [15] -1   0   0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Server Extension
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 Server Extension
   ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.2
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
(II) Module speedo: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.1
   Module class: XFree86 Font Renderer
   ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
   compiled for 4.0.2, module version = 1.0.4363
   Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 1.0.0
   Module class: XFree86 XInput Driver
   ABI class: XFree86 XInput driver, version 0.4
(II) NVIDIA XFree86 Driver  1.0-4363  Sat Apr 19 17:49:42 PDT 2003
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset NVIDIA GPU found
(II) resource ranges after xf86ClaimFixedResources() call:
   [0] -1   0   0xffe00000 - 0xffffffff (0x200000) MX[B](B)
   [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [5] -1   0   0xeffff000 - 0xefffffff (0x1000) MX[B]
   [6] -1   0   0xe8000000 - 0xe7ffffff (0x0) MX[B]O
   [7] -1   0   0xefef0000 - 0xefefffff (0x10000) MX[B](B)
   [8] -1   0   0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
   [9] -1   0   0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
   [10] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [11] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
   [12] -1   0   0x0000de00 - 0x0000deff (0x100) IX[B]
   [13] -1   0   0x0000dd80 - 0x0000dd9f (0x20) IX[B]
   [14] -1   0   0x0000dd00 - 0x0000dd1f (0x20) IX[B]
   [15] -1   0   0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
(II) resource ranges after probing:
   [0] -1   0   0xffe00000 - 0xffffffff (0x200000) MX[B](B)
   [1] -1   0   0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
   [2] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [3] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [4] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [5] -1   0   0xeffff000 - 0xefffffff (0x1000) MX[B]
   [6] -1   0   0xe8000000 - 0xe7ffffff (0x0) MX[B]O
   [7] -1   0   0xefef0000 - 0xefefffff (0x10000) MX[B](B)
   [8] -1   0   0xd8000000 - 0xdfffffff (0x8000000) MX[B](B)
   [9] -1   0   0xee000000 - 0xeeffffff (0x1000000) MX[B](B)
   [10] 0   0   0x000a0000 - 0x000affff (0x10000) MS[B]
   [11] 0   0   0x000b0000 - 0x000b7fff (0x8000) MS[B]
   [12] 0   0   0x000b8000 - 0x000bffff (0x8000) MS[B]
   [13] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [14] -1   0   0x00000000 - 0x000000ff (0x100) IX[B]
   [15] -1   0   0x0000de00 - 0x0000deff (0x100) IX[B]
   [16] -1   0   0x0000dd80 - 0x0000dd9f (0x20) IX[B]
   [17] -1   0   0x0000dd00 - 0x0000dd1f (0x20) IX[B]
   [18] -1   0   0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
   [19] 0   0   0x000003b0 - 0x000003bb (0xc) IS[B]
   [20] 0   0   0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
   compiled for 4.3.0, module version = 0.1.0
   ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "3"
(**) NVIDIA(0): Use of any AGP requested (try AGPGART, then try NVIDIA's AGP)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xEE000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.



Code:


Section "Module"
    Load        "dbe"     # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

    Load        "type1"
    Load        "speedo"
   #Load        "dri"
   #Load        "glx"
EndSection

Section "Files"

    RgbPath   "/usr/X11R6/lib/X11/rgb"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType/"
#    FontPath   "/usr/X11R6/lib/X11/fonts/freefont/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"

EndSection

Section "ServerFlags"

EndSection

Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "Keyboard"

#    Option     "Protocol"      "Xqueue"

    Option "AutoRepeat" "500 30"

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "microsoft"
    Option "XkbLayout"   "us"

EndSection

Section "InputDevice"

    Identifier   "Mouse1"
    Driver   "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/usbmouse"
    Option "ZAxisMapping"   "4 5"
EndSection

Section "Monitor"

    Identifier  "Zoltrix!"
    HorizSync   30 - 64
    VertRefresh 60 - 75

EndSection


Section "Device"
    Identifier   "NVIDIA GeForce"
    VendorName   "nVidia"
    BoardName   "Unknown"
    Driver     "nvidia"
    #VideoRam   32768
    Option "NvAGP" "3"
    Option "NvLogo" "1"

EndSection


Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA GeForce"
    Monitor     "ZOLTRIX!"
    DefaultDepth 24
   
    Subsection "Display"
        Depth       8
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600"
        ViewPort    0 0
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

 Section "DRI"
    Mode 0666
 EndSection



Please Help I am on my knees begging! Please help before I throw this box off my balcony! :P

Sallad Tosser
_________________
Linux > Windows
Back to top
View user's profile Send private message
SpinDizzy
n00b
n00b


Joined: 28 May 2003
Posts: 63
Location: Moss Vale, Australia

PostPosted: Sun Aug 31, 2003 4:07 am    Post subject: Reply with quote

It looks like it can't find the nvidia kernel module, try re-emerging it.
Back to top
View user's profile Send private message
Sallad_Tosser
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 95
Location: Edmonton

PostPosted: Sun Aug 31, 2003 4:25 am    Post subject: Reply with quote

I did prob about 20 times =\ Its in the right place too I checked.

Sallad Tosser
_________________
Linux > Windows
Back to top
View user's profile Send private message
NicholasDWolfwood
Apprentice
Apprentice


Joined: 19 Jan 2003
Posts: 235

PostPosted: Sun Aug 31, 2003 6:02 am    Post subject: Reply with quote

I've got no problems with a Winfast Geforce2 GTS 32MB on my file server.

My suggestion is to take out the comment on "Load glx" and then try merging the newest nvidia-kernel and nvidia-glx drivers (1.0.4496-r1 at this time)
_________________
AMD Athlon XP 1700+
Abit KG7-RAID
512MB PC2100 DDR266 Corsair/Kingston
40GB WD 7200RPM (37.1GB)
120GB WD 8MB 7200RPM (111GB)
160GB WD 8MB 7200RPM (149GB)
40GB WD 7200RPM (37.1GB)
Pioneer DVR-A06 4x DVD±RW
HP CD-RW 9500i (12x8x32x)
Back to top
View user's profile Send private message
Sallad_Tosser
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 95
Location: Edmonton

PostPosted: Sun Aug 31, 2003 6:11 am    Post subject: Reply with quote

I have done that too =\
_________________
Linux > Windows
Back to top
View user's profile Send private message
Arzie
n00b
n00b


Joined: 23 Oct 2002
Posts: 51
Location: Enschede, The Netherlands

PostPosted: Sun Aug 31, 2003 7:05 am    Post subject: Reply with quote

What does 'modprobe nvidia' give you? And a 'dmesg | tail' afterwards?
Back to top
View user's profile Send private message
Sallad_Tosser
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 95
Location: Edmonton

PostPosted: Sun Aug 31, 2003 4:39 pm    Post subject: Reply with quote

Thx so Much!!!!! it works!!!!!!! And I cant beleive I didnt think to look in my bios =\. You dmesg helped me so much! I owe ya a case of beer mang =D

Yay I get to play Frozen Bubble!

Sallad Tosser
_________________
Linux > Windows
Back to top
View user's profile Send private message
Arzie
n00b
n00b


Joined: 23 Oct 2002
Posts: 51
Location: Enschede, The Netherlands

PostPosted: Sun Aug 31, 2003 5:39 pm    Post subject: Reply with quote

Heh ;) No problem. But the dmesg isn't necessary, just 'nvidia' in your /etc/modules.autoload.
Back to top
View user's profile Send private message
Bar
n00b
n00b


Joined: 21 Jun 2003
Posts: 73

PostPosted: Mon Sep 01, 2003 1:59 am    Post subject: Reply with quote

might be digging up an old topic and you probably wont check back here anyway, but you have
Code:

#Load        "glx"

uncomment that (truth be told im not positive what glx is for but your supposed to load it with nvidia drivers and the docs dont lie)
Back to top
View user's profile Send private message
LockeAverame
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2003
Posts: 108

PostPosted: Mon Sep 01, 2003 7:46 am    Post subject: Reply with quote

and if u use the identifier "Zoltrix!" then use it in every identifier the monitor uses (watch the case sensitivity - not "ZOLTRIX!")
and add nvidia to modules.autoload.
Back to top
View user's profile Send private message
Sallad_Tosser
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jan 2003
Posts: 95
Location: Edmonton

PostPosted: Mon Sep 01, 2003 8:19 pm    Post subject: Reply with quote

Yea I know about the GLX I was just trying different things. And for the Monitor stuff I was just bein funny. The monitor on that machine is a Zoltrix prob the crappiest monitor ever. Still cant figure ot the scanlines for it.

Sallad Tosser
_________________
Linux > Windows
Back to top
View user's profile Send private message
Ahman_Ra
n00b
n00b


Joined: 14 Apr 2003
Posts: 9
Location: greater stlouis mo area

PostPosted: Tue Sep 02, 2003 4:13 am    Post subject: YEAH It works now!!! Reply with quote

Quote:
Thx so Much!!!!! it works!!!!!!! And I cant beleive I didnt think to look in my bios =\. You dmesg helped me so much! I owe ya a case of beer mang =D


This tipped me off, so I went back to BIOS for a little expirementing. I don't cringe in here, so i tried the Pallet Snoop option, AND NOW AM IN AN ACTUAL DESKTOP!! I never get this to work with out the linux pros from work getting into my system. Thanks for the tip that toppled the wall everyone/ :D
Back to top
View user's profile Send private message
the_wolf
n00b
n00b


Joined: 15 Aug 2003
Posts: 18
Location: Norway

PostPosted: Tue Sep 02, 2003 4:25 pm    Post subject: Reply with quote

what did you change in your bios that made it work? :)
having the same problem
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum