Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Che fine ha fatto libxcb-xlib.la ???
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 01, 2009 12:14 pm    Post subject: Che fine ha fatto libxcb-xlib.la ??? Reply with quote

Da qualche versione di libxcb a questa parte è sparito quel file.
Ora sono un po' nel casino perché non riesco né ad aggiornare il sistema né a fare un revdep-rebuild.

Ho già letto i seguenti bug ma ancora non ho capito come risolvere:
Bug1 e Bug2

L'errore che ricevo sempre é:
Code:
libtool: link: cannot find the library `/usr/lib64/libxcb-xlib.la'

Oppure No such file or directory.

Come fare?
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Oct 01, 2009 12:42 pm    Post subject: Reply with quote

Questo aiuta? http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 01, 2009 1:15 pm    Post subject: Reply with quote

Grazie!!!
Una cosa: non capisco perché dovrei rimuovere il file libxcb-xlib.so.0 e simili...
Immagino che non servano più, però la domanda nasce dal seguente fatto: nelle ultime versioni di libxcb, mi ritrovavo solo con libxcb-xlib.so, libxcb-xlib.so.0 e libxcb-xlib.so.0.0.0, mentre mancava appunto il file in oggetto.
La guida all'aggiornamento prevede alcuni passi che ripristinano (a quanto ho capito) il file libxcb-xlib.la. Ma perché cancellare gli altri?
Ad un successivo aggiornamento, non verranno poi ricreati?

Inoltre, vedo che è necessario un
Code:
revdep-rebuild -L libxcb-xlib.so.0

Ma in questo modo non viene installato di nuovo il pacchetto che contiene libxcb-xlib.so.0?
Successivamente poi viene indicato di rimuoverlo...

Qualcosa non mi torna.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Oct 01, 2009 7:16 pm    Post subject: Reply with quote

Il revdep-rebuild -L dovrebbe ricompilare i pacchetti che utilizzano la libreria in questione e non la libreria stessa. Il file va poi rimosso perché
Quote:
until recently, libX11 used a private libxcb library called libxcb-xlib.so, created specifically for libX11. While that is no problem in itself, this tiny library polluted (almost) every single .la file on your system. That's how libtool works.

But this is now turning into a problem since newer versions of libxcb no longer ship this library (and libX11 was fixed accordingly, of course). We now need to get rid of all references to this library within .la files.
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 01, 2009 7:18 pm    Post subject: Reply with quote

Ah ok, ora mi è più chiaro.

Grazie.
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Thu Oct 01, 2009 8:14 pm    Post subject: Reply with quote

Che strano...
dopo un revdep-rebuild senza alcun pacchetto da emergere, facendo:
Code:
rm -i /usr/lib/libxcb-xlib.so*

come dice nella guida, ottengo:
Code:
rm: cannot remove `/usr/lib/libxcb-xlib.so*': No such file or directory

E sembra che non ci sia più nemmeno libxcb-xlib.la.
E' normale??
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Oct 02, 2009 6:57 am    Post subject: Reply with quote

anche a me erano accadute vicende simili, quando ho aggiornato xcb.
credo che questo sia il primo post sull'argomento.

fosse per me, lo avrei trasferito nel forum principale e messo sticky.
probabilmente, per uscirne, è meglio che reinstalli provvisoriamente la vecchia versione di xcb e riavvii la procedura di aggiornamento.

quando ci sono passato, ricordo di avere avuto la necessità di mettere alcuni pacchetti in tilde. non ho capito bene il come e il perché, altrimenti avrei fatto delle segnalazioni su bugzilla.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fbcyborg
Advocate
Advocate


Joined: 16 Oct 2005
Posts: 3056
Location: ROMA

PostPosted: Fri Oct 02, 2009 7:14 am    Post subject: Reply with quote

Grazie ma alla fine ho risolto grazie al consiglio di riverdragon.
riverdragon wrote:
Questo aiuta? http://www.gentoo.org/proj/en/desktop/x/x11/libxcb-1.4-upgrade-guide.xml


Purtroppo il tuo post non l'avevo visto, ma ora che leggo, il problema mi sembra leggermente diverso, anche se relativo alla stessa "roba".
_________________
[HOWTO] Come criptare la /home usando cryptsetup e luks
[HOWTO] Abilitare il supporto al dom0 XEN su kernel 3.X
Help answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum