Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing nodejs on old Gentoo got an error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
ducnguyenvn
n00b
n00b


Joined: 07 May 2016
Posts: 7

PostPosted: Sat May 07, 2016 9:23 am    Post subject: Installing nodejs on old Gentoo got an error Reply with quote

Hi there,

I'm needing to install NodeJS on my server that running gentoo but got an error as below:
Code:

mail portage # emerge net-libs/nodejs


!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)



 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy "net-libs/nodejs" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-libs/nodejs-5.10.1 (masked by: EAPI 6)
- net-libs/nodejs-5.9.1 (masked by: EAPI 6)
- net-libs/nodejs-4.4.1 (masked by: EAPI 5)
- net-libs/nodejs-4.4.0 (masked by: EAPI 5)
- net-libs/nodejs-0.12.10 (masked by: EAPI 5)
- net-libs/nodejs-0.12.7 (masked by: EAPI 5)
- net-libs/nodejs-0.12.6 (masked by: EAPI 5)

The current version of portage supports EAPI '3'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


 * IMPORTANT: 17 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Could you please help me how to fix this error and install NodeJS.

Thanks.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 35844
Location: 56N 3W

PostPosted: Sat May 07, 2016 9:32 am    Post subject: Reply with quote

ducnguyenvn,

Welcome to Gentoo.

Code:
- net-libs/nodejs-4.4.1 (masked by: EAPI 5)
- net-libs/nodejs-4.4.0 (masked by: EAPI 5)
tells that your server has not been updated for several years.

Doing the update will be a challenging educational experience. If you just want to use your server, a reinstall from scratch will be much faster.

If you rent a server with Gentoo on, who from?
It may be that a reinstall of the vendors Gentoo won't help. You need an up to date handbook install.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ducnguyenvn
n00b
n00b


Joined: 07 May 2016
Posts: 7

PostPosted: Sat May 07, 2016 10:02 am    Post subject: Reply with quote

Hi NeddySeagoon,

Thanks for your answer. This server is of a client that give me to work on. So I don't know where he rent it.

So do I need to reinstall Gentoo? If yes, could you please tell me any documentation to do that?


Thanks.
Back to top
View user's profile Send private message
Buffoon
l33t
l33t


Joined: 17 Jun 2015
Posts: 825
Location: EU or US

PostPosted: Sat May 07, 2016 10:15 am    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/Main_Page > Documentation > Gentoo Handbook
Back to top
View user's profile Send private message
ducnguyenvn
n00b
n00b


Joined: 07 May 2016
Posts: 7

PostPosted: Sat May 07, 2016 10:46 am    Post subject: Reply with quote

Hi Buffoon,

So do I have to reinstall Gentoo so that I can install NodeJS?


Thanks
Back to top
View user's profile Send private message
ducnguyenvn
n00b
n00b


Joined: 07 May 2016
Posts: 7

PostPosted: Sat May 07, 2016 11:00 am    Post subject: Reply with quote

Hi Buffoon, NeddySeagoon,

Do you think I can resolve this error by update Gentoo?
If you know any way simpler, please let me know.


Thanks.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 35844
Location: 56N 3W

PostPosted: Sat May 07, 2016 11:38 am    Post subject: Reply with quote

ducnguyenvn,

If you are working for a client, its a waste of a clients money to do the upgrade. A reinstall will be lower cost for the client.

Your problem is that your gentoo install only understands ebuilds (thats gentoo install scrips) written for EAPI <5, at best.
EAPI 5 was introduced several years ago. That's how I can date your install. The present EAPI is 6.

Your old portage does not understand the newer EAPIs, hence your error messages about masked by EAPI ...
In theory, you only need a newer portage. Newer portage will need a newer python but it won't stop there.

Updating Gentoo will resolve the error. Any method that gets you a current portage will work.
Updating is not cost effective for your client.

If that gentoo is really all several years old it has a lot of security vunerabilities, including heart-bleed and shellshock.
Code:
glsa-check -t affected
may be informative/scary.

Code:
# glsa-check -t affected
This system is affected by the following GLSAs:
201408-10
201503-04
201401-23
201401-11
201509-01
201409-03
201403-03
201602-02
201401-14
201402-24
201503-13
201412-34
201509-06
201507-22
201402-25
201509-02
201412-02
201405-15
201404-07
201311-06
201312-02
201512-06
201601-01
201502-07
201502-11
201507-08
201407-04
201405-06
201408-08
201503-10
201410-01
201503-08
201502-14
201406-21
201310-14
201412-48
201401-08
201503-11
201506-02
201601-05
201412-39
201401-04
201605-01
201512-04
201411-05
201507-11
201409-08
201410-02
201407-05
201603-15
201504-02
201412-06
201604-04
201507-15
masterclone ~ # uname -v             
#2 SMP Sun Sep 9 15:28:56 BST 2012

Just as well, that's not an internet facing system - it has known fixed security issues from 2013.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ducnguyenvn
n00b
n00b


Joined: 07 May 2016
Posts: 7

PostPosted: Sat May 07, 2016 1:33 pm    Post subject: Reply with quote

Hi NeddySeagoon,

Thanks so much.
I have run on server you command lines:
Code:

# uname -v
#26 SMP Mon May 17 12:35:34 UTC 2010


And
Code:

# glsa-check -t affected
This system is affected by the following GLSAs:
201410-01
201503-04
201210-05
201311-04
201409-10
201507-16
201409-09
201312-01


This is first time I know about Gentoo, so I don't know how to update it, I have googled around but don't know which documentation i should use for this server. Could you please share me documentation to update portage?


Thanks a lot again.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 35844
Location: 56N 3W

PostPosted: Sat May 07, 2016 1:49 pm    Post subject: Reply with quote

ducnguyenvn,

We know your server kernel was built on Mon May 17 12:35:34 UTC 2010 and from the oldest glsa, 201210-05 it was updated sometime before 5 Oct 2012.
As Gentoo is source based updating such an old system is not just a case a the normal update process. You will need to resolve blocked packages and dependancies for yourself.

You should go back to your client and tell them what you have found. If the server is rented, rent another server, do a whole new install, then migrate everything to the new server. That's in the best interests of your client.
If the server is owned and it seems to be at least six years old, its time to buy a new server anyway.
Either way, be sure the client knows what they are letting themselves in for (a big bill) before you spend any more of their money.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum